source: projects/specs/trunk/p/perl-JSON/perl-JSON-vl.spec @ 8691

Revision 8691, 6.8 KB checked in by iwaim, 10 years ago (diff)

perl-JSON 2.53-3

Line 
1Name:           perl-JSON
2Summary:        Parse and convert to JSON (JavaScript Object Notation)
3Version:        2.53
4Release:        3%{?_dist_release}
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7Source0:        http://search.cpan.org/CPAN/authors/id/M/MA/MAKAMAKA/JSON-%{version}.tar.gz
8URL:            http://search.cpan.org/dist/JSON/
9Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
10BuildArch:      noarch
11
12BuildRequires:  perl(CGI)
13BuildRequires:  perl(ExtUtils::MakeMaker)
14BuildRequires:  perl(HTTP::Daemon)
15BuildRequires:  perl(LWP::UserAgent)
16BuildRequires:  perl(Scalar::Util)
17BuildRequires:  perl(Test::More)
18BuildRequires:  perl(Test::Pod)
19
20Vendor:         Project Vine
21Distribution:   Vine Linux
22Packager:       shaolin
23
24%description
25This module converts between JSON (JavaScript Object Notation) and Perl
26data structure into each other. For JSON, see http://www.crockford.com/JSON/.
27
28%prep
29%setup -q -n JSON-%{version}
30
31# make rpmlint happy...
32find .  -type f -exec chmod -c -x {} +
33find t/ -type f -exec perl -pi -e 's|^#! perl|#!%{__perl}|' {} +
34sed -i 's/\r//' README t/*
35
36%if %{_dist_release} > "vl6"
37%{?perl_default_filter:
38%filter_from_provides /^perl(JSON::\(Backend::PP\|backportPP::Boolean\|Boolean\|PP\|PP::IncrParser\))/d
39%filter_from_requires /^perl(JSON::backportPP)$/d
40%perl_default_filter}
41%global __provides_exclude %{?__provides_exclude:%__provides_exclude|}perl\\(JSON::(Backend::PP|backportPP::Boolean|Boolean|PP|PP::IncrParser)\\)
42%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}perl\\(JSON::backportPP\\)
43
44%{?perl_default_subpackage_tests}
45
46%else
47cat << \EOF > %{name}-prov
48#!/bin/sh
49%{__perl_provides} $* |\
50sed -e '/perl(JSON::\(Backend::PP\|backportPP::Boolean\|Boolean\|PP\|PP::IncrParser\)/d'
51EOF
52
53%global __perl_provides %{_builddir}/JSON-%{version}/%{name}-prov
54chmod +x %{__perl_provides}
55
56
57cat << \EOF > %{name}-req
58#!/bin/sh
59%{__perl_requires} $* |\
60sed -e '/perl(JSON::backportPP)/d'
61EOF
62
63%global __perl_requires %{_builddir}/JSON-%{version}/%{name}-req
64chmod +x %{__perl_requires}
65%endif
66
67%build
68%{__perl} Makefile.PL INSTALLDIRS=vendor
69make %{?_smp_mflags}
70
71%install
72make pure_install DESTDIR=%{buildroot}
73
74find %{buildroot} -type f -name .packlist -exec rm -f {} +
75find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
76
77%{_fixperms} %{buildroot}/*
78
79%check
80make test
81
82%files
83%defattr(-,root,root,-)
84%doc Changes README
85%{perl_vendorlib}/*
86%{_mandir}/man3/*
87
88%changelog
89* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.53-3
90- build with Perl 5.16
91
92* Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.53-2
93- rebuild
94
95* Thu Feb 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.53-1
96- initial build for Vine Linux
97
98* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.53-4
99- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
100
101* Wed Jul 20 2011 Iain Arnell <iarnell@gmail.com> 2.53-3
102- update filtering macros for rpm 4.9
103
104* Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 2.53-2
105- Perl mass rebuild
106
107* Sun May 22 2011 Paul Howarth <paul@city-fan.org> 2.53-1
108- update to 2.53
109  - fixed to_json (CPAN RT#68359)
110  - backport JSON::PP 2.27200 (fixed incr_parse decoding string more correctly
111    - CPAN RT#68032)
112  - made Makefile.PL skip an installing XS question when set $ENV{PERL_ONLY} or
113    $ENV{NO_XS} (CPAN RT#66820)
114
115* Tue Mar  8 2011 Paul Howarth <paul@city-fan.org> 2.51-1
116- update to 2.51 (#683052)
117  - import JSON::PP 2.27105 as BackportPP
118  - fix documentation (CPAN RT#64738)
119
120* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.50-2
121- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
122
123* Thu Jan 27 2011 Paul Howarth <paul@city-fan.org> 2.50-1
124- update to 2.50 (#665621)
125  - JSON::PP split off into separate distribution and replaced with
126    JSON::backportPP instead for internal use
127- BR: perl(Test::Pod)
128- drop t/ from %%doc as the tests are in the -tests subpackage
129- filter private module perl(JSON::backportPP) from requires
130- filter private module perl(JSON::backportPP::Boolean) from provides
131- filter private module perl(JSON::Backend::PP) from provides
132- filter private module perl(JSON::Boolean) from provides
133- filter private module perl(JSON::PP) from provides (really JSON::backportPP)
134- filter private module perl(JSON::PP::IncrParser) from provides
135
136* Sun Nov 21 2010 Iain Arnell <iarnell@gmail.com> 2.27-1
137- update to latest upstream version
138- clean up spec for modern rpmbuild
139
140* Sun May 02 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.17-2
141- Mass rebuild with perl-5.12.0
142
143* Sun Feb 28 2010 Chris Weyl <cweyl@alumni.drew.edu> 2.17-1
144- update by Fedora::App::MaintainerTools 0.004
145- PERL_INSTALL_ROOT => DESTDIR
146- dropped old BR on perl(HTTP::Request)
147- dropped old BR on perl(HTTP::Response)
148- dropped old requires on perl(HTTP::Daemon)
149- dropped old requires on perl(LWP::UserAgent)
150- dropped old requires on perl(Scalar::Util)
151
152* Wed Sep 02 2009 Chris Weyl <cweyl@alumni.drew.edu> 2.15-5
153- adjust filtering so we don't drop the versioned perl(JSON:PP) prov
154
155* Tue Sep 01 2009 Chris Weyl <cweyl@alumni.drew.edu> 2.15-4
156- bump
157
158* Mon Aug 31 2009 Chris Weyl <cweyl@alumni.drew.edu> 2.15-3
159- update filtering
160
161* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.15-2
162- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
163
164* Mon Jun 22 2009 Chris Weyl <cweyl@alumni.drew.edu> 2.15-1
165- auto-update to 2.15 (by cpan-spec-update 0.01)
166
167* Sun Mar 01 2009 Chris Weyl <cweyl@alumni.drew.edu> 2.14-1
168- update to 2.14
169
170* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.12-3
171- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
172
173* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.12-2
174- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
175
176* Sun Oct 12 2008 Chris Weyl <cweyl@alumni.drew.edu> 2.12-1
177- update to 2.12
178
179* Wed Jun 25 2008 Chris Weyl <cweyl@alumni.drew.edu> 2.11-1
180- update to 2.11
181
182* Wed May 28 2008 Chris Weyl <cweyl@alumni.drew.edu> 2.09-1
183- update to 2.09
184
185* Sun Mar 09 2008 Chris Weyl <cweyl@alumni.drew.edu> 2.07-1
186- update to 2.x series before F9
187
188* Wed Mar  5 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.15-2
189- rebuild for new perl
190
191* Mon Nov 26 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.15-1
192- update to 1.15
193
194* Sun May 13 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.14-1
195- update to 1.14
196
197* Wed May 09 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.13-1
198- update to 1.13
199
200* Fri May 04 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.12-1
201- update to 1.12
202- add t/ to %%doc
203
204* Wed Apr 25 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.11-2
205- bump
206
207* Tue Apr 24 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.11-1
208- update to 1.11
209
210* Wed Apr 18 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.10-1
211- Specfile autogenerated by cpanspec 1.69.1.
Note: See TracBrowser for help on using the repository browser.