source: projects/specs/trunk/p/perl-JSON-XS/perl-JSON-XS-vl.spec @ 5863

Revision 5863, 4.4 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1Name:           perl-JSON-XS
2Summary:        JSON serialising/deserialising, done correctly and fast
3Epoch:          1
4Version:        2.32
5Release:        1%{?_dist_release}
6License:        GPL+ or Artistic
7Group:          Development/Libraries
8URL:            http://search.cpan.org/dist/JSON-XS/
9Source0:        http://www.cpan.org/authors/id/M/ML/MLEHMANN/JSON-XS-%{version}.tar.gz
10Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
11
12BuildRequires:  perl(common::sense)
13BuildRequires:  perl(ExtUtils::MakeMaker)
14BuildRequires:  perl(Test::More)
15
16Requires:       perl(common::sense)
17
18%{?perl_default_filter}
19%{?perl_default_subpackage_tests}
20
21%description
22This module converts Perl data structures to JSON and vice versa. Its
23primary goal is to be correct and its secondary goal is to be fast. To
24reach the latter goal it was written in C.
25
26%prep
27%setup -q -n JSON-XS-%{version}
28
29sed -i 's/\r//' t/*
30perl -pi -e 's|^#!/opt/bin/perl|#!%{__perl}|' eg/*
31chmod -c -x eg/*
32
33%build
34%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
35make %{?_smp_mflags}
36
37%install
38rm -rf %{buildroot}
39make pure_install DESTDIR=%{buildroot}
40
41find %{buildroot} -type f -name .packlist -exec rm -f {} +
42find %{buildroot} -type f -name '*.bs' -size 0 -exec rm -f {} +
43find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
44
45%{_fixperms} %{buildroot}/*
46
47%check
48make test
49
50%clean
51rm -rf %{buildroot}
52
53%files
54%doc Changes COPYING README eg/
55%{perl_vendorarch}/*
56%exclude %dir %{perl_vendorarch}/auto
57%{_bindir}/*
58%{_mandir}/man[13]/*
59
60%changelog
61* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1:2.32-1
62- initial build for Vine Linux
63
64* Thu Jan 12 2012 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 1:2.32-1
65- Update to 2.32
66- Clean up spec file
67
68* Sun Jun 19 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1:2.30-3
69- Perl mass rebuild
70
71* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2.30-2
72- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
73
74* Mon Oct 11 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1:2.30-1
75- update
76
77* Sun May 02 2010 Marcela Maslanova <mmaslano@redhat.com> - 1:2.27-2
78- Mass rebuild with perl-5.12.0
79
80* Sat Feb 27 2010 Chris Weyl <cweyl@alumni.drew.edu> 1:2.27-1
81- update by Fedora::App::MaintainerTools 0.004
82- PERL_INSTALL_ROOT => DESTDIR
83- added a new br on perl(common::sense) (version 0)
84- added a new req on perl(common::sense) (version 0)
85
86* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 1:2.24-3
87- rebuild against perl 5.10.1
88
89* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2.24-2
90- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
91
92* Tue Jun 02 2009 Chris Weyl <cweyl@alumni.drew.edu> 2.24-1
93- auto-update to 2.24 (by cpan-spec-update 0.01)
94
95* Thu Mar 26 2009 Chris Weyl <cweyl@alumni.drew.edu> - 2.2311-4
96- Stripping bad provides of private Perl extension libs
97
98* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2311-3
99- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
100
101* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2311-2
102- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
103
104* Sun Feb 22 2009 Chris Weyl <cweyl@alumni.drew.edu> 2.2311-1
105- update to 2.2311
106
107* Sun Sep 07 2008 Chris Weyl <cweyl@alumni.drew.edu> 2.2222-1
108- update to the increasingly silly version of 2.2222
109- update files to include bin
110
111* Wed Jun 25 2008 Chris Weyl <cweyl@alumni.drew.edu> 2.21-1
112- update to 2.21
113
114* Wed May 28 2008 Chris Weyl <cweyl@alumni.drew.edu> 2.2-1
115- update to 2.2
116
117* Sun Mar 09 2008 Chris Weyl <cweyl@alumni.drew.edu> 2.01-1
118- update to 2.x series before F9
119
120* Thu Mar 06 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.52-3
121Rebuild for new perl
122
123* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.52-2
124- Autorebuild for GCC 4.3
125
126* Wed Oct 17 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.52-1
127- update to 1.52
128- license tag update: GPL -> GPL+
129
130* Tue Aug 21 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.43-2
131- bump
132
133* Thu Aug 09 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.43-1
134- update to 1.43
135
136* Fri Jun 01 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.22-1
137- update to 1.22
138
139* Mon May 14 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.21-3
140- bump
141
142* Mon May 14 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.21-2
143- add eg/ to doc
144
145* Sun May 13 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.21-1
146- Specfile autogenerated by cpanspec 1.71.
Note: See TracBrowser for help on using the repository browser.