source: projects/specs/trunk/p/perl-JSON-XS/perl-JSON-XS-vl.spec @ 9089

Revision 9089, 4.8 KB checked in by inagaki, 9 years ago (diff)

2014-11-15 Ryoichi INAGAKI <ryo1@…>

  • perl-Algorithm-C3, perl-Class-Inspector, perl-Hook-LexWrap?, perl-Tie-IxHash?: updated
  • perl-Algorithm-Diff, perl-JSON-XS, perl-PPI, perl-Test-SubCalls?, perl-Text-Diff: rebuilt


Line 
1Name:           perl-JSON-XS
2Summary:        JSON serialising/deserialising, done correctly and fast
3Summary(ja):    正確で高速な JSON シリアライザ/デシリアライザ
4Epoch:          1
5Version:        2.32
6Release:        2%{?_dist_release}
7License:        GPL+ or Artistic
8Group:          Development/Libraries
9URL:            http://search.cpan.org/dist/JSON-XS/
10Source0:        http://www.cpan.org/authors/id/M/ML/MLEHMANN/JSON-XS-%{version}.tar.gz
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
13BuildRequires:  perl(common::sense)
14BuildRequires:  perl(ExtUtils::MakeMaker)
15BuildRequires:  perl(Test::More)
16Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
17Requires:       perl(common::sense)
18
19Vendor:         Project Vine
20Distribution:   Vine Linux
21
22%{?perl_default_filter}
23%{?perl_default_subpackage_tests}
24
25%description
26This module converts Perl data structures to JSON and vice versa. Its
27primary goal is to be correct and its secondary goal is to be fast. To
28reach the latter goal it was written in C.
29
30%prep
31%setup -q -n JSON-XS-%{version}
32
33sed -i 's/\r//' t/*
34perl -pi -e 's|^#!/opt/bin/perl|#!%{__perl}|' eg/*
35chmod -c -x eg/*
36
37%build
38%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
39make %{?_smp_mflags}
40
41%install
42rm -rf %{buildroot}
43make pure_install DESTDIR=%{buildroot}
44
45find %{buildroot} -type f -name .packlist -exec rm -f {} +
46find %{buildroot} -type f -name '*.bs' -size 0 -exec rm -f {} +
47find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
48
49%{_fixperms} %{buildroot}/*
50
51%check
52make test
53
54%clean
55rm -rf %{buildroot}
56
57%files
58%doc Changes COPYING README eg/
59%{perl_vendorarch}/*
60%exclude %dir %{perl_vendorarch}/auto
61%{_bindir}/*
62%{_mandir}/man[13]/*
63
64%changelog
65* Sat Nov 15 2014 Ryoichi INAGAKI ryo1@toki.waseda.jp> - 1:2.32-2
66- rebuilt with perl 5.16.3
67- added Vendor and Distribution tag
68
69* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1:2.32-1
70- initial build for Vine Linux
71
72* Thu Jan 12 2012 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 1:2.32-1
73- Update to 2.32
74- Clean up spec file
75
76* Sun Jun 19 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1:2.30-3
77- Perl mass rebuild
78
79* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2.30-2
80- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
81
82* Mon Oct 11 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1:2.30-1
83- update
84
85* Sun May 02 2010 Marcela Maslanova <mmaslano@redhat.com> - 1:2.27-2
86- Mass rebuild with perl-5.12.0
87
88* Sat Feb 27 2010 Chris Weyl <cweyl@alumni.drew.edu> 1:2.27-1
89- update by Fedora::App::MaintainerTools 0.004
90- PERL_INSTALL_ROOT => DESTDIR
91- added a new br on perl(common::sense) (version 0)
92- added a new req on perl(common::sense) (version 0)
93
94* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 1:2.24-3
95- rebuild against perl 5.10.1
96
97* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2.24-2
98- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
99
100* Tue Jun 02 2009 Chris Weyl <cweyl@alumni.drew.edu> 2.24-1
101- auto-update to 2.24 (by cpan-spec-update 0.01)
102
103* Thu Mar 26 2009 Chris Weyl <cweyl@alumni.drew.edu> - 2.2311-4
104- Stripping bad provides of private Perl extension libs
105
106* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2311-3
107- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
108
109* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2311-2
110- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
111
112* Sun Feb 22 2009 Chris Weyl <cweyl@alumni.drew.edu> 2.2311-1
113- update to 2.2311
114
115* Sun Sep 07 2008 Chris Weyl <cweyl@alumni.drew.edu> 2.2222-1
116- update to the increasingly silly version of 2.2222
117- update files to include bin
118
119* Wed Jun 25 2008 Chris Weyl <cweyl@alumni.drew.edu> 2.21-1
120- update to 2.21
121
122* Wed May 28 2008 Chris Weyl <cweyl@alumni.drew.edu> 2.2-1
123- update to 2.2
124
125* Sun Mar 09 2008 Chris Weyl <cweyl@alumni.drew.edu> 2.01-1
126- update to 2.x series before F9
127
128* Thu Mar 06 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.52-3
129Rebuild for new perl
130
131* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.52-2
132- Autorebuild for GCC 4.3
133
134* Wed Oct 17 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.52-1
135- update to 1.52
136- license tag update: GPL -> GPL+
137
138* Tue Aug 21 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.43-2
139- bump
140
141* Thu Aug 09 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.43-1
142- update to 1.43
143
144* Fri Jun 01 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.22-1
145- update to 1.22
146
147* Mon May 14 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.21-3
148- bump
149
150* Mon May 14 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.21-2
151- add eg/ to doc
152
153* Sun May 13 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.21-1
154- Specfile autogenerated by cpanspec 1.71.
Note: See TracBrowser for help on using the repository browser.