source: projects/specs/trunk/p/perl-IPC-Run/perl-IPC-Run-vl.spec @ 5864

Revision 5864, 5.3 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1Name:           perl-IPC-Run
2Version:        0.89
3Release:        1%{?_dist_release}
4Summary:        Perl module for interacting with child processes
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/IPC-Run/
8Source0:        http://search.cpan.org/CPAN/authors/id/T/TO/TODDR/IPC-Run-%{version}.tar.gz
9BuildArch:      noarch
10BuildRequires:  perl(ExtUtils::MakeMaker)
11BuildRequires:  perl(IO::Pty) >= 1.00
12BuildRequires:  perl(Test::More) >= 0.47
13Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
14
15%description
16IPC::Run allows you run and interact with child processes using files,
17pipes, and pseudo-ttys. Both system()-style and scripted usages are
18supported and may be mixed. Likewise, functional and OO API styles are
19both supported and may be mixed.
20Various redirection operators reminiscent of those seen on common Unix
21and DOS command lines are provided.
22
23%prep
24%setup -q -n IPC-Run-%{version}
25chmod 644 lib/IPC/*.pm lib/IPC/Run/*.pm Changes eg/*
26for file in eg/run_daemon abuse/timers abuse/blocking_debug_with_sub_coprocess ; do
27    %{__perl} -pi -e 's,^#!.*/perl,%{__perl}, if ($. == 1)' "$file"
28done
29
30%build
31%{__perl} Makefile.PL INSTALLDIRS=vendor
32make %{?_smp_mflags}
33
34%install
35rm -rf %{buildroot}
36make pure_install PERL_INSTALL_ROOT=%{buildroot}
37
38find %{buildroot} -type f -name .packlist -exec rm -f {} \;
39find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
40
41%{_fixperms} %{buildroot}/*
42
43rm -f %{buildroot}%{perl_vendorlib}/IPC/Run/Win32*.pm
44rm -f %{buildroot}%{_mandir}/man3/IPC::Run::Win32*.3*
45
46%check
47# test doesn't work in this mock with tty
48make test || :
49
50%clean
51rm -rf %{buildroot}
52
53%files
54%defattr(-,root,root,-)
55%doc Changes LICENSE README TODO
56%doc abuse/ eg/
57%{perl_vendorlib}/*
58%{_mandir}/man3/*
59
60%changelog
61* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.89-1
62- initial build for Vine Linux
63
64* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.89-6
65- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
66
67* Fri Jun 24 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.89-5
68- Perl mass rebuild
69
70* Fri Jun 24 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.89-4
71- Perl mass rebuild
72
73* Thu Jun 23 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.89-3
74- Perl mass rebuild
75
76* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.89-2
77- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
78
79* Fri Oct 08 2010 Iain Arnell <iarnell@epo.org> 0.89-1
80- update to latest upstream version
81- clean up spec for modern rpmbuild
82
83* Sun May 02 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.84-3
84- Mass rebuild with perl-5.12.0
85
86* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.84-2
87- rebuild against perl 5.10.1
88
89* Wed Sep 02 2009 Steven Pritchard <steve@kspei.com> 0.84-1
90- Update to 0.84.
91- Drop IPCRUNDEBUG from "make test" (bug fixed long ago).
92
93* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.82-3
94- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
95
96* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.82-2
97- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
98
99* Fri Jan 16 2009 Steven Pritchard <steve@kspei.com> 0.82-1
100- Update to 0.82.
101- Use fixperms macro instead of our own chmod incantation.
102- Fix Source0 URL.
103- BR Test::More.
104- Include LICENSE, README, and abuse/ in docs.
105- Cleanup to more closely resemble cpanspec output.
106
107* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.80-5
108- Rebuild for perl 5.10 (again)
109
110* Mon Jan 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.80-4
111- rebuild for new perl
112
113* Tue Apr 17 2007 Ville Skyttä <ville.skytta at iki.fi> - 0.80-3
114- BuildRequire perl(ExtUtils::MakeMaker).
115
116* Wed Aug 30 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.80-2
117- Fix order of arguments to find(1).
118
119* Thu May 11 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.80-1
120- 0.80, fine tune build dependencies.
121
122* Tue Jan 17 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.79-3
123- Rebuild, cosmetic cleanups.
124
125* Sun Apr 10 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.79-2
126- Exclude Win32 specific modules.
127- Include more docs.
128- Skip tests if /dev/pts doesn't exist.
129
130* Sat Apr  2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.79-1
131- 0.79.
132
133* Sat Apr  2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.78-2
134- Sync with fedora-rpmdevtools' Perl spec template.
135- Improve dependency filtering script.
136
137* Sun Mar 14 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.78-0.fdr.1
138- Update to 0.78.
139
140* Sun Feb  1 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.77-0.fdr.4
141- Reduce directory ownership bloat.
142
143* Fri Nov 21 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.77-0.fdr.3
144- BuildRequire perl-IO-Tty for better test coverage.
145
146* Sat Oct 11 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.77-0.fdr.2
147- Fix typo in dependency filtering scriptlet.
148
149* Sat Sep 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.77-0.fdr.1
150- Update to 0.77.
151
152* Fri Sep  5 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.75-0.fdr.3
153- Avoid Win32-specific dependencies.
154- Use PERL_INSTALL_ROOT.
155
156* Sun Aug 31 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.75-0.fdr.2
157- Install into vendor dirs.
158
159* Thu Jun 19 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.75-0.fdr.1
160- First build.
Note: See TracBrowser for help on using the repository browser.