source: projects/specs/trunk/p/perl-IP-Country/perl-IP-Country-vl.spec @ 9189

Revision 9189, 3.7 KB checked in by inagaki, 9 years ago (diff)

2014-12-24 Ryoichi INAGAKI <ryo1@…>


Line 
1%define real_name IP-Country
2
3Summary: Classes for fast lookup of country codes from IP addresses for Perl
4Name: perl-IP-Country
5Version: 2.28
6Release: 1%{_dist_release}
7License: distributable
8Group: Development/Libraries
9URL: http://search.cpan.org/dist/IP-Country/
10
11Source: http://search.cpan.org/CPAN/authors/id/N/NW/NWETTERS/%{real_name}-%{version}.tar.gz
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13
14BuildArch: noarch
15BuildRequires: perl(ExtUtils::MakeMaker)
16BuildRequires: perl(Geography::Countries)
17Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
18
19Vendor:         Project Vine
20Distribution:   Vine Linux
21
22
23%description
24Finding the home country of a client using only the IP address can be difficult.
25Looking up the domain name associated with that address can provide some help,
26but many IP address are not reverse mapped to any useful domain, and the
27most common domain (.com) offers no help when looking for country.
28
29This module comes bundled with a database of countries where various IP addresses
30have been assigned. Although the country of assignment will probably be the
31country associated with a large ISP rather than the client herself, this is
32probably good enough for most log analysis applications, and under test has proved
33to be as accurate as reverse-DNS and WHOIS lookup.
34
35%prep
36%setup -n %{real_name}-%{version}
37
38%build
39CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS=vendor
40make
41
42%install
43rm -rf $RPM_BUILD_ROOT
44make install DESTDIR=$RPM_BUILD_ROOT
45
46find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
47
48find $RPM_BUILD_ROOT%{_prefix} -type f -print |
49        sed "s@^$RPM_BUILD_ROOT@@g" |
50        grep -v ^%{_bindir} |
51        grep -v ^%{_mandir} |
52        grep -v "\.packlist" > %{name}.files
53if [ "$(cat %{name}.files)X" = "X" ] ; then
54    echo "ERROR: EMPTY FILE LIST"
55    exit -1
56fi
57
58
59%check
60make test
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%files -f %{name}.files
66%defattr(-, root, root, 0755)
67%doc CHANGES MANIFEST README
68%{_bindir}/ip2cc
69%{_mandir}/man1/ip2cc.1*
70%{_mandir}/man3/*.3*
71%dir %{perl_vendorlib}/IP
72
73%changelog
74* Wed Dec 24 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.28-1
75- updated to 2.28
76- built with perl 5.16.3
77
78* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26-2
79- rebuild with perl-5.12.3
80
81* Mon Jun 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.26-1
82- new upstream release
83- remove BR: perl(Geography::Countries)
84
85* Mon May 06 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.24-1
86- new upstream release
87
88* Mon May 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.23-1
89- rebuild with perl 5.10
90- new versioning policy
91
92* Sun Feb 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.23-0vl1
93- new upstream release
94- change group to Development/Libraries
95
96* Tue Oct 17 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.21-1vl3
97- change group to Development/Languages
98
99* Mon Oct 16 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.21-1vl2
100- 1st release for VinePlus 4.0
101- change install dir (site -> vendor)
102- fix change log typo
103
104* Sun Oct 15 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.21-1vl1
105- 1st release for VinePlus 3.2
106- change install dir (vendor -> site)
107- remove smp flag in make section
108
109* Mon May 29 2006 Dag Wieers <dag@wieers.com> - 2.21-1
110- Updated to release 2.21.
111
112* Sat Jun 18 2005 Dries Verachtert <dries@ulyssis.org> - 2.20-1
113- Updated to release 2.20.
114
115* Sat Nov 06 2004 Dag Wieers <dag@wieers.com> - 2.18-1
116- Updated to release 2.18.
117
118* Fri Jan 02 2004 Dag Wieers <dag@wieers.com> - 2.17-0
119- Updated to release 2.17.
120
121* Mon Jul 14 2003 Dag Wieers <dag@wieers.com> - 2.14-0
122- Updated to release 2.14.
123
124* Sat Feb 01 2003 Dag Wieers <dag@wieers.com> - 2.08-0
125- Initial package. (using DAR)
Note: See TracBrowser for help on using the repository browser.