source: projects/specs/trunk/p/perl-IO-String/perl-IO-String-vl.spec @ 12120

Revision 12120, 3.2 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-IO-String
2Version:        1.08
3Release:        4%{?_dist_release}
4
5Summary:        Emulate file interface for in-core strings
6Group:          Development/Libraries
7License:        GPL or Artistic
8URL:            http://search.cpan.org/dist/IO-String/
9Source0:        http://www.cpan.org/authors/id/G/GA/GAAS/IO-String-%{version}.tar.gz
10
11Vendor:        Project Vine
12Distribution:  Vine Linux
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildArch:      noarch
16BuildRequires:  perl >= 2:5.26.2
17Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
18
19%description
20The "IO::String" module provides the "IO::File" interface for in-core
21strings.  An "IO::String" object can be attached to a string, and
22makes it possible to use the normal file operations for reading or
23writing data, as well as for seeking to various locations of the
24string.  This is useful when you want to use a library module that
25only provides an interface to file handles on data that you have in a
26string variable.
27
28Note that perl-5.8 and better has built-in support for "in memory"
29files, which are set up by passing a reference instead of a filename
30to the open() call. The reason for using this module is that it makes
31the code backwards compatible with older versions of Perl.
32
33
34%prep
35%setup -q -n IO-String-%{version}
36
37
38%build
39perl Makefile.PL INSTALLDIRS=vendor
40make %{?_smp_mflags}
41
42%install
43rm -rf $RPM_BUILD_ROOT
44make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
45#find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
46#find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
47#chmod -R u+w $RPM_BUILD_ROOT/*
48
49find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
50
51find $RPM_BUILD_ROOT/usr -type f -print |
52        sed "s@^$RPM_BUILD_ROOT@@g" |
53        grep -v %{_mandir} |
54        grep -v perllocal.pod |
55        grep -v "\.packlist" > IO-String-%{version}-filelist
56if [ "$(cat IO-String-%{version}-filelist)X" = "X" ] ; then
57    echo "ERROR: EMPTY FILE LIST"
58    exit -1
59fi
60
61
62%check || :
63make test
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68
69%files -f IO-String-%{version}-filelist
70%defattr(-,root,root,-)
71%doc Changes README
72%dir %{perl_vendorlib}/IO/
73#{perl_vendorlib}/IO/*
74%{_mandir}/man3/*.3*
75
76
77%changelog
78* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.08-4
79- rebuilt with perl-5.26.
80
81* Sat Dec 20 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.08-3
82- rebuilt with perl 5.16.3
83
84* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.08-2
85- rebuilt with perl-5.12.3
86
87* Tue Nov  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.08-1vl5
88- applied new versioning policy
89- rebuilt with perl 5.10.0
90
91* Sat Feb 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.08-0vl1
92- new upstream release
93- changed Group to Development/Libraries
94
95* Sat Feb 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.08-0vl1
96- new upstream release
97- changed Group to Development/Libraries
98
99* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
100- rebuilt for Vine
101
102* Thu Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
103- rebuilt
104
105* Wed Nov 24 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.06-1
106- Update to 1.06.
107
108* Sun Jul 04 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.05-0.fdr.1
109- First build.
Note: See TracBrowser for help on using the repository browser.