source: projects/specs/trunk/p/perl-HTML-Template/perl-HTML-Template-vl.spec @ 521

Revision 521, 3.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define perl_vendorlib  %(eval "`perl -V:installvendorlib`"; echo $installvendorlib)
2%define rel 2
3
4Summary: a Perl module to use HTML Templates
5Name: perl-HTML-Template
6Version: 2.9
7Release: %{rel}%{?_dist_release}
8License: GPL/Artistic
9Group: Development/Libraries
10Source0: http://www.cpan.org/authors/id/S/SA/SAMTREGAR/HTML-Template-%{version}.tar.gz
11Url: http://search.cpan.org/search?dist=HTML-Template
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: perl >= 5.004
14Requires: perl >= 5.004
15BuildArch: noarch
16AutoReq: false
17
18%description
19This module attempts make using HTML templates simple and natural.
20It extends standard HTML with a few new HTML-esque tags - <TMPL_VAR>,
21<TMPL_LOOP>, <TMPL_INCLUDE>, <TMPL_IF> and <TMPL_ELSE>.  The file
22written with HTML and these new tags is called a template.  It is
23usually saved separate from your script - possibly even created by
24someone else!  Using this module you fill in the values for the
25variables, loops and branches declared in the template.  This allows
26you to seperate design - the HTML - from the data, which you generate
27in the Perl script.
28
29%description -l ja
30このモジュールは HTML テンプレートを使うことを簡単に、自然にしようとし
31ます。これは標準の HTML をいくつかの新しいHTML風のタグ - <TMPL_VAR>,
32<TMPL_LOOP>, <TMPL_INCLUDE>, <TMPL_IF>, <TMPL_ELSE>, <TMPL_UNLESS> で拡
33張します。 HTML とこれらの新しいタグで書かれたファイルはテンプレートと
34呼ばれます。これは通常スクリプトとは別に保存されます - もしかしたら他の
35誰かによって作成されることさえあるかもしれません! このモジュールを使っ
36て、変数のための値を埋めたり、テンプレートで宣言されたループや分岐をお
37こないます。これにより Perl スクリプトで作成されるデータからデザイン
38- HTML - を分けることが出来ます。
39
40%prep
41%setup -q -n HTML-Template-%{version}
42
43%build
44CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
45#PREFIX=%{buildroot}%{_prefix}
46make
47
48%install
49rm -rf $RPM_BUILD_ROOT
50mkdir -p $RPM_BUILD_ROOT%{_prefix}
51make DESTDIR=$RPM_BUILD_ROOT install
52
53[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
54
55find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
56
57find $RPM_BUILD_ROOT%{_prefix} -type f -print |
58        sed "s@^$RPM_BUILD_ROOT@@g" |
59        grep -v ^%{_mandir} |
60        grep -v perllocal.pod |
61        grep -v "\.packlist" > %{name}.files
62if [ "$(cat %{name}.files)X" = "X" ] ; then
63    echo "ERROR: EMPTY FILE LIST"
64    exit -1
65fi
66
67%check
68make test
69
70%clean
71rm -rf $RPM_BUILD_ROOT
72
73
74%files -f %{name}.files
75%defattr(-,root,root)
76%doc ANNOUNCE Changes FAQ README scripts templates
77%{_mandir}/*/*
78%dir %{perl_vendorlib}/HTML
79
80%changelog
81* Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 4.06-2
82- spec in utf-8
83
84* Mon Apr 28 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 4.06-1
85- rebuild with perl-5.10.0-1
86
87* Tue Jul 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9-0vl1
88- new upstream release
89- changed Group to Development/Libraries
90
91* Sun Jul 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.7-0vl2
92- added Japanese description from VinePlus/3.2 package
93- added Autoreq: false
94- installed perl modules to vendor_perl
95
96* Mon Jan 10 2005 Satoshi MACHINO <machino@vinelinux.org> 2.7-0vl1
97- new upstream release
98- built with perl-5.8.6
99
100* Thu Apr 24 2003 IWAI Masaharu <iwai@alib.jp> 2.6-0vl1
101- build with perl-5.8.0
102- version up to 2.6
103
104* Mon Apr 29 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 2.5-0vl1
105- first build for Vine Linux
Note: See TracBrowser for help on using the repository browser.