source: projects/specs/trunk/p/perl-HTML-Tagset/perl-HTML-Tagset-vl.spec @ 521

Revision 521, 2.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define __find_provides /usr/lib/rpm/find-provides.perl
2%define __find_requires /usr/lib/rpm/find-requires.perl
3
4Summary: HTML::Tagset - data tables useful in parsing HTML.
5Name: perl-HTML-Tagset
6Version: 3.20
7Release: 2%{?_dist_release}
8License: Perl's
9Group: Development/Libraries
10Source0: HTML-Tagset-%{version}.tar.gz
11Url: http://search.cpan.org/~sburke/HTML-Tagset/
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: perl >= 1:5.6.0
14Requires: perl >= 1:5.6.0
15BuildArch: noarch
16
17Vendor: Project Vine
18Distribution: Vine Linux
19
20%description
21This module contains several data tables useful in various kinds of
22HTML parsing operations, such as tag and entity names.
23
24# Provide perl-specific find-{provides,requires}.
25%define __find_provides /usr/lib/rpm/find-provides.perl
26%define __find_requires /usr/lib/rpm/find-requires.perl
27
28%prep
29%setup -q -n HTML-Tagset-%{version}
30
31%build
32CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS="vendor"
33make
34
35%install
36rm -rf $RPM_BUILD_ROOT
37make DESTDIR=$RPM_BUILD_ROOT install
38# make install
39
40[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
41
42find $RPM_BUILD_ROOT/usr -type f -print |
43        sed "s@^$RPM_BUILD_ROOT@@g" |
44        grep -v perllocal.pod |
45        grep -v "\.packlist" > HTML-Tagset-%{version}-filelist
46if [ "$(cat HTML-Tagset-%{version}-filelist)X" = "X" ] ; then
47    echo "ERROR: EMPTY FILE LIST"
48    exit -1
49fi
50
51%check
52make test
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%files -f HTML-Tagset-%{version}-filelist
58%defattr(-,root,root)
59%dir %{perl_vendorlib}/HTML
60
61%changelog
62* Fri Apr 25 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 3.20-2
63- build on perl-5.10.0-1vl5
64- update License
65
66* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.20-1
67- new upstream release
68- add Vendor/Distributio tag
69- build under new versioning policy
70
71* Tue Jul 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10-0vl1
72- updated 3.10
73- installed module files to vendor_perl directory
74- changed Group to Development/Libraries
75
76* Sat Dec  4 2004 IWAI, Masaharu <iwai@alib.jp> 3.03-25vl4
77- build on perl-5.8.6-0vl1
78- update Url value
79
80* Mon Dec 15 2003 IWAI, Masaharu <iwai@alib.jp> 3.03-25vl3
81- build with perl-5.8.2
82- running make test
83- add %%{perl_sitelib}/HTML directory in %%files
84
85* Tue Oct 08 2002 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
86- 3.03-25vl2
87- Fix Requires, Buildrequires
88
89* Mon Oct 07 2002 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
90- 3.03-25vl1
91- first build for Vine Linux
92
93* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
94- automated release bump and build
95
96* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
97- automated rebuild
98
99* Mon Apr 30 2001 Chip Turner <cturner@redhat.com>
100- Spec file was autogenerated.
Note: See TracBrowser for help on using the repository browser.