source: projects/specs/trunk/p/perl-HTML-SimpleParse/perl-HTML-SimpleParse-vl.spec @ 6885

Revision 6885, 2.0 KB checked in by yasumichi, 12 years ago (diff)

first import

Line 
1%define pkgname HTML-SimpleParse
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        0.12
6Release:        1%{?_dist_release}
7# COPYING  などを参照して License を修正してください。
8License:        Artistic or GPL
9Group:          Development/Libraries
10Source0:        http://search.cpan.org/CPAN/authors/id/K/KW/KWILLIAMS/%{pkgname}-%{version}.tar.gz
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12BuildArch:      noarch
13
14Vendor:         Project Vine
15Distribution:   Vine Linux
16Packager:       yasumichi
17
18Summary:        HTML::SimpleParse - a bare-bones HTML parser
19Summary(ja):    ここに日本語で概要を記述してください。
20
21# Dependency
22Requires:       perl
23Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
24
25BuildRequires:  perl
26
27%description
28This module is a simple HTML parser. It is similar in concept to
29HTML::Parser, but it differs from HTML::TreeBuilder in a couple of important
30ways.
31
32%description -l ja
33このモジュールは、簡易 HTML パーサーです。HTML::Parser のコンセプトに似てい
34ますが、2、3 の重要な点で HTML::TreeBuilder と異なっています。
35
36%prep
37%setup -q -n HTML-SimpleParse-0.12
38
39%build
40%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
41%{__make} %{?_smp_mflags}
42
43%install
44%{__rm} -rf ${RPM_BUILD_ROOT}
45%{__make} pure_install DESTDIR=${RPM_BUILD_ROOT}
46
47# remove unnecessary files.
48find ${RPM_BUILD_ROOT} -type f -name perllocal.pod -exec %{__rm} -f {} ';'
49find ${RPM_BUILD_ROOT} -type f -name .packlist -exec %{__rm} -f {} ';'
50find ${RPM_BUILD_ROOT}%{_mandir} -type f -exec %{__rm} -f {} ';'
51find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
52
53# generate file list
54find $RPM_BUILD_ROOT%{_prefix} -type f -print |
55        sed "s@^$RPM_BUILD_ROOT@@g" > %{name}.files
56
57if [ "$(cat %{name}.files)X" = "X" ] ; then
58        echo "ERROR: EMPTY FILE LIST"
59        exit -1
60fi
61
62
63%clean
64%{__rm} -rf ${RPM_BUILD_ROOT}
65
66
67%files -f %{name}.files
68%defattr(-,root,root)
69%doc Changes README
70
71%changelog
72* Thu Oct 04 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.12-1
73- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.