source: projects/specs/trunk/p/perl-HTML-Scrubber/perl-HTML-Scrubber-vl.spec @ 6884

Revision 6884, 1.9 KB checked in by yasumichi, 12 years ago (diff)

first import

Line 
1%define pkgname HTML-Scrubber
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        0.09
6Release:        1%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/N/NI/NIGELM/%{pkgname}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11BuildArch:      noarch
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15Packager:       yasumichi
16
17Summary:        HTML::Scrubber - Perl extension for scrubbing/sanitizing html
18Summary(ja):    HTML::Scrubber - html の除去/サニタイジングのための Perl 拡張
19
20# Dependency
21Requires:       perl
22Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
23
24BuildRequires:  perl
25
26%description
27 If you wanna "scrub" or "sanitize" html input in a reliable and flexible
28fashion, then this module is for you.
29
30 I wasn't satisfied with HTML::Sanitizer because it is based on
31HTML::TreeBuilder, so I thought I'd write something similar that works
32directly with HTML::Parser.
33
34#%%description -l ja
35
36
37%prep
38%setup -q -n HTML-Scrubber-0.09
39
40%build
41%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
42%{__make} %{?_smp_mflags}
43
44%install
45%{__rm} -rf ${RPM_BUILD_ROOT}
46%{__make} pure_install DESTDIR=${RPM_BUILD_ROOT}
47
48# remove unnecessary files.
49find ${RPM_BUILD_ROOT} -type f -name perllocal.pod -exec %{__rm} -f {} ';'
50find ${RPM_BUILD_ROOT} -type f -name .packlist -exec %{__rm} -f {} ';'
51find ${RPM_BUILD_ROOT}%{_mandir} -type f -exec %{__rm} -f {} ';'
52find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
53
54# generate file list
55find $RPM_BUILD_ROOT%{_prefix} -type f -print |
56        sed "s@^$RPM_BUILD_ROOT@@g" > %{name}.files
57
58if [ "$(cat %{name}.files)X" = "X" ] ; then
59        echo "ERROR: EMPTY FILE LIST"
60        exit -1
61fi
62
63
64%clean
65%{__rm} -rf ${RPM_BUILD_ROOT}
66
67
68%files -f %{name}.files
69%defattr(-,root,root)
70%doc Changes LICENSE README
71
72%changelog
73* Thu Oct 04 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.09-1
74- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.