source: projects/specs/trunk/p/perl-HTML-Parser/perl-HTML-Parser-vl.spec @ 8658

Revision 8658, 5.8 KB checked in by iwaim, 10 years ago (diff)

perl-HTML-Parser 3.68-3

Line 
1%define name perl-HTML-Parser
2%define real_name HTML-Parser
3%if %{?_dist_release} == "vl5" || %{?_dist_release} == "vl4"
4%define __find_provides /usr/lib/rpm/find-provides.perl
5%define __find_requires /usr/lib/rpm/find-requires.perl
6%endif
7
8%define rel 3
9
10Summary: A Perl module for parsing HTML.
11Summary(ja): HTML を解析するための Perl モジュール
12Name: %{name}
13Version: 3.68
14Release: %{rel}%{?_dist_release}
15License: GPL or Artistic
16Group: Development/Libraries
17Source: ftp://ftp.cpan.org/pub/perl/CPAN/modules/by-module/HTML/%{real_name}-%{version}.tar.gz
18Url: http://search.cpan.org/~gaas/HTML-Parser/
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20Requires: perl >= 5.8.6, perl-HTML-Tagset >= 3.03
21BuildRequires: perl >= 5.8.6, perl-HTML-Tagset >= 3.03
22Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
23
24Vendor: Project Vine
25Distribution: Vine Linux
26
27%description
28The HTML-Parser module for perl to parse and extract information from
29HTML documents, including the HTML::Entities, HTML::HeadParser,
30HTML::LinkExtor, HTML::PullParser, and HTML::TokeParser modules.
31
32%prep
33%setup -q -n %{real_name}-%{version}
34
35%build
36CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS="vendor"
37make
38
39%install
40rm -rf $RPM_BUILD_ROOT
41# make install
42make DESTDIR=$RPM_BUILD_ROOT install
43
44[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
45
46find $RPM_BUILD_ROOT/usr -type f -print |
47        sed "s@^$RPM_BUILD_ROOT@@g" |
48        grep -v perllocal.pod |
49        grep -v "\.packlist" > perl-HTML-Parser-%{version}-filelist
50if [ "$(cat perl-HTML-Parser-%{version}-filelist)X" = "X" ] ; then
51    echo "ERROR: EMPTY FILE LIST"
52    exit -1
53fi
54
55%check
56make test
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%files -f perl-HTML-Parser-%{version}-filelist
62%defattr(-,root,root)
63%dir %{perl_vendorarch}/HTML
64%dir %{perl_vendorarch}/auto/HTML
65%dir %{perl_vendorarch}/auto/HTML/Parser
66
67%changelog
68* Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 3.68-3
69- build with Perl 5.16
70
71* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 3.68-2
72- add directory in files
73
74* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 3.68-1
75- new upstream release
76- add Requires: perl(:MODULE_COMPAT_...)
77- defined __find_{provides,requires} with vl4 and vl5 (updated 3.64-2)
78- add Vendor and Distribution tags
79
80* Tue Apr 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.64-2
81- undefine __find_provides and __find_requires at VineSeed
82- added Japanese summary
83
84* Sun Nov  1 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.64-1
85- new upstream release with security fix (CVE-2009-3627)
86
87* Fri Apr 25 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 3.56-2vl5
88- build on perl-5.10.0-1vl5
89
90* Tue Jul 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com>  3.56-0vl1
91- new upstream release
92- changed Group to Development/Libraries
93
94* Sat Dec  4 2004 IWAI, Masaharu <iwai@alib.jp>  3.41-0vl1
95- new upstream release
96- build on perl-5.8.6-0vl1
97- fix typo changelog: 3.34-0vl1 and 3.34-0vl2
98- update Url value
99- using perl_sitearch macro
100
101* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.34-0vl2
102- built on perl-5.8.2
103
104* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.34-0vl1
105- new upstream version
106- built on perl-5.8.1
107
108* Wed Apr 16 2003 Satoshi MACHINO <machino@vinelinux.org> 3.27-0vl1
109- New upstream version
110- build on perl-5.8.0
111        -- changed Requires, Buildrequires
112 
113* Tue Oct 08 2002 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
114- 3.26-14vl2
115- Fix Requires, Buildrequires
116
117* Mon Oct 07 2002 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
118- 3.26-14vl1
119- first build for Vine Linux
120- add define __find_provides / __find_requires
121- modefy files list (dir)
122
123* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
124- automated release bump and build
125
126* Tue Jun  4 2002 Chip Turner <cturner@redhat.com>
127- properly claim directories owned by package so they are removed when package is removed
128
129* Mon Jun  3 2002 Chip Turner <cturner@redhat.com>
130- fix for Makefile.PL sometimes prompting for input
131
132* Wed Mar 27 2002 Chip Turner <cturner@redhat.com>
133- update to 3.26, move to vendor_perl
134
135* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
136- automated rebuild
137
138* Thu Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 3.25-2
139- imported from mandrake. tweaked man path.
140
141* Tue Jul 03 2001 Fran輟is Pons <fpons@mandrakesoft.com> 3.25-1mdk
142- 3.25.
143
144* Wed Jun 20 2001 Christian Belisle <cbelisle@mandrakesoft.com> 3.18-3mdk
145- Fixed distribution tag.
146- Updated Requires.
147- Added an option to %makeinstall.
148
149* Sun Jun 17 2001 Geoffrey Lee <snailtalk@mandrakesoft.com> 3.18-2mdk
150- Rebuild against the latest perl.
151
152* Tue Feb 27 2001 François Pons <fpons@mandrakesoft.com> 3.18-1mdk
153- 3.18.
154
155* Tue Jan 30 2001 François Pons <fpons@mandrakesoft.com> 3.15-1mdk
156- 3.15.
157
158* Tue Dec 05 2000 François Pons <fpons@mandrakesoft.com> 3.14-1mdk
159- 3.14.
160
161* Thu Oct 12 2000 François Pons <fpons@mandrakesoft.com> 3.13-1mdk
162- 3.13.
163
164* Tue Aug 29 2000 François Pons <fpons@mandrakesoft.com> 3.11-1mdk
165- 3.11.
166
167* Thu Aug 03 2000 François Pons <fpons@mandrakesoft.com> 3.10-2mdk
168- macroszifications.
169- add doc.
170
171* Tue Jul 18 2000 François Pons <fpons@mandrakesoft.com> 3.10-1mdk
172- removed perllocal.pod from files.
173- 3.10.
174
175* Tue Jun 27 2000 Jean-Michel Dault <jmdault@mandrakesoft.com> 3.08-1mdk
176- update to 3.08
177
178* Wed May 17 2000 David BAUDENS <baudens@mandrakesoft.com> 3.05-4mdk
179- Fix build for i486
180- Use %%{_tmppath} for BuildRoot
181
182* Fri Mar 31 2000 Pixel <pixel@mandrakesoft.com> 3.05-3mdk
183- rebuild, new group, cleanup
184
185* Tue Feb 29 2000 Jean-Michel Dault <jmdault@netrevolution.com> 3.0.5-1mdk
186- upgrade to 3.05
187
188* Mon Jan  3 2000 Jean-Michel Dault <jmdault@netrevolution.com>
189- final cleanup for Mandrake 7
190
191* Thu Dec 30 1999 Jean-Michel Dault <jmdault@netrevolution.com>
192-updated to 3.02
193
194* Sun Aug 29 1999 Jean-Michel Dault <jmdault@netrevolution.com>
195- bzip2'd sources
196- updated to 2.23
197
198* Tue May 11 1999 root <root@alien.devel.redhat.com>
199- Spec file was autogenerated.
Note: See TracBrowser for help on using the repository browser.