source: projects/specs/trunk/p/perl-HTML-ParseBrowser/perl-HTML-ParseBrowser-vl.spec @ 521

Revision 521, 1.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define perl_vendorlib  %(eval "`perl -V:installvendorlib`"; echo $installvendorlib)
2%define srcver  0_5
3%define version 0.5
4
5Summary: Simple interface for User Agent string parsing for Perl
6Name: perl-HTML-ParseBrowser
7Version: %{version}
8Release: 0vl3
9License: GPL/Artistic
10Group: Development/Libraries
11Source0: http://www.cpan.org/authors/id/D/DO/DODGER/HTML-ParseBrowser-%{srcver}.tar.gz
12URL: http://search.cpan.org/~dodger/HTML-ParseBrowser/
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: perl >= 5.8.2
15Requires: perl >= 5.8.2
16BuildArch: noarch
17
18%description
19The HTML::ParseBrowser is an Object-Oriented interface for parsing a User Agent
20string. It provides simple autoloaded methods for retrieving both the actual
21values stored in the interpreted (and, so far, correct) information that these
22wildly varying and nonstandardised strings attempt to convey.
23
24%prep
25%setup -q -n HTML/ParseBrowser
26
27%build
28CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS="vendor"
29make
30
31%install
32rm -rf $RPM_BUILD_ROOT
33mkdir -p $RPM_BUILD_ROOT%{_prefix}
34make DESTDIR=$RPM_BUILD_ROOT install
35
36find $RPM_BUILD_ROOT%{_prefix} -type f -print |
37        sed "s@^$RPM_BUILD_ROOT@@g" |
38        grep -v ^%{_mandir} |
39        grep -v ParseBrowser.pod |
40        grep -v perllocal.pod |
41        grep -v "\.packlist" > %{name}.files
42if [ "$(cat %{name}.files)X" = "X" ] ; then
43    echo "ERROR: EMPTY FILE LIST"
44    exit -1
45fi
46
47%check
48make test
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%files -f %{name}.files
54%defattr(-,root,root)
55%doc Changes README test.pl
56%{_mandir}/*/*
57%dir %{perl_vendorlib}/HTML
58
59%changelog
60* Mon Oct  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5-0vl3
61- changed Group to Development/Libraries
62- added %check
63
64* Fri Sep  9 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5-0vl2
65- rebuild with perl 5.8.2
66- s/Copyright/License/
67- updated URL
68
69* Mon Apr 29 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.5-0vl1
70- first build for Vine Linux
Note: See TracBrowser for help on using the repository browser.