source: projects/specs/trunk/p/perl-HTML-FillInForm/perl-HTML-FillInForm-vl.spec @ 521

Revision 521, 2.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Populates HTML Forms with CGI data with Perl
2Name: perl-HTML-FillInForm
3Version: 2.00
4Release: 1%{?_dist_release}
5License: Artistic
6Group: Development/Libraries
7Source0: http://search.cpan.org/CPAN/authors/id/T/TJ/TJMATHER/HTML-FillInForm-%{version}.tar.gz
8Url: http://search.cpan.org/author/TJMATHER/HTML-FillInForm/
9
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildArch: noarch
12BuildRequires: perl-HTML-Parser >= 3.26
13Requires: perl-HTML-Parser >= 3.26
14Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
15
16Vendor: Project Vine
17Distribution: Vine Linux
18
19%description
20This module automatically inserts data from a previous HTML form into
21the HTML input and select tags. It is a subclass of HTML::Parser and
22uses it to parse the HTML and insert the values into the form tags.
23
24One useful application is after a user submits an HTML form without
25filling out required field.
26HTML::FillInForm can be used to redisplay the HTML form with all the
27form elements containing the submitted info.
28
29%prep
30%setup -q -n HTML-FillInForm-%{version}
31
32%build
33CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS="vendor"
34make
35
36%install
37rm -rf $RPM_BUILD_ROOT
38mkdir -p $RPM_BUILD_ROOT%{_prefix}
39make DESTDIR=$RPM_BUILD_ROOT install
40
41find $RPM_BUILD_ROOT%{_prefix} -type f -print |
42        sed "s@^$RPM_BUILD_ROOT@@g" |
43        grep -v ^%{_mandir} |
44        grep -v perllocal.pod |
45        grep -v "\.packlist" > %{name}.files
46if [ "$(cat %{name}.files)X" = "X" ] ; then
47    echo "ERROR: EMPTY FILE LIST"
48    exit -1
49fi
50
51%check
52make test
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%files -f %{name}.files
58%defattr(-,root,root)
59%doc README Changes
60%{_mandir}/*/*
61%dir %{perl_vendorlib}/HTML
62
63%changelog
64* Thu Nov 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.00-1
65- applied new versioning policy
66
67* Mon Oct  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.00-0vl1
68- new upstream release
69- changed Group to Development/Libraries
70
71* Fri Sep  9 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.05-0vl1
72- updated to 1.05
73- use vendor_perl dir
74
75* Tue Apr 29 2003 IWAI Masaharu <iwai@alib.jp> 1.01-0vl1
76- first build for Vine Linux
Note: See TracBrowser for help on using the repository browser.