source: projects/specs/trunk/p/perl-Gtk2/perl-Gtk2-vl.spec @ 9141

Revision 9141, 5.8 KB checked in by inagaki, 9 years ago (diff)

2014-12-07 Ryoichi INAGAKI <ryo1@…>

  • perl-DBD-CSV, perl-DBI, perl-Gtk2, perl-Mixin-Linewise, perl-SQL-Statement: updated
  • perl-Gtk2-Unique, perl-Module-Refresh: rebuilt
  • perl-HTML-Tree, perl-Pango, perl-PerlIO-utf8_strict: NEW
Line 
1#
2# Rebuild option:
3#
4#   --with testsuite         - run the test suite (requires X)
5#
6
7Name:           perl-Gtk2
8Version:        1.2493
9Release:        1%{?_dist_release}
10Summary:        Perl interface to the GTK+2
11Summary(ja):    GTK+2 用の Perl インタフェース
12
13Group:          Development/Libraries
14License:        LGPLv2+
15URL:            http://search.cpan.org/dist/Gtk2/
16Source0:        http://www.cpan.org/authors/id/T/TS/TSCH/Gtk2-%{version}.tar.gz
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  perl >= 5.8.0
20BuildRequires:  gtk2-devel
21BuildRequires:  perl(ExtUtils::Depends)
22BuildRequires:  perl(ExtUtils::PkgConfig)
23BuildRequires:  perl(Glib) >= 1.280
24BuildRequires:  perl(Cairo) >= 1.000
25BuildRequires:  perl(Pango) >= 1.220
26Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
27Requires:       perl(Glib)  >= 1.280
28Requires:       perl(Cairo) >= 1.000
29Requires:       perl(Pango) >= 1.220
30
31Vendor:         Project Vine
32Distribution:   Vine Linux
33
34%description
35This module allows you to write Gtk+ graphical user interfaces in a
36perlish and object-oriented way, freeing you from the casting and
37memory management in C, yet remaining very close in spirit to original
38API.  Find out more about Gtk+ at http://www.gtk.org.
39
40
41%prep
42%setup -q -n Gtk2-%{version}
43
44# Provides: exclude perl(main)
45cat <<__EOF__ > %{name}-perl.prov
46#!/bin/sh
47/usr/lib/rpm/perl.prov \$* | grep -v '^perl(main)$'
48__EOF__
49%define __perl_provides %{_builddir}/Gtk2-%{version}/%{name}-perl.prov
50chmod +x %{__perl_provides}
51
52# Requires: exclude unversioned perl(Glib)
53cat <<__EOF__ > %{name}-perl.req
54#!/bin/sh
55/usr/lib/rpm/perl.req \$* | grep -v '^perl(Glib)$'
56__EOF__
57%define __perl_requires %{_builddir}/Gtk2-%{version}/%{name}-perl.req
58chmod +x %{__perl_requires}
59
60
61%build
62%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
63make %{?_smp_mflags}
64
65
66%install
67rm -rf $RPM_BUILD_ROOT
68make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
69find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
70find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
71find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null ';'
72chmod -R u+w $RPM_BUILD_ROOT/*
73
74
75%check
76%{?_with_testsuite:make test}
77
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82
83%files
84%defattr(-,root,root,-)
85%doc AUTHORS ChangeLog.pre-git LICENSE NEWS README TODO
86%doc examples/ gtk-demo/
87%{perl_vendorarch}/auto/Gtk2/
88%{perl_vendorarch}/Gtk2*
89%{_mandir}/man3/*.3pm*
90
91
92%changelog
93* Fri Dec  5 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2493-1
94- updated to 1.2493
95
96* Tue Jul 22 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.202-3
97- build with Perl 5.16
98
99* Mon Mar 28 2011 IWAI, Masaharu <iwai@alib.jp> 1.202-2vl6
100- build with perl 5.12.3
101- add Vendor and Distribution tags
102
103* Tue Nov 04 2008 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 1.202-1
104- new upstream release
105
106* Mon Jul 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.162-1
107- initial build for Vine Linux
108
109* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.162-4
110- Rebuild for perl 5.10 (again)
111
112* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.162-3
113- Autorebuild for GCC 4.3
114
115* Tue Feb  5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.162-2
116- rebuild for new perl
117
118* Wed Dec 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.162-1
119- Update to 1.162
120
121* Sun Mar 18 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.144-1
122- Update to 1.144.
123
124* Mon Feb 26 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.143-1
125- Update to 1.143.
126
127* Sun Jan 21 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.142-1
128- Update to 1.142.
129
130* Wed Nov 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.141-1
131- Update to 1.141.
132
133* Wed Sep  6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.140-1
134- Update to 1.140.
135
136* Mon May 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.122-1
137- Update to 1.122.
138
139* Mon May  1 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.121-2
140- Requires perl(Cairo)  (distro >= FC-5).
141
142* Tue Apr 11 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.121-1
143- Update to 1.121.
144
145* Tue Mar 14 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.120-1
146- Update to 1.120.
147
148* Mon Feb 20 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.104-1
149- Update to 1.104.
150- Requires perl(Glib) >= 1.105 (1.104 had problems with perl 5.8.8).
151
152* Thu Jan 19 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.103-1
153- Update to 1.103.
154- Converted the Gtk2::Helper man page to utf8 (#177802).
155- Provides list: filtered out perl(main) (#177802).
156
157* Wed Nov 30 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.102-1
158- Update to 1.102.
159
160* Thu Oct  6 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.101-1
161- Update to 1.101.
162
163* Thu Sep  8 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.100-1
164- Update to 1.100.
165
166* Fri Jul 29 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.083-1
167- Update to 1.083.
168
169* Mon Jun 27 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.082-1
170- Update to 1.082.
171
172* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
173- rebuilt
174
175* Thu Mar 10 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.080-2
176- Use perl-Glib for versioning control (patch by Ville Skyttä).
177
178* Tue Mar  8 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.080-1
179- Update to 1.080.
180
181* Tue Feb 15 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.062-1
182- Update to 1.062.
183
184* Mon Oct 25 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.061-0.fdr.2
185- Removed irrelevant or duplicated documentation files.
186- Description simplified (as suggested by Ville Skyttä).
187
188* Tue Oct  5 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.061-0.fdr.1
189- Update to 1.061.
190
191* Tue Oct  5 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.043-0.fdr.2
192- make test commented: needs X.
193
194* Sun Jul 18 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.043-0.fdr.1
195- First build.
Note: See TracBrowser for help on using the repository browser.