source: projects/specs/trunk/p/perl-GDTextUtil/perl-GDTextUtil-vl.spec @ 521

Revision 521, 2.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define perl_vendorlib %(eval "`%{__perl} -V:installvendorlib`"; echo $installvendorlib)
2
3%define fontdir %{_datadir}/fonts/perl
4
5Name:           perl-GDTextUtil
6Version:        0.86
7Release:        6%{?_dist_release}
8
9Summary:        Text utilities for use with GD
10
11Group:          Development/Libraries
12License:        GPL or Artistic
13URL:            http://search.cpan.org/dist/GDTextUtil/
14Source0:        http://www.cpan.org/authors/id/M/MV/MVERB/GDTextUtil-%{version}.tar.gz
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildArch:      noarch
18BuildRequires:  perl >= 5.6.1, perl-GD
19Requires:       perl >= 5.6.1, perl-GD
20Requires(post): fontconfig
21
22%description
23This package provides three modules that make it possible to work with
24internal GD fonts as well as TrueType fonts, without having to worry
25about different interface functions to call. Apart from an abstract
26interface to all font types and strings for GD, this library also
27provides some utility in aligning and wrapping your string.
28
29%prep
30%setup -q -n GDTextUtil-%{version}
31
32%build
33perl Makefile.PL INSTALLDIRS=vendor
34make %{?_smp_mflags}
35
36%install
37rm -rf $RPM_BUILD_ROOT
38make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
39find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
40find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
41chmod -R u+w $RPM_BUILD_ROOT/*
42
43# Install the TrueType font
44install -d $RPM_BUILD_ROOT%{fontdir}
45install -p -m 644 Dustismo_Sans.ttf $RPM_BUILD_ROOT%{fontdir}/
46touch $RPM_BUILD_ROOT%{fontdir}/fonts.cache-1
47
48%check || :
49make test
50
51%clean
52rm -rf $RPM_BUILD_ROOT
53
54%post
55fc-cache -f %{fontdir} || :
56
57
58%files
59%defattr(-,root,root,-)
60%doc Changes README Dustismo.LICENSE demo/
61%{perl_vendorlib}/GD/*
62%{_mandir}/man3/*.3*
63%dir %{fontdir}
64%{fontdir}/*.ttf
65%ghost %{fontdir}/fonts.cache-1
66
67%changelog
68* Wed Jun 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.86-6
69- applied new versioning policy
70- rebuilt with perl-5.10.0
71
72* Sun Sep  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.86-5vl2
73- changed Group to Development/Libraries
74
75* Sat Sep 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.86-5vl1
76- rebuild for Vine
77
78* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
79- rebuilt
80
81* Sun Jul 11 2004 Jose Pedro Oliveira <jpo@di.uminho.pt> - 0:0.86-0.fdr.4
82- Unowned directory: %%{perl_vendorlib}/GD (see bug 1800 comment #1).
83
84* Tue Jul  6 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:0.86-0.fdr.3
85- Install the Dustismo_Sans TrueType font (bug 1757).
86
87* Wed Jun 16 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:0.86-0.fdr.2
88- Bring up to date with current fedora.us perl spec template.
89
90* Sun Oct 12 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.86-0.fdr.1
91- First build.
Note: See TracBrowser for help on using the repository browser.