source: projects/specs/trunk/p/perl-GD/perl-GD-vl.spec @ 521

Revision 521, 2.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define perl_vendorarch    %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
2
3Summary: A perl5 interface to Thomas Boutell's gd library
4Summary(ja): GD ライブラリの Perl 用インターフェイス
5Name: perl-GD
6Version: 2.35
7Release: 1%{?_dist_release}
8License: distributable
9Group: Development/Libraries
10Source0: http://search.cpan.org/CPAN/authors/id/L/LD/LDS/GD-%{version}.tar.gz
11Url: http://search.cpan.org/dist/GD/
12BuildRoot: %{_tmppath}/perl-GD-buildroot/
13BuildRequires: perl >= 5.6.0, gd-devel >= 2.0.20, libjpeg-devel
14BuildRequires: freetype2-devel, libpng-devel, zlib-devel
15Requires: perl >= 5.6.0, gd >= 2.0.12, libjpeg, freetype2
16Requires: libpng, zlib
17
18%description
19This is a autoloadable interface module for libgd, a popular library
20for creating and manipulating PNG files.  With this library you can
21create PNG images on the fly or modify existing files.  Features
22include:
23
24a.  lines, polygons, rectangles and arcs, both filled and unfilled
25b.  flood fills
26c.  the use of arbitrary images as brushes and as tiled fill patterns
27d.  line styling (dashed lines and the like)
28e.  horizontal and vertical text rendering
29f.  support for transparency and interlacing
30
31For full information on usage, see the accompanying man and html
32documentation.
33
34# Provide perl-specific find-{provides,requires}.
35%define __find_provides /usr/lib/rpm/find-provides.perl
36%define __find_requires /usr/lib/rpm/find-requires.perl
37
38%prep
39%setup -q -n GD-%{version}
40
41%build
42CFLAGS="$RPM_OPT_FLAGS" \
43perl Makefile.PL --lib_gd_path=%{_libdir} INSTALLDIRS="vendor" << _OPT_
44y
45_OPT_
46make
47make test
48
49%clean 
50rm -rf %{buildroot}
51
52%install
53rm -rf %{buildroot}
54make DESTDIR=%{buildroot} install
55
56[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
57
58find %{buildroot}%{_prefix} -type f -print | 
59        sed "s@^%{buildroot}@@g" | 
60        grep -v perllocal.pod | 
61        grep -v "\.packlist" > %{name}-filelist
62if [ "$(cat %{name}-filelist)X" = "X" ] ; then
63    echo "ERROR: EMPTY FILE LIST"
64    exit -1
65fi
66
67find demos -type f | xargs perl -pi -e "s|^#!(\s)?/usr/local/bin/perl|#!/usr/bin/perl|g"
68find bdf_scripts -type f | xargs perl -pi -e "s|^#!(\s)?/usr/local/bin/perl|#!/usr/bin/perl|g"
69
70%files -f %{name}-filelist
71%defattr(-,root,root)
72%doc ChangeLog README* demos bdf_scripts
73%dir %{perl_vendorarch}/GD
74%dir %{perl_vendorarch}/auto/GD
75
76%changelog
77* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.35-1vl5
78- applied new versioning policy, spec in utf-8
79- built with perl-5.10.0
80
81* Sun Sep  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.35-0vl1
82- new upstream release
83- changed Group to Development/Libraries
84
85* Sat Sep 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28-0vl1
86- new upstream release
87- added Japanese summary
88
89* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 2.19-0vl1
90- new upstream release
91- update {Build,}Requires
92
93* Tue Nov 11 2003 IWAI, Masaharu <iwai@alib.jp> 2.11-0vl1
94- initial build
Note: See TracBrowser for help on using the repository browser.