source: projects/specs/trunk/p/perl-File-Which/perl-File-Which-vl.spec @ 12120

Revision 12120, 2.0 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Summary: Portable implementation of the `which' utility
2Name: perl-File-Which
3Version: 1.23
4Release: 1%{_dist_release}
5License: GPL+ or Artistic
6Group: Development/Libraries
7URL: http://search.cpan.org/~pereinar/File-Which/
8
9Source0: http://search.cpan.org/CPAN/authors/id/P/PE/PEREINAR/File-Which-%{version}.tar.gz
10BuildArch: noarch
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: perl(ExtUtils::MakeMaker)
13BuildRequires: perl(File::Spec)
14BuildRequires: perl(Test::More)
15BuildRequires: perl(Test::Script)
16Requires:      perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
17
18Vendor: Project Vine
19Distribution: Vine Linux
20
21%description
22File::Which is a portable implementation (in Perl) of `which', and can
23be used to get the absolute filename of an executable program
24installed somewhere in your PATH, or just check for its existence. It
25includes the command-line utility `pwhich' which has the same function
26as `which'.
27
28%prep
29%setup -q -n File-Which-%{version}
30
31%build
32perl Makefile.PL INSTALLDIRS=vendor
33make %{?_smp_mflags}
34
35%install
36rm -rf $RPM_BUILD_ROOT
37make install DESTDIR=$RPM_BUILD_ROOT
38find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
39find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
40find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
41#chmod -R u+w $RPM_BUILD_ROOT/*
42
43%check
44make test
45
46%clean
47rm -rf $RPM_BUILD_ROOT
48
49
50%files
51%defattr(-,root,root,-)
52%doc Changes README
53%dir %{perl_vendorlib}/File
54%{perl_vendorlib}/File/*
55%{_mandir}/man3/*
56
57
58%changelog
59* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.23-1
60- new upstream release.
61- rebuilt with perl-5.26.
62
63* Sat Nov  8 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.09-1
64- updated to 1.09
65- built with perl 5.16.3
66
67* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.05-2
68- rebuild with perl-5.12.3
69
70* Thu May  1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.05-1
71- rebuilt with perl-5.10.0.
72
73* Tue Dec  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.05-0vl1
74- First build for Vine Linux
Note: See TracBrowser for help on using the repository browser.