source: projects/specs/trunk/p/perl-File-Tail/perl-File-Tail-vl.spec @ 3736

Revision 3736, 3.6 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with perl-5.12.3

Line 
1%define perl_sitelib    %(eval "`perl -V:installvendorlib`"; echo $installvendorlib)
2
3Name:           perl-File-Tail
4Version:        0.99.3
5Release:        2%{?_dist_release}
6Summary:        Perl extension for reading from continously updated files
7Group:          Development/Libraries
8License:        GPL or Artistic
9URL:            http://search.cpan.org/dist/File-Tail/
10Source0:        http://www.cpan.org/authors/id/M/MG/MGRABNAR/File-Tail-%{version}.tar.gz
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12BuildArch:      noarch
13BuildRequires:  perl(Time::HiRes)
14#Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
15Requires: perl >= 1:5.6.0
16
17Vendor: Project Vine
18Distribution: Vine Linux
19
20%description
21The primary purpose of File::Tail is reading and analysing log files
22while they are being written, which is especially useful if you are
23monitoring the logging process with a tool like Tobias Oetiker's MRTG.
24
25%description -l ja
26File::Tail の主目的は,ログファイルの読み込み,分析です.
27特に Tobias Oetiker の MRTG ようなツールでログを監視するのに有用です.
28
29# Provide perl-specific find-{provides,requires}.
30%define __find_provides /usr/lib/rpm/find-provides.perl
31%define __find_requires /usr/lib/rpm/find-requires.perl
32
33%prep
34%setup -q -n File-Tail-%{version}
35
36%build
37CFLAGS="$RPM_OPT_FLAGS" %{__perl} Makefile.PL INSTALLDIRS=vendor
38make
39
40%install
41rm -rf $RPM_BUILD_ROOT
42mkdir -p $RPM_BUILD_ROOT%{_prefix}
43make DESTDIR=$RPM_BUILD_ROOT install
44
45[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
46
47find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
48
49find $RPM_BUILD_ROOT%{_prefix} -type f -print |
50        sed "s@^$RPM_BUILD_ROOT@@g" |
51        grep -v ^%{_mandir} |
52        grep -v perllocal.pod |
53        grep -v "\.packlist" > %{name}.files
54if [ "$(cat %{name}.files)X" = "X" ] ; then
55    echo "ERROR: EMPTY FILE LIST"
56    exit -1
57fi
58
59%check
60make test
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%files -f %{name}.files
66%defattr(-,root,root,-)
67%doc Changes README
68%dir %{perl_vendorlib}/File
69%{_mandir}/man3/File::Tail.3*
70
71%changelog
72* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.99.3-2
73- rebuild with perl-5.12.3
74
75* Sun Jul 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.3-1
76- rebuilt with perl 5.10.0
77- applied new versioning policy
78
79* Wed Sep 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.99.3-0vl3
80- changed Group to Development/Libraries
81- enable make test
82
83* Sun Jul 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.99.3-0vl2
84- rebuilt for VineSeed (4.0)
85
86* Fri Jul  7 2006 Takeru INOUE <takeru.inoue@ieee.org>
87- 0.99.0vl1
88- Add description -l ja
89- Build with perl-5.8.2
90- Build for Vine 3.2
91
92* Fri Jun  9 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.99.3-5
93- Added the requirement perl(:MODULE_COMPAT_x.x.x).
94
95* Mon Feb 20 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.99.3-4
96- Rebuild for FC5 (perl 5.8.8).
97
98* Fri Jan  6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.99.3-3
99- Another typo corrected.
100
101* Wed Jan  4 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.99.3-2
102- Correction of spelling error in the description.
103
104* Thu Sep 15 2005 Ville Skytt辰 <ville.skytta at iki.fi> - 0.99.3-1
105- 0.99.3.
106- Specfile cleanups.
107
108* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.98-4
109- rebuilt
110
111* Sun Feb  8 2004 Ville Skytt辰 <ville.skytta at iki.fi> - 0:0.98-0.fdr.3
112- BuildRequire Time::HiRes (bug 731).
113- Run tests in the %%check section.
114- Reduce directory ownership bloat.
115
116* Mon Nov 17 2003 Ville Skytt辰 <ville.skytta at iki.fi> - 0:0.98-0.fdr.2
117- Specfile rewrite.
118
119* Tue Sep 17 2003 Warren Togami <warren@togami.com> - 0.98-0.fdr.1
120- Specfile autogenerated.
Note: See TracBrowser for help on using the repository browser.