source: projects/specs/trunk/p/perl-File-ShareDir-Install/perl-File-ShareDir-Install-vl.spec @ 12120

Revision 12120, 5.9 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-File-ShareDir-Install
2Version:        0.13
3Release:        5%{?_dist_release}
4Summary:        Install shared files
5License:        GPL+ or Artistic
6URL:            https://metacpan.org/release/File-ShareDir-Install
7Source0:        https://cpan.metacpan.org/authors/id/E/ET/ETHER/File-ShareDir-Install-%{version}.tar.gz
8
9Vendor:        Project Vine
10Distribution:  Vine Linux
11
12BuildArch:      noarch
13# Module Build
14BuildRequires:  coreutils
15BuildRequires:  findutils
16BuildRequires:  make
17BuildRequires:  perl >= 2:5.26.2
18BuildRequires:  perl(ExtUtils::MakeMaker)
19# Module Runtime
20BuildRequires:  perl(Carp)
21BuildRequires:  perl(Exporter)
22BuildRequires:  perl(File::Spec)
23BuildRequires:  perl(IO::Dir)
24BuildRequires:  perl(strict)
25BuildRequires:  perl(warnings)
26# Test Suite
27BuildRequires:  perl(Config)
28BuildRequires:  perl(CPAN::Meta::YAML)
29BuildRequires:  perl(File::Path)
30BuildRequires:  perl(Test::More)
31# Runtime
32Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
33
34%description
35File::ShareDir::Install allows you to install read-only data files from a
36distribution. It is a companion module to File::ShareDir, which allows you
37to locate these files after installation.
38
39%prep
40%setup -q -n File-ShareDir-Install-%{version}
41
42%build
43perl Makefile.PL INSTALLDIRS=vendor
44make %{?_smp_mflags}
45
46%install
47make pure_install DESTDIR=%{buildroot}
48find %{buildroot} -type f -name .packlist -delete
49%{_fixperms} -c %{buildroot}
50
51%check
52make test
53
54%files
55%license LICENSE
56%doc Changes CONTRIBUTING README
57%{perl_vendorlib}/File/
58%{_mandir}/man3/File::ShareDir::Install.3*
59
60%changelog
61* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.13-5
62- initial build for Vine Linux.
63
64* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.13-4
65- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
66
67* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.13-3
68- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
69
70* Thu Jun 28 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.13-2
71- Perl 5.28 rebuild
72
73* Mon May 14 2018 Paul Howarth <paul@city-fan.org> - 0.13-1
74- Update to 0.13
75  - Add rules files for 'prove' and Test::Harness to specify that tests need to
76    be run serially for now
77  - Support spaces (and other special characters too) in share files (GH#2)
78- BR: perl(CPAN::Meta::YAML) so we can process testrules.yml
79
80* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.11-5
81- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
82
83* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.11-4
84- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
85
86* Sun Jun 04 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.11-3
87- Perl 5.26 rebuild
88
89* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.11-2
90- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
91
92* Mon Aug  8 2016 Paul Howarth <paul@city-fan.org> - 0.11-1
93- Update to 0.11
94  - Release with new tooling
95- This release by ETHER → update source URL
96- BR: perl-generators
97- Simpify find command using -delete
98
99* Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.10-5
100- Perl 5.24 rebuild
101
102* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.10-4
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
104
105* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10-3
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
107
108* Fri Jun 05 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.10-2
109- Perl 5.22 rebuild
110
111* Thu Dec 11 2014 Paul Howarth <paul@city-fan.org> - 0.10-1
112- Update to 0.10
113  - Recurse with $def in _scan_share_dir (CPAN RT#95749)
114
115* Thu Nov 13 2014 Paul Howarth <paul@city-fan.org> - 0.09-1
116- Update to 0.09
117  - Get rid of DB::single
118  - Don't do POD tests by default
119- Specify all dependencies
120
121* Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.08-3
122- Perl 5.20 rebuild
123
124* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.08-2
125- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
126
127* Mon Feb  3 2014 Paul Howarth <paul@city-fan.org> - 0.08-1
128- Update to 0.08
129  - Tweak documentation and fix typos
130  - Added $INCLUDE_DOTFILES and $INCLUDE_DOTDIRS
131  - Added delete_share
132  - Tests may now be run in parallel
133- Don't need to remove empty directories from the buildroot
134
135* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.04-7
136- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
137
138* Sat Jul 20 2013 Petr Pisar <ppisar@redhat.com> - 0.04-6
139- Perl 5.18 rebuild
140
141* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.04-5
142- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
143
144* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.04-4
145- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
146
147* Tue Jun 12 2012 Petr Pisar <ppisar@redhat.com> - 0.04-3
148- Perl 5.16 rebuild
149
150* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.04-2
151- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
152
153* Sun Aug 28 2011 Iain Arnell <iarnell@gmail.com> 0.04-1
154- update to latest upstream
155- clean up spec for modern rpmbuild
156
157* Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.03-6
158- Perl mass rebuild
159
160* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.03-5
161- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
162
163* Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.03-4
164- Rebuild to fix problems with vendorarch/lib (#661697)
165
166* Sat May 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.03-3
167- Mass rebuild with perl-5.12.0
168
169* Sun Apr 04 2010 Iain Arnell <iarnell@gmail.com> 0.03-2
170- use perl_default_filter and DESTDIR
171
172* Fri Apr 02 2010 Iain Arnell 0.03-1
173- Specfile autogenerated by cpanspec 1.78.
Note: See TracBrowser for help on using the repository browser.