source: projects/specs/trunk/p/perl-File-Find-Rule-Perl/perl-File-Find-Rule-Perl-vl.spec @ 5743

Revision 5743, 4.3 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1# define bootstrap for initial build
2%define perl_bootstrap 1
3
4Name:           perl-File-Find-Rule-Perl
5Version:        1.12
6Release:        1%{?_dist_release}
7Summary:        Common rules for searching for Perl things
8License:        GPL+ or Artistic
9Group:          Development/Libraries
10URL:            http://search.cpan.org/dist/File-Find-Rule-Perl/
11Source0:        http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/File-Find-Rule-Perl-%{version}.tar.gz
12
13Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
14BuildArch:      noarch
15
16BuildRequires:  perl(File::Find::Rule) >= 0.20
17BuildRequires:  perl(File::Spec) >= 0.82
18BuildRequires:  perl(Test::More) >= 0.47
19BuildRequires:  perl(Params::Util) >= 0.38
20BuildRequires:  perl(Parse::CPAN::Meta) >= 0.04
21
22# For improved tests
23%if !%{defined perl_bootstrap}
24BuildRequires:  perl(Perl::MinimumVersion) >= 1.27
25BuildRequires:  perl(Test::MinimumVersion) >= 0.101080
26BuildRequires:  perl(Test::Pod) >= 1.44
27BuildRequires:  perl(Test::CPAN::Meta) >= 0.17
28%endif
29
30Vendor:         Project Vine
31Distribution:   Vine Linux
32Packager:       shaolin
33
34%description
35Common rules for searching for Perl things.
36
37%prep
38%setup -q -T -c
39%setup -q -T -D -a0
40
41%build
42cd File-Find-Rule-Perl-%{version}
43%{__perl} Makefile.PL INSTALLDIRS=vendor
44make %{?_smp_mflags}
45cd ..
46
47%install
48rm -rf ${RPM_BUILD_ROOT}
49cd File-Find-Rule-Perl-%{version}
50make pure_install PERL_INSTALL_ROOT=${RPM_BUILD_ROOT}
51cd ..
52find ${RPM_BUILD_ROOT} -type f -name .packlist -exec rm -f {} ';'
53find ${RPM_BUILD_ROOT} -type d -depth -exec rmdir {} 2>/dev/null ';'
54chmod -R u+w ${RPM_BUILD_ROOT}/*
55
56%clean
57rm -rf ${RPM_BUILD_ROOT}
58
59%check
60%if !%{defined perl_bootstrap}
61cd File-Find-Rule-Perl-%{version}
62make test AUTOMATED_TESTING=1
63cd ..
64%endif
65
66%files
67%defattr(-,root,root,-)
68%doc File-Find-Rule-Perl-%{version}/Changes File-Find-Rule-Perl-%{version}/LICENSE
69%{perl_vendorlib}/File
70%{_mandir}/man3/*
71
72%changelog
73* Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.12-1
74- initial build for Vine Linux
75- define perl_boostrap until things get done...
76
77* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12-2
78- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
79
80* Fri Nov 25 2011 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.12-1
81- Upstream update.
82- Update BRs.
83- Spec file cleanup.
84
85* Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.10-3
86- rebuild with Perl 5.14.1
87- add perl_bootstrap macro for test BR
88
89* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.10-2
90- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
91
92* Wed Nov 03 2010 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.10-1
93- Upstream update.
94
95* Sun May 09 2010 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.09-5
96- Re-enable pmv-test.
97
98* Sat May 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.09-4
99- Mass rebuild with perl-5.12.0
100
101* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.09-3
102- Mass rebuild with perl-5.12.0
103
104* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 1.09-2
105- rebuild against perl 5.10.1
106
107* Fri Aug 07 2009 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.09-1
108- Upstream update.
109
110* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.08-2
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
112
113* Mon Jul 20 2009 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.08-1
114- Upstream update.
115
116* Wed Jun 17 2009 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.06-1
117- Upstream update.
118- Build in subdir to work-around rpm disturbing testsuite.
119- Rework BRs.
120
121* Fri Feb 27 2009 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.04-4
122- Adjust minimum perl version in META.yml (Add File-Find-Rule-Perl-1.04.diff).
123
124* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.04-3
125- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
126
127* Tue Jun 24 2008 Ralf Corsépius <rc040203@freenet.de> - 1.04-2
128- Unconditionally BR: perl(Test::CPAN::Meta).
129
130* Tue Jun 10 2008 Ralf Corsépius <rc040203@freenet.de> - 1.04-1
131- Upstream update.
132
133* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.03-3
134- Rebuild for perl 5.10 (again)
135
136* Fri Jan 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.03-2
137- rebuild for new perl
138
139* Mon Nov 19 2007 Ralf Corsépius <rc040203@freenet.de> - 0.03-1
140- Initial version.
Note: See TracBrowser for help on using the repository browser.