source: projects/specs/trunk/p/perl-File-Copy-Recursive/perl-File-Copy-Recursive-vl.spec @ 8709

Revision 8709, 2.0 KB checked in by tomop, 10 years ago (diff)

updated perl modules.

Line 
1%define pkgname File-Copy-Recursive
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        0.38
6Release:        2%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/D/DM/DMUEY/%{pkgname}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14Packager:       yasumichi
15
16Summary:        Perl extension for recursively copying files and directories
17Summary(ja):    再帰的にファイルおよびディレクトリをコピーする Perl 拡張
18
19# Dependency
20Requires:       perl
21Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
22
23BuildRequires:  perl
24
25%description
26This module copies and moves directories recursively (or single files,
27well... singley) to an optional depth and attempts to preserve each file or
28directory's mode.
29
30%description -l ja
31このモジュールは、ディレクトリ(あるいは、単一のファイル)をオプションにより深
32さを考慮し、各ファイルおよびディレクトリのモードを保ちながら、再帰的にコピー
33または移動します。
34
35%prep
36%setup -q -n File-Copy-Recursive-0.38
37
38%build
39perl Makefile.PL INSTALLDIRS="vendor"
40%{__make}
41
42%install
43%{__rm} -rf ${RPM_BUILD_ROOT}
44%{__make} install DESTDIR=${RPM_BUILD_ROOT}
45
46find $RPM_BUILD_ROOT%{_prefix} -type f -print |
47        sed "s@^$RPM_BUILD_ROOT@@g" |
48        grep -v ^%{_mandir} |
49        grep -v perllocal.pod |
50        grep -v "\.packlist" > %{name}.files
51if [ "$(cat %{name}.files)X" = "X" ] ; then
52    echo "ERROR: EMPTY FILE LIST"
53    exit -1
54fi
55
56# remove unnecessary files.
57%{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
58%{__rm} ${RPM_BUILD_ROOT}%{perl_vendorarch}/auto/File/Copy/Recursive/.packlist
59
60%clean
61%{__rm} -rf ${RPM_BUILD_ROOT}
62
63
64%files -f %{name}.files
65%defattr(-,root,root)
66%doc Changes README
67%{_mandir}/*/*
68
69%changelog
70* Tue Jul  1 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.38-2
71- rebuilt with perl-5.16.3.
72
73* Sun Oct 09 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.38-1
74- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.