source: projects/specs/trunk/p/perl-ExtUtils-InstallPaths/perl-ExtUtils-InstallPaths-vl.spec @ 12120

Revision 12120, 5.7 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-ExtUtils-InstallPaths
2Version:        0.012
3Release:        5%{?_dist_release}
4Summary:        Build.PL install path logic made easy
5License:        GPL+ or Artistic
6URL:            https://metacpan.org/release/ExtUtils-InstallPaths
7Source0:        http://cpan.metacpan.org/authors/id/L/LE/LEONT/ExtUtils-InstallPaths-%{version}.tar.gz
8
9Vendor:        Project Vine
10Distribution:  Vine Linux
11
12BuildArch:      noarch
13# Build
14BuildRequires:  coreutils
15BuildRequires:  findutils
16BuildRequires:  make
17BuildRequires:  perl >= 2:5.26.2
18BuildRequires:  perl(ExtUtils::MakeMaker)
19# Module
20BuildRequires:  perl(Carp)
21BuildRequires:  perl(ExtUtils::Config)
22BuildRequires:  perl(File::Spec)
23BuildRequires:  perl(strict)
24BuildRequires:  perl(warnings)
25# Test Suite
26BuildRequires:  perl(Config)
27BuildRequires:  perl(File::Spec::Functions)
28BuildRequires:  perl(File::Temp)
29BuildRequires:  perl(Test::More)
30# Runtime
31Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
32
33%description
34This module tries to make install path resolution as easy as possible.
35
36When you want to install a module, it needs to figure out where to install
37things. The nutshell version of how this works is that default installation
38locations are determined from ExtUtils::Config, and they may be individually
39overridden by using the install_path attribute. An install_base attribute lets
40you specify an alternative installation root like /home/foo and prefix does
41something similar in a rather different (and more complicated) way. destdir
42lets you specify a temporary installation directory like /tmp/install in case
43you want to create bundled-up installable packages.
44
45%prep
46%setup -q -n ExtUtils-InstallPaths-%{version}
47
48%build
49perl Makefile.PL INSTALLDIRS=vendor
50make %{?_smp_mflags}
51
52%install
53make pure_install DESTDIR=%{buildroot}
54find %{buildroot} -type f -name .packlist -delete
55%{_fixperms} -c %{buildroot}
56
57%check
58make test
59
60%files
61%if 0%{?_licensedir:1}
62%license LICENSE
63%else
64%doc LICENSE
65%endif
66%doc Changes
67%{perl_vendorlib}/ExtUtils/
68%{_mandir}/man3/ExtUtils::InstallPaths.3*
69
70%changelog
71* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.012-5
72- initial build for Vine Linux.
73
74* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.012-4
75- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
76
77* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.012-3
78- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
79
80* Thu Jun 28 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.012-2
81- Perl 5.28 rebuild
82
83* Fri May 11 2018 Paul Howarth <paul@city-fan.org> - 0.012-1
84- Update to 0.012
85  - Allow an argument to install_map with source dirs
86  - Make tests prove and 5.6 friendly
87- Release tests moved to xt/, so don't bother with them
88- Simplify find command using -delete
89- Drop EL-5 support
90  - Drop BuildRoot: and Group: tags
91  - Drop explicit buildroot cleaning in %%install section
92  - Drop explicit %%clean section
93
94* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.011-12
95- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
96
97* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.011-11
98- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
99
100* Wed Jun 07 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.011-10
101- Perl 5.26 re-rebuild of bootstrapped packages
102
103* Sun Jun 04 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.011-9
104- Perl 5.26 rebuild
105
106* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.011-8
107- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
108
109* Wed May 18 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.011-7
110- Perl 5.24 re-rebuild of bootstrapped packages
111
112* Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.011-6
113- Perl 5.24 rebuild
114
115* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.011-5
116- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
117
118* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.011-4
119- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
120
121* Wed Jun 10 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.011-3
122- Perl 5.22 re-rebuild of bootstrapped packages
123
124* Thu Jun 04 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.011-2
125- Perl 5.22 rebuild
126
127* Mon Feb 16 2015 Paul Howarth <paul@city-fan.org> - 0.011-1
128- Update to 0.011
129  - Make EU::IP compatible with perl 5.6
130  - Declare dependency on File::Spec 0.83 for case_sensitive
131- Use %%license where possible
132- Don't attempt to run the release tests on old EL versions prior to EL-7 as
133  they require Test::Pod ≥ 1.41
134
135* Sun Sep 07 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.010-4
136- Perl 5.20 re-rebuild of bootstrapped packages
137
138* Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.010-3
139- Perl 5.20 rebuild
140
141* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.010-2
142- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
143
144* Tue Oct 29 2013 Paul Howarth <paul@city-fan.org> - 0.010-1
145- Update to 0.010
146  - Deprecated usage of legacy configuration variables
147  - Generate default paths more dynamically
148
149* Wed Sep  4 2013 Paul Howarth <paul@city-fan.org> - 0.009-6
150- Skip the release tests when bootstrapping
151
152* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.009-5
153- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
154
155* Tue Jul 23 2013 Petr Pisar <ppisar@redhat.com> - 0.009-4
156- Perl 5.18 rebuild
157
158* Tue Apr 16 2013 Paul Howarth <paul@city-fan.org> - 0.009-3
159- Drop non-dual-lived buildreqs (#947454)
160
161* Mon Apr  1 2013 Paul Howarth <paul@city-fan.org> - 0.009-2
162- Sanitize for Fedora submission
163
164* Sun Mar 31 2013 Paul Howarth <paul@city-fan.org> - 0.009-1
165- Initial RPM version
Note: See TracBrowser for help on using the repository browser.