source: projects/specs/trunk/p/perl-Exporter-Tiny/perl-Exporter-Tiny-vl.spec @ 12120

Revision 12120, 6.4 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1# Test::Warnings introduced in Fedora 18
2%if 0%{?fedora} < 18 && 0%{?rhel} < 7
3%global no_test_warnings 1
4%else
5%global no_test_warnings 0
6%endif
7
8Name:           perl-Exporter-Tiny
9Version:        1.002001
10Release:        3%{?_dist_release}
11Summary:        An exporter with the features of Sub::Exporter but only core dependencies
12License:        GPL+ or Artistic
13URL:            https://metacpan.org/release/Exporter-Tiny
14Source0:        https://cpan.metacpan.org/modules/by-module/Exporter/Exporter-Tiny-%{version}.tar.gz
15BuildArch:      noarch
16# Module Build
17BuildRequires:  coreutils
18BuildRequires:  findutils
19BuildRequires:  make
20BuildRequires:  perl >= 2:5.26.2
21BuildRequires:  perl(ExtUtils::MakeMaker)
22# Module Runtime
23BuildRequires:  perl(Carp)
24BuildRequires:  perl(strict)
25BuildRequires:  perl(warnings)
26# Test Suite
27BuildRequires:  perl(lib)
28BuildRequires:  perl(Test::More)
29# Optional Tests
30BuildRequires:  perl(Test::Fatal)
31%if ! %{no_test_warnings}
32BuildRequires:  perl(Test::Warnings)
33%endif
34# Runtime
35Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
36Requires:       perl(Carp)
37
38Vendor:        Project Vine
39Distribution:  Vine Linux
40
41# Avoid doc-file dependency on perl(base)
42%{?perl_default_filter}
43
44%description
45Exporter::Tiny supports many of Sub::Exporter's external-facing features
46including renaming imported functions with the -as, -prefix and -suffix
47options; explicit destinations with the into option; and alternative
48installers with the installer option. But it's written in only about 40%%
49as many lines of code and with zero non-core dependencies.
50
51Its internal-facing interface is closer to Exporter.pm, with configuration
52done through the @EXPORT, @EXPORT_OK and %%EXPORT_TAGS package variables.
53
54Exporter::Tiny performs most of its internal duties (including resolution of
55tag names to sub names, resolution of sub names to coderefs, and installation
56of coderefs into the target package) as method calls, which means they can be
57overridden to provide interesting behavior.
58
59%prep
60%setup -q -n Exporter-Tiny-%{version}
61
62%build
63perl Makefile.PL INSTALLDIRS=vendor
64make %{?_smp_mflags}
65
66%install
67make pure_install DESTDIR=%{buildroot}
68find %{buildroot} -type f -name .packlist -delete
69%{_fixperms} -c %{buildroot}
70
71%check
72make test
73
74%files
75%if 0%{?_licensedir:1}
76%license COPYRIGHT LICENSE
77%else
78%doc COPYRIGHT LICENSE
79%endif
80%doc Changes CREDITS examples/ README TODO
81%{perl_vendorlib}/Exporter/
82%{_mandir}/man3/Exporter::Tiny.3*
83%{_mandir}/man3/Exporter::Tiny::Manual::Etc.3*
84%{_mandir}/man3/Exporter::Tiny::Manual::Exporting.3*
85%{_mandir}/man3/Exporter::Tiny::Manual::Importing.3*
86%{_mandir}/man3/Exporter::Tiny::Manual::QuickStart.3*
87%{_mandir}/man3/Exporter::Shiny.3*
88
89%changelog
90* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net>
91- initial build for Vine Linux.
92- rebuilt with perl-5.26.
93
94* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.002001-2
95- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
96
97* Wed Jul 18 2018 Paul Howarth <paul@city-fan.org> - 1.002001-1
98- Update to 1.002001
99  - Added support for generating and exporting non-code symbols such as $Foo,
100    @Bar, and %%Baz
101  - Improved test coverage, up from 88.78%% on coveralls.io to 96.74%%
102
103* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.000000-6
104- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
105
106* Thu Jun 28 2018 Jitka Plesnikova <jplesnik@redhat.com> - 1.000000-5
107- Perl 5.28 rebuild
108
109* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.000000-4
110- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
111
112* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.000000-3
113- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
114
115* Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 1.000000-2
116- Perl 5.26 rebuild
117
118* Mon May 22 2017 Paul Howarth <paul@city-fan.org> - 1.000000-1
119- Update to 1.000000
120  - Repackage as 1.000000
121- All shipped files are now GPL+ or Artistic
122- Drop EL-5 support
123  - Drop BuildRoot: and Group: tags
124  - Drop explicit buildroot cleaning in %%install section
125  - Drop explicit %%clean section
126
127* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.044-2
128- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
129
130* Mon Jan 30 2017 Paul Howarth <paul@city-fan.org> - 0.044-1
131- Update to 0.044
132  - Support { -as => CODE } to programmatically rename functions
133  - Restructure documentation
134- Simplify find command using -delete
135
136* Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.042-6
137- Perl 5.24 rebuild
138
139* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.042-5
140- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
141
142* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.042-4
143- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
144
145* Sat Jun 06 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.042-3
146- Perl 5.22 rebuild
147
148* Fri Mar  6 2015 Paul Howarth <paul@city-fan.org> - 0.042-2
149- Correct license tagging (#1199491)
150
151* Thu Oct  9 2014 Paul Howarth <paul@city-fan.org> - 0.042-1
152- Update to 0.042
153  - Add an 'unimport' feature
154  - Option validation needs to happen after expanding tags
155  - Housekeeping on %%TRACKED
156
157* Wed Sep 17 2014 Paul Howarth <paul@city-fan.org> - 0.040-1
158- Update to 0.040
159  - Document warning and error messages produced by Exporter::Tiny
160  - Exporter::Tiny would previously cause B.pm to be loaded into memory any
161    time it exported anything: it no longer does
162  - No longer die when redefining locally defined subs
163  - Warn when redefining any subs
164- Use %%license where possible
165
166* Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.038-3
167- Perl 5.20 rebuild
168
169* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.038-2
170- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
171
172* Fri Apr  4 2014 Paul Howarth <paul@city-fan.org> - 0.038-1
173- Update to 0.038
174  - Added: Support Exporter.pm's import negation syntax qw( !foo )
175  - Added: Support Exporter.pm's regexp import syntax qw( /foo/ )
176  - Fix minor error in documentation of generators
177  - Improved handling of hashrefs of options passed to tags, and hashrefs of
178    options found within %%EXPORT_TAGS arrayrefs
179  - Only attempt to merge hashes if we're sure they're both really hashes!
180
181* Mon Mar 17 2014 Paul Howarth <paul@city-fan.org> - 0.036-2
182- Sanitize for Fedora submission
183
184* Thu Mar 13 2014 Paul Howarth <paul@city-fan.org> - 0.036-1
185- Initial RPM version
Note: See TracBrowser for help on using the repository browser.