source: projects/specs/trunk/p/perl-Eval-Closure/perl-Eval-Closure-vl.spec @ 12120

Revision 12120, 3.6 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-Eval-Closure
2Version:        0.14
3Release:        1%{?_dist_release}
4Summary:        Safely and cleanly create closures via string eval
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/Eval-Closure/
8Source0:        http://www.cpan.org/authors/id/D/DO/DOY/Eval-Closure-%{version}.tar.gz
9
10Vendor:        Project Vine
11Distribution:  Vine Linux
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
14BuildArch:      noarch
15BuildRequires:  perl(ExtUtils::MakeMaker)
16BuildRequires:  perl(PadWalker)
17BuildRequires:  perl(Perl::Tidy)
18BuildRequires:  perl(Scalar::Util)
19BuildRequires:  perl(Sub::Exporter)
20BuildRequires:  perl(Test::Fatal)
21BuildRequires:  perl(Test::More)
22BuildRequires:  perl(Test::Output)
23BuildRequires:  perl(Test::Requires)
24BuildRequires:  perl(Try::Tiny)
25Requires:       perl(Perl::Tidy)
26Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
27
28%{?perl_default_filter}
29
30%description
31String eval is often used for dynamic code generation. For instance, Moose uses
32it heavily, to generate inlined versions of accessors and constructors, which
33speeds code up at runtime by a significant amount. String eval is not without
34its issues however - it's difficult to control the scope it's used in (which
35determines which variables are in scope inside the eval), and it's easy to miss
36compilation errors, since eval catches them and sticks them in $@ instead.
37
38This module attempts to solve these problems. It provides an eval_closure
39function, which evals a string in a clean environment, other than a fixed list
40of specified variables. Compilation errors are rethrown automatically.
41
42%prep
43%setup -q -n Eval-Closure-%{version}
44
45%build
46%{__perl} Makefile.PL INSTALLDIRS=vendor
47make %{?_smp_mflags}
48
49%install
50rm -rf %{buildroot}
51
52make pure_install DESTDIR=%{buildroot}
53
54find %{buildroot} -type f -name .packlist -exec rm -f {} \;
55find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
56
57%{_fixperms} %{buildroot}/*
58
59%check
60make test
61
62%clean
63rm -rf %{buildroot}
64
65%files
66%doc Changes LICENSE README
67%{perl_vendorlib}/*
68%{_mandir}/man3/*
69
70%changelog
71* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.14-1
72- new upstream release.
73- rebuilt with perl-5.26.
74
75* Fri Dec 19 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.11-1
76- updated to 0.11
77- built with perl 5.16.3
78
79* Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.08-1
80- initial build for Vine Linux
81
82* Fri Feb 10 2012 Iain Arnell <iarnell@gmail.com> 0.08-1
83- update to latest upstream version
84
85* Sat Feb 04 2012 Iain Arnell <iarnell@gmail.com> 0.07-1
86- update to latest upstream version
87- update description
88
89* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.06-3
90- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
91
92* Wed Jun 29 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.06-2
93- Perl mass rebuild
94
95* Tue Jun 07 2011 Iain Arnell <iarnell@gmail.com> 0.06-1
96- update to latest upstream version
97
98* Wed May 04 2011 Iain Arnell <iarnell@gmail.com> 0.05-1
99- update to latest upstream version
100
101* Wed Apr 20 2011 Iain Arnell <iarnell@gmail.com> 0.04-1
102- update to latest upstream version
103
104* Thu Mar 03 2011 Iain Arnell <iarnell@gmail.com> 0.03-1
105- update to latest upstream version
106
107* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-2
108- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
109
110* Fri Jan 28 2011 Iain Arnell <iarnell@gmail.com> 0.02-1
111- update to latest upstream version
112
113* Sun Jan 23 2011 Iain Arnell <iarnell@gmail.com> 0.01-1
114- Specfile autogenerated by cpanspec 1.78.
Note: See TracBrowser for help on using the repository browser.