source: projects/specs/trunk/p/perl-Eval-Closure/perl-Eval-Closure-vl.spec @ 9167

Revision 9167, 3.4 KB checked in by inagaki, 9 years ago (diff)

2014-12-19 Ryoichi INAGAKI <ryo1@…>

  • perl-Authen-{Captcha, Radius, SASL}, perl-DBM-Deep, perl-DateTime?-Format-{HTTP, Mail}, perl-Dist-CheckConflicts?, perl-Eval-Closure, perl-Package-DeprecationManager?, perl-Regexp-Common, perl-Term-ReadLine?-Gnu, perl-Text-Template: updated
  • perl-DateTime?-Format-{IBeat, W3CDTF}, perl-Declare-Constraints-Simple, perl-Text-Markdown: rebuilt
  • perl-String-Random: NEW


Line 
1Name:           perl-Eval-Closure
2Version:        0.11
3Release:        1%{?_dist_release}
4Summary:        Safely and cleanly create closures via string eval
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/Eval-Closure/
8Source0:        http://www.cpan.org/authors/id/D/DO/DOY/Eval-Closure-%{version}.tar.gz
9
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
11BuildArch:      noarch
12BuildRequires:  perl(ExtUtils::MakeMaker)
13BuildRequires:  perl(PadWalker)
14BuildRequires:  perl(Perl::Tidy)
15BuildRequires:  perl(Scalar::Util)
16BuildRequires:  perl(Sub::Exporter)
17BuildRequires:  perl(Test::Fatal)
18BuildRequires:  perl(Test::More) >= 0.88
19BuildRequires:  perl(Test::Output)
20BuildRequires:  perl(Test::Requires)
21BuildRequires:  perl(Try::Tiny)
22Requires:       perl(Perl::Tidy)
23Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
24
25%{?perl_default_filter}
26
27%description
28String eval is often used for dynamic code generation. For instance, Moose uses
29it heavily, to generate inlined versions of accessors and constructors, which
30speeds code up at runtime by a significant amount. String eval is not without
31its issues however - it's difficult to control the scope it's used in (which
32determines which variables are in scope inside the eval), and it's easy to miss
33compilation errors, since eval catches them and sticks them in $@ instead.
34
35This module attempts to solve these problems. It provides an eval_closure
36function, which evals a string in a clean environment, other than a fixed list
37of specified variables. Compilation errors are rethrown automatically.
38
39%prep
40%setup -q -n Eval-Closure-%{version}
41
42%build
43%{__perl} Makefile.PL INSTALLDIRS=vendor
44make %{?_smp_mflags}
45
46%install
47rm -rf %{buildroot}
48
49make pure_install DESTDIR=%{buildroot}
50
51find %{buildroot} -type f -name .packlist -exec rm -f {} \;
52find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
53
54%{_fixperms} %{buildroot}/*
55
56%check
57make test
58
59%clean
60rm -rf %{buildroot}
61
62%files
63%doc Changes LICENSE README
64%{perl_vendorlib}/*
65%{_mandir}/man3/*
66
67%changelog
68* Fri Dec 19 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.11-1
69- updated to 0.11
70- built with perl 5.16.3
71
72* Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.08-1
73- initial build for Vine Linux
74
75* Fri Feb 10 2012 Iain Arnell <iarnell@gmail.com> 0.08-1
76- update to latest upstream version
77
78* Sat Feb 04 2012 Iain Arnell <iarnell@gmail.com> 0.07-1
79- update to latest upstream version
80- update description
81
82* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.06-3
83- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
84
85* Wed Jun 29 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.06-2
86- Perl mass rebuild
87
88* Tue Jun 07 2011 Iain Arnell <iarnell@gmail.com> 0.06-1
89- update to latest upstream version
90
91* Wed May 04 2011 Iain Arnell <iarnell@gmail.com> 0.05-1
92- update to latest upstream version
93
94* Wed Apr 20 2011 Iain Arnell <iarnell@gmail.com> 0.04-1
95- update to latest upstream version
96
97* Thu Mar 03 2011 Iain Arnell <iarnell@gmail.com> 0.03-1
98- update to latest upstream version
99
100* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-2
101- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
102
103* Fri Jan 28 2011 Iain Arnell <iarnell@gmail.com> 0.02-1
104- update to latest upstream version
105
106* Sun Jan 23 2011 Iain Arnell <iarnell@gmail.com> 0.01-1
107- Specfile autogenerated by cpanspec 1.78.
Note: See TracBrowser for help on using the repository browser.