source: projects/specs/trunk/p/perl-Error/perl-Error-vl.spec @ 8730

Revision 8730, 2.7 KB checked in by tomop, 10 years ago (diff)

updated perl modules.

Line 
1%define pkgver 0.17022
2
3Summary: Error/exception handling in an OO-ish way with Perl
4Name: perl-Error
5Version: %{pkgver}
6Release: 1%{?_dist_release}
7License: Aristic and GPL
8Group: Development/Libraries
9Source0: http://search.cpan.org/CPAN/authors/id/U/UA/UARUN/Error-%{pkgver}.tar.gz
10Url: http://search.cpan.org/dist/Error/
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: perl >= 5.005
13Requires: perl >= 5.005
14Vendor: Project Vine
15Distribution: Vine Linux
16BuildArch: noarch
17SUmmary(ja): エラーや例外をオブジェクト指向的に扱う Perl モジュール
18
19%description
20The Error package provides two interfaces. Firstly Error provides
21a procedural interface to exception handling. Secondly Error is a
22base class for errors/exceptions that can either be thrown, for
23subsequent catch, or can simply be recorded.
24
25Errors in the class Error should not be thrown directly, but the
26user should throw errors from a sub-class of Error
27
28%description -l ja
29Errorパッケージはふたつのインターフェースを提供します。まず、
30Errorは例外を扱うための手続き型インターフェースを提供します。
31またErrorは、throw したり、あとでcatchしたり、もしくは単に
32recordしたりするための、エラーや例外のベースクラスとなること
33ができます。
34
35Errorクラスのエラーを直接throwするべきではありません。Errorの
36サブクラスを使ってエラーを投げるようにしてください。
37
38%prep
39%setup -q -n Error-%{pkgver}
40
41%build
42CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
43make
44
45%check
46make test
47
48%clean
49rm -rf %{buildroot}
50
51%install
52rm -rf %{buildroot}
53make DESTDIR=%{buildroot} install
54
55find %{buildroot}%{_prefix} -type f -print |
56        sed "s@^%{buildroot}@@g" |
57        grep -v ^%{_mandir} |
58        grep -v perllocal.pod |
59        grep -v "\.packlist" > %{name}.files
60if [ "$(cat %{name}.files)X" = "X" ] ; then
61    echo "ERROR: EMPTY FILE LIST"
62    exit -1
63fi
64
65%files -f %{name}.files
66%defattr(-,root,root)
67%doc README ChangeLog examples
68%dir %{perl_vendorlib}/Error
69%{_mandir}/*/*
70
71%changelog
72* Thu Jul  3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.17022-1
73- new upstream release.
74- applied versioning presented by upstream.
75
76* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 0.17-2
77- updated to 0.17016
78- add %%{perl_vendorlib}/Error directory in %%files
79
80* Thu Aug 28 2008 Shu KONNO <owa@bg.wakwak.com> 0.17-1vl5
81- applied new versioning policy, spec in utf-8
82- built with perl-5.10.0
83
84* Tue Sep 25 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-0vl1
85- updated to 0.17009
86- changed Group to Development/Libraries
87- install module files to vendor_perl dir
88
89* Sat May 10 2003 IWAI Masaharu <iwai@alib.jp> 0.15-0vl1
90- first build for Vine Linux
Note: See TracBrowser for help on using the repository browser.