source: projects/specs/trunk/p/perl-Dist-CheckConflicts/perl-Dist-CheckConflicts-vl.spec @ 5844

Revision 5844, 3.2 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1Name:           perl-Dist-CheckConflicts
2Version:        0.02
3Release:        1%{?_dist_release}
4Summary:        Declare version conflicts for your dist
5Group:          Development/Libraries
6License:        GPL+ or Artistic
7URL:            http://search.cpan.org/dist/Dist-CheckConflicts/
8Source0:        http://search.cpan.org/CPAN/authors/id/D/DO/DOY/Dist-CheckConflicts-%{version}.tar.gz
9Patch0:         Dist-CheckConflicts-0.02-old-eumm.patch
10Patch1:         Dist-CheckConflicts-0.02-old-Test::More.patch
11BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
12BuildArch:      noarch
13BuildRequires:  perl(Carp)
14BuildRequires:  perl(ExtUtils::MakeMaker)
15BuildRequires:  perl(List::MoreUtils) >= 0.12
16BuildRequires:  perl(Pod::Coverage::TrustPod)
17BuildRequires:  perl(Sub::Exporter)
18BuildRequires:  perl(Test::EOL)
19BuildRequires:  perl(Test::Fatal)
20BuildRequires:  perl(Test::More)
21BuildRequires:  perl(Test::NoTabs)
22BuildRequires:  perl(Test::Pod)
23BuildRequires:  perl(Test::Pod::Coverage)
24Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
25
26%description
27One shortcoming of the CPAN clients that currently exist is that they have no
28way of specifying conflicting downstream dependencies of modules. This module
29attempts to work around this issue by allowing you to specify conflicting
30versions of modules separately, and deal with them after the module is done
31installing.
32
33For instance, say you have a module Foo, and some other module Bar uses Foo. If
34Foo were to change its API in a non-backwards-compatible way, this would cause
35Bar to break until it is updated to use the new API. Foo can't just depend on
36the fixed version of Bar, because this will cause a circular dependency
37(because Bar is already depending on Foo), and this doesn't express intent
38properly anyway - Foo doesn't use Bar at all. The ideal solution would be for
39there to be a way to specify conflicting versions of modules in a way that would
40let CPAN clients update conflicting modules automatically after an existing
41module is upgraded, but until that happens, this module will allow users to do
42this manually.
43
44%prep
45%setup -q -n Dist-CheckConflicts-%{version}
46
47%build
48perl Makefile.PL INSTALLDIRS=vendor
49make %{?_smp_mflags}
50
51%install
52rm -rf %{buildroot}
53make pure_install DESTDIR=%{buildroot}
54find %{buildroot} -type f -name .packlist -exec rm -f {} \;
55find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
56%{_fixperms} %{buildroot}
57
58%check
59make test RELEASE_TESTING=1
60
61%clean
62rm -rf %{buildroot}
63
64%files
65%defattr(-,root,root,-)
66%doc Changes LICENSE README
67%{perl_vendorlib}/Dist/
68%{_mandir}/man3/Dist::CheckConflicts.3pm*
69
70%changelog
71* Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.02-1
72- initial build for Vine Linux
73
74* Wed Jan 11 2012 Paul Howarth <paul@city-fan.org> - 0.02-5
75- Pod::Coverage::TrustPod now available in all supported releases
76- BR: perl(Carp)
77
78* Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 0.02-4
79- Perl mass rebuild
80
81* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-3
82- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
83
84* Wed Jan  5 2011 Paul Howarth <paul@city-fan.org> - 0.02-2
85- Sanitize for Fedora submission
86
87* Tue Jan  4 2011 Paul Howarth <paul@city-fan.org> - 0.02-1
88- Initial RPM version
Note: See TracBrowser for help on using the repository browser.