source: projects/specs/trunk/p/perl-Digest-SHA1/perl-Digest-SHA1-vl.spec @ 521

Revision 521, 2.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define real_name Digest-SHA1
2
3Summary: Digest-SHA1 Perl module
4Name: perl-Digest-SHA1
5Version: 2.12
6Release: 1%{_dist_release}
7License: distributable
8Group: Development/Libraries
9URL: http://search.cpan.org/dist/Digest-SHA1/
10
11Source: http://www.cpan.org/modules/by-module/Digest/Digest-SHA1-%{version}.tar.gz
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13
14BuildRequires: perl >= 0:5.10.0
15Requires: perl >= 0:5.10.0
16
17%description
18The Digest::SHA1 module allows you to use the NIST SHA-1 message
19digest algorithm from within Perl programs. The algorithm takes as
20input a message of arbitrary length and produces as output a 160-bit
21"fingerprint" or "message digest" of the input.
22
23The Digest::SHA1 module provide a procedural interface for simple use,
24as well as an object oriented interface that can handle messages of
25arbitrary length and which can read files directly.
26
27A binary digest will be 20 bytes long. A hex digest will be 40
28characters long. A base64 digest will be 27 characters long.
29
30%prep
31%setup -n %{real_name}-%{version}
32
33%build
34CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS="vendor" PREFIX="%{buildroot}%{_prefix}"
35%{__make} %{?_smp_mflags} OPTIMIZE="%{optflags}"
36
37%install
38%{__rm} -rf %{buildroot}
39%makeinstall
40
41### Clean up buildroot
42%{__rm} -rf %{buildroot}%{perl_archlib} %{buildroot}%{perl_vendorarch}/auto/*{,/*{,/*}}/.packlist
43
44%clean
45%{__rm} -rf %{buildroot}
46
47%files
48%defattr(-, root, root, 0755)
49%doc Changes MANIFEST README fip180-1*
50%doc %{_mandir}/man3/*.3pm*
51%dir %{perl_vendorarch}/Digest/
52%{perl_vendorarch}/Digest/SHA1.pm
53%dir %{perl_vendorarch}/auto/Digest/
54%{perl_vendorarch}/auto/Digest/SHA1/
55
56%changelog
57* Wed Jul  8 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.12-1
58- new upstream release.
59
60* Tue Apr 29 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> - 2.11-2
61- rebuilt with perl-5.10.0.
62
63* Sat Sep 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.11-1vl1
64- Initial built for Vine Linux
65
66* Mon Sep 18 2006 Dries Verachtert <dries@ulyssis.org> - 2.11-1
67- Updated to release 2.11.
68
69* Sat Apr 08 2006 Dries Verachtert <dries@ulyssis.org> - 2.10-1.2
70- Rebuild for Fedora Core 5.
71
72* Fri Mar 18 2005 Dag Wieers <dag@wieers.com> - 2.10-1
73- Cosmetic cleanup.
74
75* Thu Mar 18 2004 Dag Wieers <dag@wieers.com> - 2.07-1
76- Updated to release 2.07.
77
78* Sun Jan 26 2003 Dag Wieers <dag@wieers.com> - 2.03-0
79- Initial package. (using DAR)
Note: See TracBrowser for help on using the repository browser.