source: projects/specs/trunk/p/perl-Digest-HMAC/perl-Digest-HMAC-vl.spec @ 521

Revision 521, 2.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _use_internal_dependency_generator 0
2
3Name: perl-Digest-HMAC
4Version: 1.01
5Release: 14%{_dist_release}
6Summary: Digest-HMAC Perl module
7License: distributable
8Group: Development/Libraries
9URL: http://search.cpan.org/search?mode=module&query=Digest%3a%3aHMAC
10BuildRoot: %{_tmppath}/%{name}-root
11BuildRequires: perl >= 0:5.00503
12Source0: Digest-HMAC-%{version}.tar.gz
13BuildArch: noarch
14
15BuildRequires: perl(Digest::SHA1)
16BuildRequires: perl(Digest::MD5)
17Requires: perl(Digest::SHA1) perl(Digest::MD5)
18
19%description
20HMAC is used for message integrity checks between two parties that
21share a secret key, and works in combination with some other Digest
22algorithm, usually MD5 or SHA-1. The HMAC mechanism is described in
23RFC 2104.
24
25HMAC follow the common Digest:: interface, but the constructor takes
26the secret key and the name of some other simple Digest:: as argument.
27
28%prep
29%setup -q -n Digest-HMAC-%{version}
30
31%build
32CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
33make
34
35%clean
36rm -rf $RPM_BUILD_ROOT
37
38%install
39rm -rf $RPM_BUILD_ROOT
40#eval `perl '-V:installarchlib'`
41#mkdir -p $RPM_BUILD_ROOT/$installarchlib
42make DESTDIR=$RPM_BUILD_ROOT install
43
44[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
45
46find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
47
48find $RPM_BUILD_ROOT/usr -type f -print | \
49        sed "s@^$RPM_BUILD_ROOT@@g" | \
50        grep -v perllocal.pod | \
51        grep -v "\.packlist" > Digest-HMAC-%{version}-filelist
52if [ "$(cat Digest-HMAC-%{version}-filelist)X" = "X" ] ; then
53    echo "ERROR: EMPTY FILE LIST"
54    exit -1
55fi
56
57%check
58make test
59
60%files -f Digest-HMAC-%{version}-filelist
61%defattr(-,root,root)
62
63%changelog
64* Tue Apr 29 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> - 1.01-14
65- built with perl-5.10.0.
66
67* Tue Sep 25 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.01-13vl4
68- added %check
69- changed Group to Development/Libraries
70
71* Mon Oct 09 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
72- 1.01-13vl3
73- rebuild for VineSeed / Vine 4.0
74- changed Group to Development/Languages
75- installs to vendor_arch directory
76
77* Thu Oct 05 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
78- 1.01-13vl2
79- change install dir (remove vender)
80
81* Thu Oct 05 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
82- 1.01-13vl1
83- rebuild fot Vine 3.2
84
85* Wed Sep 22 2004 Chip Turner <cturner@redhat.com> 1.01-13
86- rebuild
87
88* Fri Apr 23 2004 Chip Turner <cturner@redhat.com> 1.01-12
89- bump
90
91* Mon Jan 27 2003 Chip Turner <cturner@redhat.com>
92- version bump and rebuild
93
94* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
95- automated release bump and build
96
97* Thu Jun 27 2002 Chip Turner <cturner@redhat.com>
98- description update
99
100* Wed Jun 26 2002 cturner@redhat.com
101- Specfile autogenerated
102
Note: See TracBrowser for help on using the repository browser.