source: projects/specs/trunk/p/perl-Declare-Constraints-Simple/perl-Declare-Constraints-Simple-vl.spec @ 5859

Revision 5859, 4.6 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1Name:           perl-Declare-Constraints-Simple
2Version:        0.03
3Release:        1%{?_dist_release}
4Summary:        Declarative Validation of Data Structures
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/Declare-Constraints-Simple/
8Source0:        http://search.cpan.org/CPAN/authors/id/P/PH/PHAYLON/Declare-Constraints-Simple-%{version}.tar.gz
9BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
10BuildArch:      noarch
11# Build
12BuildRequires:  perl(ExtUtils::MakeMaker)
13# Module
14BuildRequires:  perl(aliased)
15BuildRequires:  perl(Carp::Clan)
16BuildRequires:  perl(Class::Inspector)
17BuildRequires:  perl(Scalar::Util)
18# Test suite
19BuildRequires:  perl(Test::More)
20BuildRequires:  perl(Test::Pod)
21BuildRequires:  perl(Test::Pod::Coverage)
22# Runtime
23Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
24
25%if "%{_dist_release}" > "vl6"
26# Filter unwanted Requires: (rpm 4.9 onwards)
27%global __requires_exclude ^perl\\(Declare::Constraints::Simple-Library\\)
28%else
29# Filter unwanted Requires (prior to rpm 4.9)
30%global reqfilt /bin/sh -c "%{__perl_requires} | grep -Fvx 'perl(Declare::Constraints::Simple-Library)'"
31%define __perl_requires %{reqfilt}
32%endif
33
34%description
35The main purpose of this module is to provide an easy way to build a
36profile to validate a data structure. It does this by giving you a set of
37declarative keywords in the importing namespace.
38
39%prep
40%setup -q -n Declare-Constraints-Simple-%{version}
41
42%build
43%{__perl} Makefile.PL INSTALLDIRS=vendor
44make %{?_smp_mflags}
45
46%install
47rm -rf %{buildroot}
48make pure_install DESTDIR=%{buildroot}
49find %{buildroot} -type f -name .packlist -exec rm -f {} \;
50find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
51%{_fixperms} %{buildroot}
52
53%check
54make test
55
56%clean
57rm -rf %{buildroot}
58
59%files
60%defattr(-,root,root,-)
61%doc Changes README t/
62%{perl_vendorlib}/Declare/
63%{_mandir}/man3/Declare::Constraints::Simple.3pm*
64%{_mandir}/man3/Declare::Constraints::Simple::Library.3pm*
65%{_mandir}/man3/Declare::Constraints::Simple::Library::Array.3pm*
66%{_mandir}/man3/Declare::Constraints::Simple::Library::Base.3pm*
67%{_mandir}/man3/Declare::Constraints::Simple::Library::Exportable.3pm*
68%{_mandir}/man3/Declare::Constraints::Simple::Library::General.3pm*
69%{_mandir}/man3/Declare::Constraints::Simple::Library::Hash.3pm*
70%{_mandir}/man3/Declare::Constraints::Simple::Library::Numerical.3pm*
71%{_mandir}/man3/Declare::Constraints::Simple::Library::OO.3pm*
72%{_mandir}/man3/Declare::Constraints::Simple::Library::Operators.3pm*
73%{_mandir}/man3/Declare::Constraints::Simple::Library::Referencial.3pm*
74%{_mandir}/man3/Declare::Constraints::Simple::Library::Scalar.3pm*
75%{_mandir}/man3/Declare::Constraints::Simple::Result.3pm*
76
77%changelog
78* Thu Mar 08 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.03-1
79- initial build for Vine Linux
80
81* Mon Jan 23 2012 Paul Howarth <paul@city-fan.org> - 0.03-15
82- Spec clean-up
83  - Make %%files list more explicit
84  - Classify buildreqs by build/module/test
85  - Use search.cpan.org source URL
86  - Don't use macros for commands
87  - Use tabs
88
89* Wed Jan 11 2012 Paul Howarth <paul@city-fan.org> - 0.03-14
90- Spec clean-up
91  - Simplify pre-rpm-4.9 provides filter
92  - Use DESTDIR rather than PERL_INSTALL_ROOT
93  - Make %%files list more specific
94
95* Wed Jun 29 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.03-13
96- Perl mass rebuild
97
98* Sun Feb 13 2011 Paul Howarth <paul@city-fan.org> - 0.03-12
99- Fix dependency filter for rpm 4.9 onwards
100
101* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.03-11
102- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
103
104* Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.03-10
105- Rebuild to fix problems with vendorarch/lib (#661697)
106
107* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.03-9
108- Mass rebuild with perl-5.12.0
109
110* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.03-8
111- Mass rebuild with perl-5.12.0
112
113* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.03-7
114- Mass rebuild with perl-5.12.0
115
116* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.03-6
117- Rebuild against perl 5.10.1
118
119* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.03-5
120- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
121
122* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.03-4
123- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
124
125* Wed Mar 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.03-3
126- Rebuild for new perl
127
128* Fri May 04 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.03-2
129- Bump
130
131* Tue May 01 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.03-1
132- Specfile autogenerated by cpanspec 1.71
Note: See TracBrowser for help on using the repository browser.