source: projects/specs/trunk/p/perl-Declare-Constraints-Simple/perl-Declare-Constraints-Simple-vl.spec @ 9167

Revision 9167, 4.7 KB checked in by inagaki, 9 years ago (diff)

2014-12-19 Ryoichi INAGAKI <ryo1@…>

  • perl-Authen-{Captcha, Radius, SASL}, perl-DBM-Deep, perl-DateTime?-Format-{HTTP, Mail}, perl-Dist-CheckConflicts?, perl-Eval-Closure, perl-Package-DeprecationManager?, perl-Regexp-Common, perl-Term-ReadLine?-Gnu, perl-Text-Template: updated
  • perl-DateTime?-Format-{IBeat, W3CDTF}, perl-Declare-Constraints-Simple, perl-Text-Markdown: rebuilt
  • perl-String-Random: NEW


Line 
1Name:           perl-Declare-Constraints-Simple
2Version:        0.03
3Release:        2%{?_dist_release}
4Summary:        Declarative Validation of Data Structures
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/Declare-Constraints-Simple/
8Source0:        http://search.cpan.org/CPAN/authors/id/P/PH/PHAYLON/Declare-Constraints-Simple-%{version}.tar.gz
9
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
11BuildArch:      noarch
12# Build
13BuildRequires:  perl(ExtUtils::MakeMaker)
14# Module
15BuildRequires:  perl(aliased)
16BuildRequires:  perl(Carp::Clan)
17BuildRequires:  perl(Class::Inspector)
18BuildRequires:  perl(Scalar::Util)
19# Test suite
20BuildRequires:  perl(Test::More)
21BuildRequires:  perl(Test::Pod)
22BuildRequires:  perl(Test::Pod::Coverage)
23# Runtime
24Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
25
26%if "%{_dist_release}" > "vl6"
27# Filter unwanted Requires: (rpm 4.9 onwards)
28%global __requires_exclude ^perl\\(Declare::Constraints::Simple-Library\\)
29%else
30# Filter unwanted Requires (prior to rpm 4.9)
31%global reqfilt /bin/sh -c "%{__perl_requires} | grep -Fvx 'perl(Declare::Constraints::Simple-Library)'"
32%define __perl_requires %{reqfilt}
33%endif
34
35%description
36The main purpose of this module is to provide an easy way to build a
37profile to validate a data structure. It does this by giving you a set of
38declarative keywords in the importing namespace.
39
40%prep
41%setup -q -n Declare-Constraints-Simple-%{version}
42
43%build
44%{__perl} Makefile.PL INSTALLDIRS=vendor
45make %{?_smp_mflags}
46
47%install
48rm -rf %{buildroot}
49make pure_install DESTDIR=%{buildroot}
50find %{buildroot} -type f -name .packlist -exec rm -f {} \;
51find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
52%{_fixperms} %{buildroot}
53
54%check
55make test
56
57%clean
58rm -rf %{buildroot}
59
60%files
61%defattr(-,root,root,-)
62%doc Changes README t/
63%{perl_vendorlib}/Declare/
64%{_mandir}/man3/Declare::Constraints::Simple.3pm*
65%{_mandir}/man3/Declare::Constraints::Simple::Library.3pm*
66%{_mandir}/man3/Declare::Constraints::Simple::Library::Array.3pm*
67%{_mandir}/man3/Declare::Constraints::Simple::Library::Base.3pm*
68%{_mandir}/man3/Declare::Constraints::Simple::Library::Exportable.3pm*
69%{_mandir}/man3/Declare::Constraints::Simple::Library::General.3pm*
70%{_mandir}/man3/Declare::Constraints::Simple::Library::Hash.3pm*
71%{_mandir}/man3/Declare::Constraints::Simple::Library::Numerical.3pm*
72%{_mandir}/man3/Declare::Constraints::Simple::Library::OO.3pm*
73%{_mandir}/man3/Declare::Constraints::Simple::Library::Operators.3pm*
74%{_mandir}/man3/Declare::Constraints::Simple::Library::Referencial.3pm*
75%{_mandir}/man3/Declare::Constraints::Simple::Library::Scalar.3pm*
76%{_mandir}/man3/Declare::Constraints::Simple::Result.3pm*
77
78%changelog
79* Fri Dec 19 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.03-2
80- rebuilt with perl 5.16.3
81
82* Thu Mar 08 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.03-1
83- initial build for Vine Linux
84
85* Mon Jan 23 2012 Paul Howarth <paul@city-fan.org> - 0.03-15
86- Spec clean-up
87  - Make %%files list more explicit
88  - Classify buildreqs by build/module/test
89  - Use search.cpan.org source URL
90  - Don't use macros for commands
91  - Use tabs
92
93* Wed Jan 11 2012 Paul Howarth <paul@city-fan.org> - 0.03-14
94- Spec clean-up
95  - Simplify pre-rpm-4.9 provides filter
96  - Use DESTDIR rather than PERL_INSTALL_ROOT
97  - Make %%files list more specific
98
99* Wed Jun 29 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.03-13
100- Perl mass rebuild
101
102* Sun Feb 13 2011 Paul Howarth <paul@city-fan.org> - 0.03-12
103- Fix dependency filter for rpm 4.9 onwards
104
105* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.03-11
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
107
108* Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.03-10
109- Rebuild to fix problems with vendorarch/lib (#661697)
110
111* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.03-9
112- Mass rebuild with perl-5.12.0
113
114* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.03-8
115- Mass rebuild with perl-5.12.0
116
117* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.03-7
118- Mass rebuild with perl-5.12.0
119
120* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.03-6
121- Rebuild against perl 5.10.1
122
123* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.03-5
124- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
125
126* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.03-4
127- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
128
129* Wed Mar 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.03-3
130- Rebuild for new perl
131
132* Fri May 04 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.03-2
133- Bump
134
135* Tue May 01 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.03-1
136- Specfile autogenerated by cpanspec 1.71
Note: See TracBrowser for help on using the repository browser.