source: projects/specs/trunk/p/perl-DateTime-TimeZone/perl-DateTime-TimeZone-vl.spec @ 9158

Revision 9158, 4.8 KB checked in by inagaki, 9 years ago (diff)

2014-12-16 Ryoichi INAGAKI <ryo1@…>

  • perl-DateTime?-TimeZone?, perl-LDAP: updated
  • perl-List-AllUtils?, perl-Test-Warnings: NEW
  • perl-Unicode-{Map, Map8, MapUTF8, String}: rebuilt
  • perl-X11-Protocol: rebuilt


Line 
1%global perl_bootstrap 1
2
3Name:           perl-DateTime-TimeZone
4Version:        1.81
5Release:        1%{?_dist_release}
6Summary:        Time zone object base class and factory
7License:        Artistic License 2.0
8Group:          Development/Libraries
9URL:            http://search.cpan.org/dist/DateTime-TimeZone/
10Source0:        http://www.cpan.org/authors/id/D/DR/DROLSKY/DateTime-TimeZone-%{version}.tar.gz
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildArch:      noarch
14BuildRequires:  perl(Class::Load)
15BuildRequires:  perl(Class::Singleton) >= 1.03
16BuildRequires:  perl(constant)
17BuildRequires:  perl(Cwd) >= 3
18BuildRequires:  perl(ExtUtils::MakeMaker)
19BuildRequires:  perl(File::Compare)
20BuildRequires:  perl(File::Spec)
21BuildRequires:  perl(List::AllUtils)
22BuildRequires:  perl(List::Util)
23BuildRequires:  perl(Params::Validate) >= 0.72
24BuildRequires:  perl(parent)
25BuildRequires:  perl(Pod::Man) >= 1.14
26BuildRequires:  perl(Test::Fatal)
27BuildRequires:  perl(Test::More) >= 0.88
28BuildRequires:  perl(Test::Output)
29BuildRequires:  perl(Test::Requires)
30# not automatically detected
31Requires:       perl(Cwd) >= 3
32Requires:       perl(File::Compare)
33Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
34
35%{?filter_setup:
36%filter_from_requires /^perl(Win32/d
37%if 0%{?perl_bootstrap}
38%filter_from_requires /^perl(DateTime\(::Duration\)?)/d
39%endif
40%?perl_default_filter}
41
42%if 0%{?perl_bootstrap}
43# perl-DateTime-TimeZone used to be bundled with perl-DateTime
44# when bootstrapping, we can't require the unbundled version, so
45# need to conflict with the old package
46Conflicts:      perl-DateTime <= 1:0.7000-3
47%else
48# explicitly require the unbundled perl-DateTime to avoid implicit conflicts
49Requires:       perl-DateTime >= 2:0.70-1
50# and BR perl(DateTime) to enable testing
51BuildRequires:  perl(DateTime)
52%endif
53
54%description
55This class is the base class for all time zone objects. A time zone is
56represented internally as a set of observances, each of which describes the
57offset from GMT for a given time period.
58
59%prep
60%setup -q -n DateTime-TimeZone-%{version}
61
62%if "%{_dist_release}" > "vl6"
63
64%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}perl\\(Win32
65
66%if 0%{?perl_bootstrap}
67# avoid circular dependencies - DateTime strictly requires DateTime::TimeZone
68%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}perl\\(DateTime\\)
69%global __requires_exclude %{__requires_exclude}|perl\\(DateTime::Duration\\)
70%endif
71
72%else
73
74cat << \EOF > %{name}-req
75#!/bin/sh
76%{__perl_requires} $* |\
77sed -e '/perl(Win32/d' |\
78EOF
79
80%if 0%{?perl_bootstrap}
81
82cat << \EOF >> %{name}-req
83sed -e '/perl(DateTime)/d' |\
84sed -e '/perl(DateTime::Duration)/d'
85EOF
86
87%endif
88
89%global __perl_requires %{_builddir}/DateTime-TimeZone-%{version}/%{name}-req
90chmod +x %{__perl_requires}
91
92%endif
93
94%build
95%{__perl} Makefile.PL INSTALLDIRS=vendor
96make %{?_smp_mflags}
97
98%install
99make pure_install DESTDIR=%{buildroot}
100
101find %{buildroot} -type f -name .packlist -exec rm -f {} \;
102find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
103
104%{_fixperms} %{buildroot}/*
105
106%check
107make test
108
109%files
110%doc Changes LICENSE README.md
111%{perl_vendorlib}/*
112%{_mandir}/man3/*
113
114%changelog
115* Sun Dec 14 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.81-1
116- updated to 1.81
117- added BR: perl(List::AllUtils), perl(Test::Fatal) and perl(Test::Requires)
118- built with perl 5.16.3 (bootstrap)
119
120* Tue Mar 06 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.45-2
121- now without bootstrapping
122
123* Tue Mar 06 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.45-1
124- initial build for Vine Linux (bootstrap)
125
126* Sun Mar 04 2012 Iain Arnell <iarnell@gmail.com> 1.45-1
127- update to latest upstream version
128
129* Fri Mar 02 2012 Iain Arnell <iarnell@gmail.com> 1.44-1
130- update to latest upstream version - Olson 2012b
131
132* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.42-2
133- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
134
135* Wed Nov 09 2011 Iain Arnell <iarnell@gmail.com> 1.42-1
136- update to latest upstream - Olson 2011n
137
138* Tue Oct 25 2011 Iain Arnell <iarnell@gmail.com> 1.41-1
139- update to latest upstream - Olson 2011m
140
141* Tue Oct 11 2011 Iain Arnell <iarnell@gmail.com> 1.40-1
142- update to latest upstream - Olson 2011l
143
144* Tue Sep 27 2011 Iain Arnell <iarnell@gmail.com> 1.39-1
145- update to latest upstream - Olson 2011k
146
147* Wed Sep 14 2011 Iain Arnell <iarnell@gmail.com> 1.37-1
148- update to latest upstream - Olson 2011j
149
150* Tue Aug 30 2011 Iain Arnell <iarnell@gmail.com> 1.36-1
151- update to latest upstream - Olson 2011i
152
153* Thu Aug 18 2011 Iain Arnell <iarnell@gmail.com> 1.35-3
154- rebuild against unbunled perl-DateTime
155
156* Mon Aug 15 2011 Iain Arnell <iarnell@gmail.com> 1.35-2
157- additional explicit (build)requires for core modules
158
159* Mon Aug 15 2011 Iain Arnell <iarnell@gmail.com> 1.35-1
160- Specfile autogenerated by cpanspec 1.78.
161- Add bootstrapping logic
Note: See TracBrowser for help on using the repository browser.