source: projects/specs/trunk/p/perl-DateTime-Format-Mail/perl-DateTime-Format-Mail-vl.spec @ 5871

Revision 5871, 4.7 KB checked in by shaolin, 12 years ago (diff)
  • perl-XML-XPath, perl-Test-Manifest, perl-XML-RSS
    • update and/or rebuild
  • others: new packages
Line 
1Name:           perl-DateTime-Format-Mail
2Version:        0.3001       
3Release:        1%{?_dist_release}
4Summary:        Convert between DateTime and RFC2822/822 formats
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic       
8URL:            http://search.cpan.org/dist/DateTime-Format-Mail           
9Source0: http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/DateTime-Format-Mail-%{version}.tar.gz       
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11
12BuildArch:      noarch
13BuildRequires:  perl(Class::ISA)
14BuildRequires:  perl(Module::Build), perl(DateTime)
15BuildRequires:  perl(Params::Validate) >= 0.67, perl(Test::More) >= 0.47
16BuildRequires:  perl(File::Find::Rule)
17
18Requires:  perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
19
20# DateTime >= 0.1705 plays havoc with rpm's versioning system
21Requires:       perl(DateTime) >= 0.18
22
23%if "%{_dist_release}" > "vl6"
24%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}perl\\(DateTime\\)
25%else
26%global provfilt /bin/sh -c "%{__perl_provides} | grep -Ev 'perl[(]DateTime[)]'"
27%define __perl_provides %{provfilt}
28%endif
29
30%description
31RFCs 2822 and 822 specify date formats to be used by email. This module parses
32and emits such dates.
33
34RFC2822 (April 2001) introduces a slightly different format of date than that
35used by RFC822 (August 1982). The main correction is that the preferred format
36is more limited, and thus easier to parse programmatically.
37
38Despite the ease of generating and parsing perfectly valid RFC822 and RFC2822
39people still get it wrong. This module aims to correct that.
40
41
42%prep
43%setup -q -n DateTime-Format-Mail-%{version}
44
45# POD doesn't like E<copy> very much...
46perl -pi -e 's/E<copy>/(C)/' `find lib/ -type f`
47
48# DateTime >= 0.1705 plays havoc with rpm's versioning system
49for X in lib/DateTime/Format/Mail.pm META.yml Build.PL ; do
50sed -i -e 's/0\.1705/0.70/g' $X
51done
52
53%build
54%{__perl} Makefile.PL INSTALLDIRS=vendor
55make %{?_smp_mflags}
56
57# American English, bitte
58mv LICENCE LICENSE
59
60%install
61rm -rf %{buildroot}
62make pure_install PERL_INSTALL_ROOT=%{buildroot}
63find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
64find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
65chmod -R u+w %{buildroot}/*
66
67
68%check
69# we don't have a SIGNATURE, regardless of perl(Test::Signature) being around
70rm t/00signature.t
71
72make test
73
74
75%clean
76rm -rf %{buildroot}
77
78
79%files
80%defattr(-,root,root,-)
81%doc Artistic COPYING LICENSE Changes AUTHORS README CREDITS
82%doc t/sample_dates t/invalid.t
83%{perl_vendorlib}/*
84%{_mandir}/man3/*.3*
85
86
87%changelog
88* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.3001-1
89- initial build for Vine Linux
90
91* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3001-13
92- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
93
94* Wed Jul 20 2011 Iain Arnell <iarnell@gmail.com> - 0.3001-12
95- update filtering macros for rpm 4.9
96
97* Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 0.3001-11
98- Perl mass rebuild
99
100* Mon Feb 14 2011 Ralf Corsépius <corsepiu@fedoraproject.org> - 0.3001-10
101- Switch to using perl-filters/Abandon filter-requires.sh
102  (Work around mass rebuild breakdown).
103
104* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3001-9
105- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
106
107* Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.3001-8
108- 661697 rebuild for fixing problems with vendorach/lib
109
110* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.3001-7
111- Mass rebuild with perl-5.12.0
112
113* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.3001-6
114- rebuild against perl 5.10.1
115
116* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3001-5
117- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
118
119* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3001-4
120- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
121
122* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.3001-3
123- Rebuild for perl 5.10 (again)
124
125* Fri Jan 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.3001-2
126- no more notes/ directory
127
128* Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.3001-1
129- 0.3001
130- fix license tag
131- rebuild against new perl
132
133* Thu Aug 31 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.30-4
134- bump for mass rebuild
135
136* Sun Aug 06 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.30-3
137- bump for build and release
138
139* Sun Aug 06 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.30-2
140- add missing br: perl(File::Find::Rule)
141- additional files from the test suite added to %%doc
142
143* Fri Aug 04 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.30-1
144- Initial spec file for F-E
Note: See TracBrowser for help on using the repository browser.