source: projects/specs/trunk/p/perl-DateTime-Format-Builder/perl-DateTime-Format-Builder-vl.spec @ 7292

Revision 7292, 5.7 KB checked in by munepi, 11 years ago (diff)

added perl-DateTime?-Format-HTTP perl-DateTime?-Format-Strptime perl-DateTime?-Format-Builder

Line 
1# Note:  Some tests for this package are disabled by default, as they
2# require network access and would thus fail in the buildsys' mock
3# environments.  To build locally while enabling tests, either:
4#
5#   rpmbuild ... --define '_with_network_tests 1' ...
6#   rpmbuild ... --with network_tests ...
7#   define _with_network_tests 1 in your ~/.rpmmacros
8#
9# Note that right now, the only way to run tests locally from a cvs sandbox
10# "make noarch" type scenario is the third one.
11%define real_version   0.80
12
13Name:           perl-DateTime-Format-Builder
14# 0.80 in reality, but rpm can't get it
15Version:        0.8000
16Release:        1%{?_dist_release}
17Summary:        Create DateTime parser classes and objects       
18
19Group:          Development/Libraries
20License:        GPL+ or Artistic
21URL:            http://search.cpan.org/dist/DateTime-Format-Builder           
22Source0:        http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/DateTime-Format-Builder-%{real_version}.tar.gz       
23
24BuildArch: noarch
25Requires:  perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
26
27## core
28BuildRequires:  perl(Test::More)
29## non-core
30BuildRequires:  perl(Module::Build)
31BuildRequires:  perl(Class::ISA)
32BuildRequires:  perl(Class::Factory::Util)
33BuildRequires:  perl(DateTime)
34BuildRequires:  perl(DateTime::Format::Strptime)
35BuildRequires:  perl(Params::Validate) >= 0.73
36# note -- listed as a BR but _not_ needed with Fedora perl
37#BuildRequires:  perl(Task::Weaken)
38BuildRequires:  perl(Test::Pod)
39## For extended testing
40BuildRequires:  perl(DateTime::Format::HTTP)
41BuildRequires:  perl(DateTime::Format::Mail)
42BuildRequires:  perl(DateTime::Format::IBeat)
43Provides:       perl(DateTime::Format::Builder) = %{version}
44
45# for signature checking
46%{?_with_network_tests:BuildRequires: perl(Module::Signature) }
47
48# not explicitly picked up
49Requires:       perl(DateTime::Format::Strptime)
50
51%{?perl_default_filter}
52
53%description
54DateTime::Format::Builder creates DateTime parsers. Many string formats of
55dates and times are simple and just require a basic regular expression to
56extract the relevant information. Builder provides a simple way to do this
57without writing reams of structural code.
58
59Builder provides a number of methods, most of which you'll never need, or at
60least rarely need. They're provided more for exposing of the module's innards
61to any subclasses, or for when you need to do something slightly beyond what
62is expected.
63
64
65%prep
66%setup -q -n DateTime-Format-Builder-%{real_version}
67
68cat << \EOF > %{name}-req
69#!/bin/sh
70%{__perl_requires} $* |\
71   sed -e '/perl(DateTime::Format::HTTP)/d;/perl(DateTime::Format::IBeat)/d' \
72       -e '/perl(DateTime::Format::Mail)/d'
73EOF
74
75%define __perl_requires %{_builddir}/DateTime-Format-Builder-%{real_version}/%{name}-req
76chmod +x %{__perl_requires}
77
78# digital signature checking.  Not essential, but nice
79%{?_with_network_tests: cpansign -v }
80
81# POD doesn't like E<copy> very much...
82perl -pi -e 's/E<copy>/(C)/' `find lib/ -type f`
83
84# American English
85mv LICENCE LICENSE
86
87
88%build
89%{__perl} Makefile.PL INSTALLDIRS=vendor
90make %{?_smp_mflags}
91
92
93%install
94make pure_install PERL_INSTALL_ROOT=%{buildroot}
95find %{buildroot} -type f -name .packlist -exec rm -f {} +
96find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
97
98%{_fixperms} %{buildroot}/*
99
100
101%check
102make test
103
104
105%files
106%defattr(-,root,root,-)
107%doc COPYING Artistic Changes AUTHORS CREDITS LICENSE README examples/ t/
108%{perl_vendorlib}/*
109%{_mandir}/man3/*.3*
110
111
112%changelog
113* Sun Jan  6 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.8000-1
114- initial build based on Fedora development package
115
116* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8000-10
117- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
118
119* Wed Jun 20 2012 Petr Pisar <ppisar@redhat.com> - 0.8000-9
120- Perl 5.16 rebuild
121
122* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8000-8
123- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
124
125* Thu Jul 21 2011 Petr Sabata <contyk@redhat.com> - 0.8000-7
126- Perl mass rebuild
127
128* Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 0.8000-6
129- Perl mass rebuild
130
131* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8000-5
132- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
133
134* Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.8000-4
135- 661697 rebuild for fixing problems with vendorach/lib
136
137* Sun Dec 12 2010 Iain Arnell <iarnell@gmail.com> 0.8000-3
138- use perl_default_filter
139- clean up spec for modern rpmbuild
140
141* Fri May 14 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.8000-2
142- add provides with rpm version for other packages
143
144* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.8000-1
145- Mass rebuild with perl-5.12.0
146
147* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.7901-5
148- rebuild against perl 5.10.1
149
150* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7901-4
151- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
152
153* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7901-3
154- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
155
156* Tue Mar  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.7901-2
157- rebuild for new perl
158
159* Sat Jan 26 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.7901-1
160- update to 0.7901
161- additional docs
162- some spec rework
163
164* Thu Aug 31 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.7807-4
165- bump for mass rebuild
166
167* Tue Aug 08 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.7807-3
168- bump for release & build, not in that order
169
170* Tue Aug 08 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.7807-2
171- additional br's
172
173* Fri Aug 04 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.7807-1
174- Initial spec file for F-E
Note: See TracBrowser for help on using the repository browser.