source: projects/specs/trunk/p/perl-DateTime-Format-Builder/perl-DateTime-Format-Builder-vl.spec @ 9170

Revision 9170, 5.5 KB checked in by inagaki, 9 years ago (diff)

2014-12-20 Ryoichi INAGAKI <ryo1@…>

  • perl-Class-{Accessor-Fast-Contained, Factory-Util}, perl-IO-String: rebuilt
  • perl-Crypt-{GeneratePassword?, Rijndeal}, perl-DateTime?-Format-{Builder, Strptime}, perl-Number-Compare, perl-Pod-ToDemo?: updated


Line 
1# Note:  Some tests for this package are disabled by default, as they
2# require network access and would thus fail in the buildsys' mock
3# environments.  To build locally while enabling tests, either:
4#
5#   rpmbuild ... --define '_with_network_tests 1' ...
6#   rpmbuild ... --with network_tests ...
7#   define _with_network_tests 1 in your ~/.rpmmacros
8#
9# Note that right now, the only way to run tests locally from a cvs sandbox
10# "make noarch" type scenario is the third one.
11%define real_version   0.81
12
13Name:           perl-DateTime-Format-Builder
14# 0.80 in reality, but rpm can't get it
15Version:        0.8100
16Release:        1%{?_dist_release}
17Summary:        Create DateTime parser classes and objects       
18
19Group:          Development/Libraries
20License:        Artistic 2.0
21URL:            http://search.cpan.org/dist/DateTime-Format-Builder           
22Source0:        http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/DateTime-Format-Builder-%{real_version}.tar.gz       
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25BuildArch:      noarch
26## core
27BuildRequires:  perl(Test::More)
28## non-core
29BuildRequires:  perl(Module::Build)
30BuildRequires:  perl(Class::ISA)
31BuildRequires:  perl(Class::Factory::Util)
32BuildRequires:  perl(DateTime)
33BuildRequires:  perl(DateTime::Format::Strptime)
34BuildRequires:  perl(Params::Validate) >= 0.73
35# note -- listed as a BR but _not_ needed with Fedora perl
36#BuildRequires:  perl(Task::Weaken)
37BuildRequires:  perl(Test::Pod)
38## For extended testing
39BuildRequires:  perl(DateTime::Format::HTTP)
40BuildRequires:  perl(DateTime::Format::Mail)
41BuildRequires:  perl(DateTime::Format::IBeat)
42Provides:       perl(DateTime::Format::Builder) = %{version}
43
44# for signature checking
45%{?_with_network_tests:BuildRequires: perl(Module::Signature) }
46
47Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
48
49%{?perl_default_filter}
50
51%description
52DateTime::Format::Builder creates DateTime parsers. Many string formats of
53dates and times are simple and just require a basic regular expression to
54extract the relevant information. Builder provides a simple way to do this
55without writing reams of structural code.
56
57Builder provides a number of methods, most of which you'll never need, or at
58least rarely need. They're provided more for exposing of the module's innards
59to any subclasses, or for when you need to do something slightly beyond what
60is expected.
61
62
63%prep
64%setup -q -n DateTime-Format-Builder-%{real_version}
65
66# digital signature checking.  Not essential, but nice
67%{?_with_network_tests: cpansign -v }
68
69# POD doesn't like E<copy> very much...
70perl -pi -e 's/E<copy>/(C)/' `find lib/ -type f`
71
72# silence rpmlint
73sed -i '1s~^#!.*perl~#!%{__perl}~' t/*.t
74
75%build
76%{__perl} Makefile.PL INSTALLDIRS=vendor
77make %{?_smp_mflags}
78
79
80%install
81make pure_install PERL_INSTALL_ROOT=%{buildroot}
82find %{buildroot} -type f -name .packlist -exec rm -f {} +
83find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
84
85%{_fixperms} %{buildroot}/*
86
87
88%check
89make test
90
91
92%files
93%defattr(-,root,root,-)
94%doc Changes LICENSE README examples/ t/
95%{perl_vendorlib}/*
96%{_mandir}/man3/*.3*
97
98
99%changelog
100* Sat Dec 20 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.8100-1
101- updated to 0.81
102- built with perl 5.16.3
103
104* Sun Jan  6 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.8000-1
105- initial build based on Fedora development package
106
107* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8000-10
108- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
109
110* Wed Jun 20 2012 Petr Pisar <ppisar@redhat.com> - 0.8000-9
111- Perl 5.16 rebuild
112
113* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8000-8
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
115
116* Thu Jul 21 2011 Petr Sabata <contyk@redhat.com> - 0.8000-7
117- Perl mass rebuild
118
119* Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 0.8000-6
120- Perl mass rebuild
121
122* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8000-5
123- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
124
125* Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.8000-4
126- 661697 rebuild for fixing problems with vendorach/lib
127
128* Sun Dec 12 2010 Iain Arnell <iarnell@gmail.com> 0.8000-3
129- use perl_default_filter
130- clean up spec for modern rpmbuild
131
132* Fri May 14 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.8000-2
133- add provides with rpm version for other packages
134
135* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.8000-1
136- Mass rebuild with perl-5.12.0
137
138* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.7901-5
139- rebuild against perl 5.10.1
140
141* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7901-4
142- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
143
144* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7901-3
145- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
146
147* Tue Mar  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.7901-2
148- rebuild for new perl
149
150* Sat Jan 26 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.7901-1
151- update to 0.7901
152- additional docs
153- some spec rework
154
155* Thu Aug 31 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.7807-4
156- bump for mass rebuild
157
158* Tue Aug 08 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.7807-3
159- bump for release & build, not in that order
160
161* Tue Aug 08 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.7807-2
162- additional br's
163
164* Fri Aug 04 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.7807-1
165- Initial spec file for F-E
Note: See TracBrowser for help on using the repository browser.