source: projects/specs/trunk/p/perl-DateManip/perl-DateManip-vl.spec @ 521

Revision 521, 2.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _use_internal_dependency_generator 0
2
3Summary: A Perl module containing a wide variety of date manipulation routines.
4Name: perl-DateManip
5Version: 5.44
6Release: 0vl1
7License: distributable
8Group: Development/Libraries
9Source0: DateManip-%{version}.tar.gz
10Url: http://search.cpan.org/~sbeck/DateManip/
11BuildRoot: %{_tmppath}/%{name}-%{version}-root/
12BuildRequires: perl >= 5.8.2
13Requires: perl >= 5.8.2
14BuildArch: noarch
15
16%description
17This is a set of routines designed to make any common date/time
18manipulation easy to do.  Operations such as comparing two times,
19calculating a time a given amount of time from another, or parsing
20international times are all easily done.
21
22# Provide perl-specific find-{provides,requires}.
23%define __find_provides /usr/lib/rpm/find-provides.perl
24%define __find_requires /usr/lib/rpm/find-requires.perl
25
26%prep
27%setup -q -n DateManip-%{version}
28
29%build
30CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
31make
32
33%check
34make test
35
36%clean
37rm -rf $RPM_BUILD_ROOT
38
39%install
40rm -rf $RPM_BUILD_ROOT
41mkdir -p $RPM_BUILD_ROOT%{_prefix}
42make DESTDIR=$RPM_BUILD_ROOT install
43
44[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
45
46find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
47
48find $RPM_BUILD_ROOT/usr -type f -print |
49        sed "s@^$RPM_BUILD_ROOT@@g" |
50        grep -v perllocal.pod |
51        grep -v "\.packlist" > DateManip-%{version}-filelist
52if [ "$(cat DateManip-%{version}-filelist)X" = "X" ] ; then
53    echo "ERROR: EMPTY FILE LIST"
54    exit -1
55fi
56
57%files -f DateManip-%{version}-filelist
58%defattr(-,root,root)
59
60%changelog
61* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.44-0vl1
62- new upstream release
63- installed files to vendor_perl
64- changed URL
65
66* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 5.42a-0vl3
67- build on perl-5.8.6-0vl1
68
69* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 5.42a-0vl2
70- rebuilt on perl-5.8.2
71
72* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 5.42a-0vl1
73- new upstream version
74- built on perl-5.8.1
75
76* Sun Apr 29 2003 Satoshi MACHINO <machino@vinelinux.org> 5.40-30vl2
77- build on perl-5.8.0
78
79* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 5.40-30vl1
80- build for VineLinux
81
82* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
83- automated release bump and build
84
85* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
86- automated rebuild
87
88* Fri Dec 7 2001 root <root@redhat.com>
89- Spec file was autogenerated.
Note: See TracBrowser for help on using the repository browser.