source: projects/specs/trunk/p/perl-Date-Manip/perl-Date-Manip-vl.spec @ 5923

Revision 5923, 3.0 KB checked in by shaolin, 12 years ago (diff)
  • new upstream release
Line 
1%define _use_internal_dependency_generator 0
2
3Summary: A Perl module containing a wide variety of date manipulation routines.
4Name: perl-Date-Manip
5Version: 6.31
6Release: 1%{?_dist_release}
7License: GPL+ or Artistic
8Group: Development/Libraries
9Source0: Date-Manip-%{version}.tar.gz
10URL: http://search.cpan.org/~sbeck/DateManip/
11
12BuildArch: noarch
13BuildRoot: %{_tmppath}/%{name}-%{version}-root/
14BuildRequires: perl >= 5.8.2
15BuildRequires:  perl(Carp)
16BuildRequires:  perl(Encode)
17BuildRequires:  perl(Exporter)
18BuildRequires:  perl(IO::File)
19BuildRequires:  perl(Module::Build) >= 0.3600
20BuildRequires:  perl(Storable)
21BuildRequires:  perl(Test::More)
22BuildRequires:  perl(YAML::Syck)
23# Tests only
24BuildRequires:  perl(Test::Inter)
25BuildRequires:  perl(Test::Pod) >= 1.00
26BuildRequires:  perl(Test::Pod::Coverage) >= 1.00
27
28Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
29
30# This package was formerly known as perl-DateManip
31Provides: perl-DateManip = %{version}-%{release}
32Obsoletes: perl-DateManip < 5.48
33
34%description
35This is a set of routines designed to make any common date/time
36manipulation easy to do.  Operations such as comparing two times,
37calculating a time a given amount of time from another, or parsing
38international times are all easily done.
39
40%prep
41%setup -q -n Date-Manip-%{version}
42chmod -x examples/*
43
44%build
45%{__perl} Makefile.PL INSTALLDIRS=vendor
46make %{?_smp_mflags}
47
48%install
49rm -rf %{buildroot}
50make pure_install PERL_INSTALL_ROOT=%{buildroot}
51find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
52find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
53chmod -R u+w %{buildroot}/*
54
55%check
56make test
57
58%clean
59rm -rf %{buildroot}
60
61%files
62%defattr(-,root,root,-)
63%doc HISTORY LICENSE README README.first examples
64%{perl_vendorlib}/Date/
65%{_mandir}/man3/*.3*
66
67%changelog
68* Mon Mar 19 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 6.31-1
69- updated to 6.31
70
71* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 5.54-2vl6
72- build with perl 5.12.3
73- defined __find_{provides,requires} with vl4 and vl5
74
75* Sat Nov  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.54-1
76- changed name to Date-Manip as now used on CPAN
77- new upstream release
78- applied new versioning policy
79
80* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.44-0vl1
81- new upstream release
82- installed files to vendor_perl
83- changed URL
84
85* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 5.42a-0vl3
86- build on perl-5.8.6-0vl1
87
88* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 5.42a-0vl2
89- rebuilt on perl-5.8.2
90
91* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 5.42a-0vl1
92- new upstream version
93- built on perl-5.8.1
94
95* Sun Apr 29 2003 Satoshi MACHINO <machino@vinelinux.org> 5.40-30vl2
96- build on perl-5.8.0
97
98* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 5.40-30vl1
99- build for VineLinux
100
101* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
102- automated release bump and build
103
104* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
105- automated rebuild
106
107* Fri Dec 7 2001 root <root@redhat.com>
108- Spec file was autogenerated.
Note: See TracBrowser for help on using the repository browser.