source: projects/specs/trunk/p/perl-Date-Manip/perl-Date-Manip-vl.spec @ 521

Revision 521, 2.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _use_internal_dependency_generator 0
2
3Summary: A Perl module containing a wide variety of date manipulation routines.
4Name: perl-Date-Manip
5Version: 5.54
6Release: 1%{?_dist_release}
7License: GPL+ or Artistic
8Group: Development/Libraries
9Source0: Date-Manip-%{version}.tar.gz
10URL: http://search.cpan.org/~sbeck/DateManip/
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root/
13BuildRequires: perl >= 5.8.2
14Requires: perl >= 5.8.2
15BuildArch: noarch
16
17# This package was formerly known as perl-DateManip
18Provides: perl-DateManip = %{version}-%{release}
19Obsoletes: perl-DateManip < 5.48
20
21%description
22This is a set of routines designed to make any common date/time
23manipulation easy to do.  Operations such as comparing two times,
24calculating a time a given amount of time from another, or parsing
25international times are all easily done.
26
27# Provide perl-specific find-{provides,requires}.
28%define __find_provides /usr/lib/rpm/find-provides.perl
29%define __find_requires /usr/lib/rpm/find-requires.perl
30
31%prep
32%setup -q -n Date-Manip-%{version}
33
34%build
35CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
36make %{?_smp_mflags}
37
38%install
39rm -rf $RPM_BUILD_ROOT
40mkdir -p $RPM_BUILD_ROOT%{_prefix}
41make DESTDIR=$RPM_BUILD_ROOT install
42
43[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
44
45find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
46
47find $RPM_BUILD_ROOT/usr -type f -print |
48        sed "s@^$RPM_BUILD_ROOT@@g" |
49        grep -v perllocal.pod |
50        grep -v "\.packlist" > Date-Manip-%{version}-filelist
51if [ "$(cat Date-Manip-%{version}-filelist)X" = "X" ] ; then
52    echo "ERROR: EMPTY FILE LIST"
53    exit -1
54fi
55
56%check
57make test
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%files -f Date-Manip-%{version}-filelist
63%defattr(-,root,root)
64
65%changelog
66* Sat Nov  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.54-1
67- changed name to Date-Manip as now used on CPAN
68- new upstream release
69- applied new versioning policy
70
71* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.44-0vl1
72- new upstream release
73- installed files to vendor_perl
74- changed URL
75
76* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 5.42a-0vl3
77- build on perl-5.8.6-0vl1
78
79* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 5.42a-0vl2
80- rebuilt on perl-5.8.2
81
82* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 5.42a-0vl1
83- new upstream version
84- built on perl-5.8.1
85
86* Sun Apr 29 2003 Satoshi MACHINO <machino@vinelinux.org> 5.40-30vl2
87- build on perl-5.8.0
88
89* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 5.40-30vl1
90- build for VineLinux
91
92* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
93- automated release bump and build
94
95* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
96- automated rebuild
97
98* Fri Dec 7 2001 root <root@redhat.com>
99- Spec file was autogenerated.
Note: See TracBrowser for help on using the repository browser.