source: projects/specs/trunk/p/perl-Date-Manip/perl-Date-Manip-vl.spec @ 8699

Revision 8699, 3.1 KB checked in by tomop, 10 years ago (diff)

spamassassin-3.4.0

Line 
1%define _use_internal_dependency_generator 0
2
3Summary: A Perl module containing a wide variety of date manipulation routines.
4Name: perl-Date-Manip
5Version: 6.45
6Release: 1%{?_dist_release}
7License: GPL+ or Artistic
8Group: Development/Libraries
9Source0: Date-Manip-%{version}.tar.gz
10URL: http://search.cpan.org/~sbeck/DateManip/
11
12BuildArch: noarch
13BuildRoot: %{_tmppath}/%{name}-%{version}-root/
14BuildRequires: perl >= 5.16.3
15BuildRequires:  perl(Carp)
16BuildRequires:  perl(Encode)
17BuildRequires:  perl(Exporter)
18BuildRequires:  perl(IO::File)
19BuildRequires:  perl(Module::Build)
20BuildRequires:  perl(Storable)
21BuildRequires:  perl(Test::More)
22BuildRequires:  perl(YAML::Syck)
23# Tests only
24BuildRequires:  perl(Test::Inter)
25BuildRequires:  perl(Test::Pod) >= 1.00
26BuildRequires:  perl(Test::Pod::Coverage) >= 1.00
27
28Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
29
30# This package was formerly known as perl-DateManip
31Provides: perl-DateManip = %{version}-%{release}
32Obsoletes: perl-DateManip < 5.48
33
34%description
35This is a set of routines designed to make any common date/time
36manipulation easy to do.  Operations such as comparing two times,
37calculating a time a given amount of time from another, or parsing
38international times are all easily done.
39
40%prep
41%setup -q -n Date-Manip-%{version}
42chmod -x examples/*
43
44%build
45%{__perl} Makefile.PL INSTALLDIRS=vendor
46make %{?_smp_mflags}
47
48%install
49rm -rf %{buildroot}
50make pure_install PERL_INSTALL_ROOT=%{buildroot}
51find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
52find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
53chmod -R u+w %{buildroot}/*
54
55%check
56make test
57
58%clean
59rm -rf %{buildroot}
60
61%files
62%defattr(-,root,root,-)
63%doc LICENSE README README.first examples
64%{_bindir}/*
65%{perl_vendorlib}/Date/
66%{_mandir}/man1/*.1*
67%{_mandir}/man3/*.3*
68
69%changelog
70* Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.45-1
71- new upstream release.
72
73* Mon Mar 19 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 6.31-1
74- updated to 6.31
75
76* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 5.54-2vl6
77- build with perl 5.12.3
78- defined __find_{provides,requires} with vl4 and vl5
79
80* Sat Nov  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.54-1
81- changed name to Date-Manip as now used on CPAN
82- new upstream release
83- applied new versioning policy
84
85* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.44-0vl1
86- new upstream release
87- installed files to vendor_perl
88- changed URL
89
90* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 5.42a-0vl3
91- build on perl-5.8.6-0vl1
92
93* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 5.42a-0vl2
94- rebuilt on perl-5.8.2
95
96* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 5.42a-0vl1
97- new upstream version
98- built on perl-5.8.1
99
100* Tue Apr 29 2003 Satoshi MACHINO <machino@vinelinux.org> 5.40-30vl2
101- build on perl-5.8.0
102
103* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 5.40-30vl1
104- build for VineLinux
105
106* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
107- automated release bump and build
108
109* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
110- automated rebuild
111
112* Fri Dec 7 2001 root <root@redhat.com>
113- Spec file was autogenerated.
Note: See TracBrowser for help on using the repository browser.