source: projects/specs/trunk/p/perl-Date-Calc/perl-Date-Calc-vl.spec @ 521

Revision 521, 2.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Gregorian calendar date calculations using Perl
2Name: perl-Date-Calc
3Version: 5.4
4Release: 1%{?_dist_release}
5License: distributable
6Group: Development/Libraries
7URL: http://search.cpan.org/search?dist=Date-Calc
8Source0: http://www.cpan.org/authors/id/STBEY/Date-Calc-%{version}.tar.gz
9
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildRequires: perl >= 0:5.00503
12BuildRequires: perl-Bit-Vector >= 6.4
13BuildRequires: perl-Carp-Clan >= 5.3
14Requires: perl-Bit-Vector >= 6.4
15Requires: perl-Carp-Clan >= 5.3
16
17%description
18This package consists of a C library (intended to make life easier for C
19developers) and a Perl module to access this library from Perl.
20
21The library provides all sorts of date calculations based on the Gregorian
22calendar (the one used in all western countries today), thereby complying
23with all relevant norms and standards: ISO/R 2015-1971, DIN 1355 and, to
24some extent, ISO 8601 (where applicable).
25
26The package is designed as an efficient (and fast) toolbox, not a bulky
27ready-made application. It provides extensive documentation and examples
28of use, multi-language support and special functions for business needs.
29
30%prep
31%setup -q -n Date-Calc-%{version}
32
33%build
34CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
35make
36
37%install
38rm -rf $RPM_BUILD_ROOT
39make DESTDIR=$RPM_BUILD_ROOT pure_install
40
41find $RPM_BUILD_ROOT%{perl_vendorarch} -type f -print | \
42        sed "s@^$RPM_BUILD_ROOT@@g" | \
43        grep -v perllocal.pod | \
44        grep -v "\.packlist" > Date-Calc-%{version}-filelist
45if [ "$(cat Date-Calc-%{version}-filelist)X" = "X" ] ; then
46    echo "ERROR: EMPTY FILE LIST"
47    exit -1
48fi
49install -m 0644 blib/man3/* %{buildroot}%{_mandir}/man3
50
51%check
52LANG=C make test
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%files -f Date-Calc-%{version}-filelist
58%defattr(-,root,root)
59%doc CHANGES.txt CREDITS.txt EXAMPLES.txt README.txt TOOLS.txt
60%doc examples tools
61%dir %{perl_vendorarch}/Date
62%dir %{perl_vendorarch}/Date/Calc
63%dir %{perl_vendorarch}/Date/Calendar
64%dir %{perl_vendorarch}/auto/Date/Calc
65%{_mandir}/man3/*
66
67%changelog
68* Sat Nov  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.4-1
69- applied new versioning policy
70- rebuilt with perl-5.10.0
71
72* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 5.4-0vl1
73- new upstream release
74- update {Build,}Requires
75- add Summary and description
76
77* Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 5.3-0vl1
78- version up to 5.3
79- add directories in %%files section
80- add some documents
81- drop %%{perl_sitearch}/Carp ( installed from perl-Bit-Vector )
82
83* Thu Apr 11 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 5.0-15vl2
84- add LANG=C for 'make test'
85
86* Thu Apr 11 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 5.0-15vl1
87- build Rawhide-5.0-15 for Vine Linux
88- added perl-Bit-Vector in {Build,}Requires
89
90* Wed Jan 30 2002 cturner@redhat.com
91- Specfile autogenerated
92
Note: See TracBrowser for help on using the repository browser.