source: projects/specs/trunk/p/perl-Data-OptList/perl-Data-OptList-vl.spec @ 5844

Revision 5844, 4.6 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1Name:           perl-Data-OptList
2Summary:        Parse and validate simple name/value option pairs
3Version:        0.107
4Release:        1%{?_dist_release}
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/Data-OptList/
8Source0:        http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Data-OptList-%{version}.tar.gz
9BuildArch:      noarch
10BuildRequires:  perl(ExtUtils::MakeMaker) >= 6.30
11BuildRequires:  perl(List::Util)
12BuildRequires:  perl(Params::Util)
13BuildRequires:  perl(Sub::Install) >= 0.921
14BuildRequires:  perl(Test::More)
15BuildRequires:  perl(Test::Pod)
16Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
17
18# Obsolete/provide old -tests subpackage (can be removed in F19 development cycle)
19Obsoletes:      %{name}-tests < %{version}-%{release}
20Provides:       %{name}-tests = %{version}-%{release}
21
22%description
23Hashes are great for storing named data, but if you want more than one entry
24for a name, you have to use a list of pairs. Even then, this is really boring
25to write:
26
27$values = [
28    foo => undef,
29    bar => undef,
30    baz => undef,
31    xyz => { ... },
32];
33
34With Data::OptList, you can do this instead:
35
36$values = Data::OptList::mkopt([
37    qw(foo bar baz),
38    xyz => { ... },
39]);
40
41This works by assuming that any defined scalar is a name and any reference
42following a name is its value.
43
44%prep
45%setup -q -n Data-OptList-%{version}
46
47%build
48perl Makefile.PL INSTALLDIRS=vendor
49make %{?_smp_mflags}
50
51%install
52make pure_install DESTDIR=%{buildroot}
53find %{buildroot} -type f -name .packlist -exec rm -f {} \;
54find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
55%{_fixperms} %{buildroot}
56
57%check
58make test RELEASE_TESTING=1
59
60%files
61%doc Changes LICENSE README t/
62%{perl_vendorlib}/Data/
63%{_mandir}/man3/Data::OptList.3pm*
64
65%changelog
66* Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.107-1
67- initial build for Vine Linux
68
69* Sat Jan 21 2012 Paul Howarth <paul@city-fan.org> - 0.107-5
70- obsolete/provide old -tests subpackage to support upgrades
71
72* Fri Jan 20 2012 Paul Howarth <paul@city-fan.org> - 0.107-4
73- drop -tests subpackage (general lack of interest in this), but include
74  them as documentation for the main package
75- drop redundant %%{?perl_default_filter}
76- don't use macros for commands
77- can't find any dependency cycle so drop %%{?perl_bootstrap} usage
78- drop ExtUtils::MakeMaker version requirement to 6.30, actual working minimum
79
80* Wed Jan 11 2012 Paul Howarth <paul@city-fan.org> - 0.107-3
81- package LICENSE file
82- run test suite even when bootstrapping, as it should still pass
83- run release tests too
84- enhance %%description so it makes sense
85- BR: perl(Test::More)
86
87* Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.107-2
88- Perl mass rebuild
89- add perl_bootstrap macro
90
91* Wed May 11 2011 Iain Arnell <iarnell@gmail.com> 0.107-1
92- update to latest upstream version
93- clean up spec for modern rpmbuild
94
95* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.106-4
96- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
97
98* Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.106-3
99- rebuild to fix problems with vendorarch/lib (#661697)
100
101* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.106-2
102- Mass rebuild with perl-5.12.0
103
104* Mon Mar 08 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.106-1
105- update by Fedora::App::MaintainerTools 0.004
106- PERL_INSTALL_ROOT => DESTDIR
107- updating to latest GA CPAN version (0.106)
108- added a new br on perl(ExtUtils::MakeMaker) (version 6.42)
109- added a new br on perl(List::Util) (version 0)
110- altered br on perl(Sub::Install) (0.92 => 0.921)
111- added a new req on perl(List::Util) (version 0)
112- added a new req on perl(Params::Util) (version 0.14)
113- added a new req on perl(Sub::Install) (version 0.921)
114
115* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.104-4
116- rebuild against perl 5.10.1
117
118* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.104-3
119- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
120
121* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.104-2
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
123
124* Wed Feb 11 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.104-1
125- update to 0.104
126
127* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.103-2
128- Rebuild for perl 5.10 (again)
129
130* Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.103-1
131- rebuild for new perl
132- bump to 0.103
133- fix license tag
134
135* Thu Sep 07 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.101-2
136- bump
137
138* Sat Sep 02 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.101-1
139- Specfile autogenerated by cpanspec 1.69.1.
Note: See TracBrowser for help on using the repository browser.