source: projects/specs/trunk/p/perl-Data-OptList/perl-Data-OptList-vl.spec @ 12120

Revision 12120, 4.9 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-Data-OptList
2Summary:        Parse and validate simple name/value option pairs
3Version:        0.110
4Release:        1%{?_dist_release}
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/Data-OptList/
8Source0:        http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Data-OptList-%{version}.tar.gz
9BuildArch:      noarch
10BuildRequires:  perl(ExtUtils::MakeMaker)
11BuildRequires:  perl(List::Util)
12BuildRequires:  perl(Params::Util)
13#BuildRequires:  perl(Sub::Install) >= 0.921
14#BuildRequires:  perl(Test::More)
15#BuildRequires:  perl(Test::Pod)
16Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
17
18# Obsolete/provide old -tests subpackage (can be removed in F19 development cycle)
19Obsoletes:      %{name}-tests < %{version}-%{release}
20Provides:       %{name}-tests = %{version}-%{release}
21
22Vendor:         Project Vine
23Distribution:   Vine Linux
24
25%description
26Hashes are great for storing named data, but if you want more than one entry
27for a name, you have to use a list of pairs. Even then, this is really boring
28to write:
29
30$values = [
31    foo => undef,
32    bar => undef,
33    baz => undef,
34    xyz => { ... },
35];
36
37With Data::OptList, you can do this instead:
38
39$values = Data::OptList::mkopt([
40    qw(foo bar baz),
41    xyz => { ... },
42]);
43
44This works by assuming that any defined scalar is a name and any reference
45following a name is its value.
46
47%prep
48%setup -q -n Data-OptList-%{version}
49
50%build
51perl Makefile.PL INSTALLDIRS=vendor
52make %{?_smp_mflags}
53
54%install
55make pure_install DESTDIR=%{buildroot}
56find %{buildroot} -type f -name .packlist -exec rm -f {} \;
57find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
58%{_fixperms} %{buildroot}
59
60%check
61#make test RELEASE_TESTING=1
62
63%files
64%license LICENSE
65%doc Changes README t/
66%{perl_vendorlib}/Data/
67%{_mandir}/man3/Data::OptList.3pm*
68
69%changelog
70* Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.110-1
71- new upstream release.
72- rebuilt with perl-5.26.
73
74* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.109-1
75- update to 0.109-1
76
77* Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.107-1
78- initial build for Vine Linux
79
80* Sat Jan 21 2012 Paul Howarth <paul@city-fan.org> - 0.107-5
81- obsolete/provide old -tests subpackage to support upgrades
82
83* Fri Jan 20 2012 Paul Howarth <paul@city-fan.org> - 0.107-4
84- drop -tests subpackage (general lack of interest in this), but include
85  them as documentation for the main package
86- drop redundant %%{?perl_default_filter}
87- don't use macros for commands
88- can't find any dependency cycle so drop %%{?perl_bootstrap} usage
89- drop ExtUtils::MakeMaker version requirement to 6.30, actual working minimum
90
91* Wed Jan 11 2012 Paul Howarth <paul@city-fan.org> - 0.107-3
92- package LICENSE file
93- run test suite even when bootstrapping, as it should still pass
94- run release tests too
95- enhance %%description so it makes sense
96- BR: perl(Test::More)
97
98* Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.107-2
99- Perl mass rebuild
100- add perl_bootstrap macro
101
102* Wed May 11 2011 Iain Arnell <iarnell@gmail.com> 0.107-1
103- update to latest upstream version
104- clean up spec for modern rpmbuild
105
106* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.106-4
107- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
108
109* Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.106-3
110- rebuild to fix problems with vendorarch/lib (#661697)
111
112* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.106-2
113- Mass rebuild with perl-5.12.0
114
115* Mon Mar 08 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.106-1
116- update by Fedora::App::MaintainerTools 0.004
117- PERL_INSTALL_ROOT => DESTDIR
118- updating to latest GA CPAN version (0.106)
119- added a new br on perl(ExtUtils::MakeMaker) (version 6.42)
120- added a new br on perl(List::Util) (version 0)
121- altered br on perl(Sub::Install) (0.92 => 0.921)
122- added a new req on perl(List::Util) (version 0)
123- added a new req on perl(Params::Util) (version 0.14)
124- added a new req on perl(Sub::Install) (version 0.921)
125
126* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.104-4
127- rebuild against perl 5.10.1
128
129* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.104-3
130- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
131
132* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.104-2
133- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
134
135* Wed Feb 11 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.104-1
136- update to 0.104
137
138* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.103-2
139- Rebuild for perl 5.10 (again)
140
141* Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.103-1
142- rebuild for new perl
143- bump to 0.103
144- fix license tag
145
146* Thu Sep 07 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.101-2
147- bump
148
149* Sat Sep 02 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.101-1
150- Specfile autogenerated by cpanspec 1.69.1.
Note: See TracBrowser for help on using the repository browser.