source: projects/specs/trunk/p/perl-Data-OptList/perl-Data-OptList-vl.spec @ 8708

Revision 8708, 4.7 KB checked in by daisuke, 10 years ago (diff)

perl-*: rebuild with perl 5.16

  • update: Data-OptList?, Log-Dispatch,Log-Log4perl,

Package-Stash, Package-Stash-XS, Sub-Install

Line 
1Name:           perl-Data-OptList
2Summary:        Parse and validate simple name/value option pairs
3Version:        0.109
4Release:        1%{?_dist_release}
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/Data-OptList/
8Source0:        http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Data-OptList-%{version}.tar.gz
9BuildArch:      noarch
10BuildRequires:  perl(ExtUtils::MakeMaker) >= 6.30
11BuildRequires:  perl(List::Util)
12BuildRequires:  perl(Params::Util)
13#BuildRequires:  perl(Sub::Install) >= 0.921
14#BuildRequires:  perl(Test::More)
15#BuildRequires:  perl(Test::Pod)
16Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
17
18# Obsolete/provide old -tests subpackage (can be removed in F19 development cycle)
19Obsoletes:      %{name}-tests < %{version}-%{release}
20Provides:       %{name}-tests = %{version}-%{release}
21
22%description
23Hashes are great for storing named data, but if you want more than one entry
24for a name, you have to use a list of pairs. Even then, this is really boring
25to write:
26
27$values = [
28    foo => undef,
29    bar => undef,
30    baz => undef,
31    xyz => { ... },
32];
33
34With Data::OptList, you can do this instead:
35
36$values = Data::OptList::mkopt([
37    qw(foo bar baz),
38    xyz => { ... },
39]);
40
41This works by assuming that any defined scalar is a name and any reference
42following a name is its value.
43
44%prep
45%setup -q -n Data-OptList-%{version}
46
47%build
48perl Makefile.PL INSTALLDIRS=vendor
49make %{?_smp_mflags}
50
51%install
52make pure_install DESTDIR=%{buildroot}
53find %{buildroot} -type f -name .packlist -exec rm -f {} \;
54find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
55%{_fixperms} %{buildroot}
56
57%check
58#make test RELEASE_TESTING=1
59
60%files
61%doc Changes LICENSE README t/
62%{perl_vendorlib}/Data/
63%{_mandir}/man3/Data::OptList.3pm*
64
65%changelog
66* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.109-1
67- update to 0.109-1
68
69* Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.107-1
70- initial build for Vine Linux
71
72* Sat Jan 21 2012 Paul Howarth <paul@city-fan.org> - 0.107-5
73- obsolete/provide old -tests subpackage to support upgrades
74
75* Fri Jan 20 2012 Paul Howarth <paul@city-fan.org> - 0.107-4
76- drop -tests subpackage (general lack of interest in this), but include
77  them as documentation for the main package
78- drop redundant %%{?perl_default_filter}
79- don't use macros for commands
80- can't find any dependency cycle so drop %%{?perl_bootstrap} usage
81- drop ExtUtils::MakeMaker version requirement to 6.30, actual working minimum
82
83* Wed Jan 11 2012 Paul Howarth <paul@city-fan.org> - 0.107-3
84- package LICENSE file
85- run test suite even when bootstrapping, as it should still pass
86- run release tests too
87- enhance %%description so it makes sense
88- BR: perl(Test::More)
89
90* Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.107-2
91- Perl mass rebuild
92- add perl_bootstrap macro
93
94* Wed May 11 2011 Iain Arnell <iarnell@gmail.com> 0.107-1
95- update to latest upstream version
96- clean up spec for modern rpmbuild
97
98* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.106-4
99- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
100
101* Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.106-3
102- rebuild to fix problems with vendorarch/lib (#661697)
103
104* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.106-2
105- Mass rebuild with perl-5.12.0
106
107* Mon Mar 08 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.106-1
108- update by Fedora::App::MaintainerTools 0.004
109- PERL_INSTALL_ROOT => DESTDIR
110- updating to latest GA CPAN version (0.106)
111- added a new br on perl(ExtUtils::MakeMaker) (version 6.42)
112- added a new br on perl(List::Util) (version 0)
113- altered br on perl(Sub::Install) (0.92 => 0.921)
114- added a new req on perl(List::Util) (version 0)
115- added a new req on perl(Params::Util) (version 0.14)
116- added a new req on perl(Sub::Install) (version 0.921)
117
118* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.104-4
119- rebuild against perl 5.10.1
120
121* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.104-3
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
123
124* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.104-2
125- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
126
127* Wed Feb 11 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.104-1
128- update to 0.104
129
130* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.103-2
131- Rebuild for perl 5.10 (again)
132
133* Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.103-1
134- rebuild for new perl
135- bump to 0.103
136- fix license tag
137
138* Thu Sep 07 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.101-2
139- bump
140
141* Sat Sep 02 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.101-1
142- Specfile autogenerated by cpanspec 1.69.1.
Note: See TracBrowser for help on using the repository browser.