source: projects/specs/trunk/p/perl-Data-Dump/perl-Data-Dump-vl.spec @ 4916

Revision 4916, 1.7 KB checked in by yasumichi, 13 years ago (diff)

Import spec file.

Line 
1%define pkgname Data-Dump
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        1.20
6Release:        1%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/%{pkgname}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14Packager:       yasumichi
15
16Summary:        Pretty printing of data structures
17Summary(ja):    データ構造のきれいな出力
18
19# Dependency
20Requires:       perl
21Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
22
23BuildRequires:  perl
24
25%description
26This module provide a few functions that traverse their argument and
27produces a string as its result. The string contains Perl code that, when
28evaled, produces a deep copy of the original arguments.
29
30#%%description -l ja
31#ここに日本語で詳細を記述してください。
32
33%prep
34%setup -q -n Data-Dump-1.20
35
36%build
37perl Makefile.PL
38%{__make}
39
40%install
41%{__rm} -rf ${RPM_BUILD_ROOT}
42%{__make} install DESTDIR=${RPM_BUILD_ROOT}
43
44find $RPM_BUILD_ROOT%{_prefix} -type f -print |
45        sed "s@^$RPM_BUILD_ROOT@@g" |
46        grep -v ^%{_mandir} |
47        grep -v perllocal.pod |
48        grep -v "\.packlist" > %{name}.files
49if [ "$(cat %{name}.files)X" = "X" ] ; then
50        echo "ERROR: EMPTY FILE LIST"
51        exit -1
52fi
53
54# remove unnecessary files.
55%{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
56%{__rm} ${RPM_BUILD_ROOT}%{perl_sitearch}/auto/Data/Dump/.packlist
57
58
59%clean
60%{__rm} -rf ${RPM_BUILD_ROOT}
61
62
63%files -f %{name}.files
64%defattr(-,root,root)
65%doc Changes README
66%dir %{perl_sitelib}/Data/Dump
67%{_mandir}/*/*
68
69
70%changelog
71* Mon Oct 10 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.20-1
72- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.