source: projects/specs/trunk/p/perl-Data-Buffer/perl-Data-Buffer-vl.spec @ 521

Revision 521, 1.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define module  Data-Buffer
2%define name    perl-%{module}
3%define version 0.04
4%define release 1%{_dist_release}
5
6Name:           %{name}
7Version:        %{version}
8Release:        %{release}
9Summary:        Read/write buffer class
10Group:          Development/Languages
11License:        GPL or Artistic
12Url:            http://search.cpan.org/dist/%{module}/
13Source:         http://search.cpan.org/CPAN/authors/id/B/BT/BTROTT/%{module}-%{version}.tar.gz
14BuildArch:      noarch
15BuildRoot:      %{_tmppath}/%{name}-%{version}
16
17Vendor:         Project Vine
18Distribution:   Vine Linux
19
20%description
21Data::Buffer implements a low-level binary buffer in which you can get and
22put integers, strings, and other data.
23Internally the implementation is based on pack and unpack,
24such that Data::Buffer is really a layer on top of those built-in functions.
25
26%prep
27%setup -q -n %{module}-%{version}
28
29%build
30CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS="vendor" PREFIX="%{buildroot}%{_prefix}"
31%{__make}
32
33%check
34%{__make} test
35
36%install
37rm -rf %{buildroot}
38%makeinstall
39rm -f %{buildroot}%{perl_archlib}/perllocal.pod
40rm -rf %{buildroot}%{perl_vendorarch}
41
42%clean
43rm -rf %{buildroot}
44
45%files
46%defattr(-,root,root)
47%doc README Changes
48%{_mandir}/man3*/*
49%{perl_vendorlib}/Data/*
50
51%changelog
52* Fri May 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.04-1vl5
53- rebuild with perl 5.10
54- new versioning policy
55
56* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.04-0vl1
57- built for VineSeed
58
59* Sun Mar 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.04-0vl0.43
60- rebuilt to relase for VinePlus 4.2
61
62* Tue Mar 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.04-0vl0.42
63- built for Vine 4.2 (testing)
Note: See TracBrowser for help on using the repository browser.