source: projects/specs/trunk/p/perl-DBI/perl-DBI-vl.spec @ 8638

Revision 8638, 6.2 KB checked in by iwaim, 10 years ago (diff)

perl-DBI 1.618-2

Line 
1%define version 1.618
2%define release 2
3
4Summary: A database access API for perl
5Summary(ja): perl 用データベース接続 API
6Name: perl-DBI
7Version: %{version}
8Release: %{release}%{?_dist_release}
9License: Artistic
10Group: Development/Libraries
11URL:            http://dbi.perl.org/
12Source0:        http://www.cpan.org/authors/id/T/TI/TIMB/DBI-%{version}.tar.gz
13BuildRequires:  perl(ExtUtils::MakeMaker)
14# Run-time
15BuildRequires:  perl(base)
16BuildRequires:  perl(constant)
17BuildRequires:  perl(Carp)
18# Clone is optional
19BuildRequires:  perl(Clone)
20BuildRequires:  perl(Coro)
21BuildRequires:  perl(Coro::Handle)
22BuildRequires:  perl(Coro::Select)
23BuildRequires:  perl(Cwd)
24BuildRequires:  perl(Data::Dumper)
25# DB_File is optional
26BuildRequires:  perl(DB_File)
27BuildRequires:  perl(DynaLoader)
28BuildRequires:  perl(Errno)
29BuildRequires:  perl(Exporter)
30BuildRequires:  perl(Fcntl)
31BuildRequires:  perl(File::Basename)
32BuildRequires:  perl(File::Spec)
33BuildRequires:  perl(Getopt::Long)
34BuildRequires:  perl(IO::File)
35BuildRequires:  perl(IO::Select)
36BuildRequires:  perl(IPC::Open3)
37BuildRequires:  perl(Math::BigInt)
38# MLDBM is optional
39##BuildRequires:  perl(MLDBM)
40# RPC::PlClient is optional
41##BuildRequires:  perl(RPC::PlClient) >= 0.2000
42# RPC::PlServer is optional
43##BuildRequires:  perl(RPC::PlServer)
44BuildRequires:  perl(Scalar::Util)
45# SQL::Statement is optional
46BuildRequires:  perl(SQL::Statement) >= 1.28
47BuildRequires:  perl(Storable)
48BuildRequires:  perl(Symbol)
49BuildRequires:  perl(threads)
50BuildRequires:  perl(Tie::Hash)
51BuildRequires:  perl(UNIVERSAL)
52# Tests
53BuildRequires:  perl(Encode)
54BuildRequires:  perl(File::Path)
55BuildRequires:  perl(lib)
56BuildRequires:  perl(Net::Daemon::Test)
57BuildRequires:  perl(Test::More)
58BuildRequires:  perl(Test::Simple) >= 0.90
59# Optional tests
60BuildRequires:  perl(Test::Pod) >= 1.00
61BuildRequires:  perl(Test::Pod::Coverage) >= 1.04
62Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
63Requires:       perl(Math::BigInt)
64
65BuildRoot:      %{_tmppath}/%{name}-%{version}-root
66
67
68%description 
69DBI is a database access Application Programming Interface (API) for
70the Perl Language. The DBI API Specification defines a set of
71functions, variables and conventions that provide a consistent
72database interface independent of the actual database being used.
73
74%description -l ja
75DBI  Perl でデータベースにアクセスするための API です.
76DBI API では,実際に使われるデータベースに依存しない様に,
77関数,変数などの取り決めが定義されています.
78
79
80%prep
81%setup -q -n DBI-%{version} 
82iconv -f iso8859-1 -t utf-8 lib/DBD/Gofer.pm >lib/DBD/Gofer.pm.new &&
83  mv lib/DBD/Gofer.pm{.new,}
84chmod 644 ex/*
85chmod 744 dbixs_rev.pl
86sed -i 's?#!perl?#!%{__perl}?' ex/corogofer.pl
87
88
89%build
90perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
91make %{?_smp_mflags}
92
93%install
94[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
95make pure_install PERL_INSTALL_ROOT=%{buildroot}
96find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
97find %{buildroot} -type f -name '*.bs' -empty -exec rm -f {} ';'
98find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
99chmod -R u+w %{buildroot}/*
100# Remove Win32 specific files and man pages to avoid unwanted dependencies
101rm -rf %{buildroot}%{perl_vendorarch}/{Win32,DBI/W32ODBC.pm} \
102    %{buildroot}%{_mandir}/man3/{DBI::W32,Win32::DBI}ODBC.3pm
103perl -pi -e 's"#!perl -w"#!/usr/bin/perl -w"' \
104    %{buildroot}%{perl_vendorarch}/{goferperf,dbixs_rev}.pl
105
106%clean
107[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
108
109%check
110make test
111
112%files 
113%defattr(-,root,root)
114%doc Changes README  ex/
115%{perl_vendorarch}/*.p*
116%{perl_vendorarch}/Bundle/
117%{perl_vendorarch}/DBD/
118%{perl_vendorarch}/DBI/
119%{perl_vendorarch}/auto/DBI/
120%{_bindir}/*
121%{_mandir}/*/*
122
123%changelog
124* Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.618-2
125- build with Perl 5.16
126
127* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.618-1
128- updated to 1.618; spec revamped
129
130* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.604-4vl6
131- rebuild with perl 5.12.3
132- using __perl_requires macro for VineSeed (vl6)
133
134* Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.604-3
135- spec in utf-8
136
137* Thu May  1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.604-2
138- rebuilt with perl-5.10.0.
139
140* Wed Apr 23 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 1.604-1
141- new upstream release
142
143* Mon Aug 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.58-0vl1
144- new upstream release
145
146* Sun Jan 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.53-0vl1
147- new upstream release
148
149* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.51-0vl1
150- new upstream release
151- changed Group to Development/Libraries
152- installed module files to vendor_perl
153
154* Sat Jul 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.46-0vl2
155- use filter-requires-dbi.sh instead of find-requires.perl
156
157* Sat Dec 04 2004 IWAI, Masaharu <iwai@alib.jp> 1.46-0vl1
158- new upstream version
159- build on perl-5.8.6-0vl1
160
161* Sat May 22 2004 Satoshi MACHINO <machino@vinelinux.org> 1.40-0vl1
162- new upstream version
163
164* Sat May 24 2003 IWAI Masaharu <iwai@alib.jp> 1.37-0vl1
165- update 1.37
166- build with perl-5.8.0
167- add make test
168
169* Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 1.21-0vl1
170- updated 1.21
171
172* Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 1.20-0vl1
173- updated 1.20
174
175* Sat Sep 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.19-0vl2
176- the spec was in Shift-JIS. Fixed.
177
178* Fri Aug 03 2001 Satoshi MACHINO <machino@vinelinux.org> 1.19-0vl1
179- updated 1.19
180
181* Sat Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 1.15-1vl2
182- rebuild on perl-5.6.0
183- changed mandir to /usr/share/man
184- removed version in Requires perl
185
186* Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 1.15-1vl1
187- updated perl-DBL-1.15
188
189* Tue May 08 2001 Satoshi MACHINO <machino@vinelinux.org> 1.14-10vl1
190- fixed Vine Linux
191
192* Tue Feb 27 2001 Trond Eivind Glomsr <teg@redhat.com>
193- Cleanups
194
195* Thu Nov 30 2000 Trond Eivind Glomsr <teg@redhat.com>
196- build for main distribution
197- use %%{_tmppath}
198- change name of specfile
199- don't use a find script to generate file lists
200- general cleanup
201- add descriptive summary and description
202
203
204* Mon Aug 14 2000 Tim Powers <timp@redhat.com>
205- Spec file was autogenerated. 
Note: See TracBrowser for help on using the repository browser.