source: projects/specs/trunk/p/perl-DBI/perl-DBI-vl.spec @ 9141

Revision 9141, 6.2 KB checked in by inagaki, 9 years ago (diff)

2014-12-07 Ryoichi INAGAKI <ryo1@…>

  • perl-DBD-CSV, perl-DBI, perl-Gtk2, perl-Mixin-Linewise, perl-SQL-Statement: updated
  • perl-Gtk2-Unique, perl-Module-Refresh: rebuilt
  • perl-HTML-Tree, perl-Pango, perl-PerlIO-utf8_strict: NEW
Line 
1%define version 1.632
2%define release 1
3
4Summary: A database access API for perl
5Summary(ja): perl 用データベース接続 API
6Name: perl-DBI
7Version: %{version}
8Release: %{release}%{?_dist_release}
9License: GPL or Artistic
10Group: Development/Libraries
11URL:            http://dbi.perl.org/
12Source0:        http://www.cpan.org/authors/id/T/TI/TIMB/DBI-%{version}.tar.gz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  perl(ExtUtils::MakeMaker)
16# Run-time
17BuildRequires:  perl(base)
18BuildRequires:  perl(constant)
19BuildRequires:  perl(Carp)
20# Clone is optional
21BuildRequires:  perl(Clone)
22BuildRequires:  perl(Coro)
23BuildRequires:  perl(Coro::Handle)
24BuildRequires:  perl(Coro::Select)
25BuildRequires:  perl(Cwd)
26BuildRequires:  perl(Data::Dumper)
27# DB_File is optional
28BuildRequires:  perl(DB_File)
29BuildRequires:  perl(DynaLoader)
30BuildRequires:  perl(Errno)
31BuildRequires:  perl(Exporter)
32BuildRequires:  perl(Fcntl)
33BuildRequires:  perl(File::Basename)
34BuildRequires:  perl(File::Spec)
35BuildRequires:  perl(Getopt::Long)
36BuildRequires:  perl(IO::File)
37BuildRequires:  perl(IO::Select)
38BuildRequires:  perl(IPC::Open3)
39BuildRequires:  perl(Math::BigInt)
40# MLDBM is optional
41##BuildRequires:  perl(MLDBM)
42# RPC::PlClient is optional
43##BuildRequires:  perl(RPC::PlClient) >= 0.2000
44# RPC::PlServer is optional
45##BuildRequires:  perl(RPC::PlServer)
46BuildRequires:  perl(Scalar::Util)
47# SQL::Statement is optional
48BuildRequires:  perl(SQL::Statement) > 1.33
49BuildRequires:  perl(Storable)
50BuildRequires:  perl(Symbol)
51BuildRequires:  perl(threads)
52BuildRequires:  perl(Tie::Hash)
53BuildRequires:  perl(UNIVERSAL)
54# Tests
55BuildRequires:  perl(Encode)
56BuildRequires:  perl(File::Path)
57BuildRequires:  perl(lib)
58BuildRequires:  perl(Net::Daemon::Test)
59BuildRequires:  perl(Test::More)
60BuildRequires:  perl(Test::Simple) >= 0.90
61# Optional tests
62BuildRequires:  perl(Test::Pod) >= 1.00
63BuildRequires:  perl(Test::Pod::Coverage) >= 1.04
64Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
65Requires:       perl(Math::BigInt)
66
67
68%description 
69DBI is a database access Application Programming Interface (API) for
70the Perl Language. The DBI API Specification defines a set of
71functions, variables and conventions that provide a consistent
72database interface independent of the actual database being used.
73
74%description -l ja
75DBI  Perl でデータベースにアクセスするための API です.
76DBI API では,実際に使われるデータベースに依存しない様に,
77関数,変数などの取り決めが定義されています.
78
79
80%prep
81%setup -q -n DBI-%{version} 
82iconv -f iso8859-1 -t utf-8 lib/DBD/Gofer.pm >lib/DBD/Gofer.pm.new &&
83  mv lib/DBD/Gofer.pm{.new,}
84chmod 644 ex/*
85chmod 744 dbixs_rev.pl
86sed -i 's?#!perl?#!%{__perl}?' ex/corogofer.pl
87
88
89%build
90perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
91make %{?_smp_mflags}
92
93%install
94[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
95make pure_install PERL_INSTALL_ROOT=%{buildroot}
96find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
97find %{buildroot} -type f -name '*.bs' -empty -exec rm -f {} ';'
98find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
99chmod -R u+w %{buildroot}/*
100# Remove Win32 specific files and man pages to avoid unwanted dependencies
101rm -rf %{buildroot}%{perl_vendorarch}/{Win32,DBI/W32ODBC.pm} \
102    %{buildroot}%{_mandir}/man3/{DBI::W32,Win32::DBI}ODBC.3pm
103perl -pi -e 's"#!perl -w"#!/usr/bin/perl -w"' \
104    %{buildroot}%{perl_vendorarch}/{goferperf,dbixs_rev}.pl
105
106%clean
107[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
108
109%check
110make test
111
112%files 
113%defattr(-,root,root)
114%doc Changes README.md  ex/
115%{perl_vendorarch}/*.p*
116%{perl_vendorarch}/Bundle/
117%{perl_vendorarch}/DBD/
118%{perl_vendorarch}/DBI/
119%{perl_vendorarch}/auto/DBI/
120%{_bindir}/*
121%{_mandir}/*/*
122
123%changelog
124* Fri Dec  5 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.632-1
125- updated to 1.632
126
127* Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.618-2
128- build with Perl 5.16
129
130* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.618-1
131- updated to 1.618; spec revamped
132
133* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.604-4vl6
134- rebuild with perl 5.12.3
135- using __perl_requires macro for VineSeed (vl6)
136
137* Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.604-3
138- spec in utf-8
139
140* Thu May  1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.604-2
141- rebuilt with perl-5.10.0.
142
143* Wed Apr 23 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 1.604-1
144- new upstream release
145
146* Mon Aug 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.58-0vl1
147- new upstream release
148
149* Sun Jan 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.53-0vl1
150- new upstream release
151
152* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.51-0vl1
153- new upstream release
154- changed Group to Development/Libraries
155- installed module files to vendor_perl
156
157* Sat Jul 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.46-0vl2
158- use filter-requires-dbi.sh instead of find-requires.perl
159
160* Sat Dec 04 2004 IWAI, Masaharu <iwai@alib.jp> 1.46-0vl1
161- new upstream version
162- build on perl-5.8.6-0vl1
163
164* Sat May 22 2004 Satoshi MACHINO <machino@vinelinux.org> 1.40-0vl1
165- new upstream version
166
167* Sat May 24 2003 IWAI Masaharu <iwai@alib.jp> 1.37-0vl1
168- update 1.37
169- build with perl-5.8.0
170- add make test
171
172* Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 1.21-0vl1
173- updated 1.21
174
175* Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 1.20-0vl1
176- updated 1.20
177
178* Sat Sep 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.19-0vl2
179- the spec was in Shift-JIS. Fixed.
180
181* Fri Aug 03 2001 Satoshi MACHINO <machino@vinelinux.org> 1.19-0vl1
182- updated 1.19
183
184* Sat Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 1.15-1vl2
185- rebuild on perl-5.6.0
186- changed mandir to /usr/share/man
187- removed version in Requires perl
188
189* Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 1.15-1vl1
190- updated perl-DBL-1.15
191
192* Tue May 08 2001 Satoshi MACHINO <machino@vinelinux.org> 1.14-10vl1
193- fixed Vine Linux
194
195* Tue Feb 27 2001 Trond Eivind Glomsr <teg@redhat.com>
196- Cleanups
197
198* Thu Nov 30 2000 Trond Eivind Glomsr <teg@redhat.com>
199- build for main distribution
200- use %%{_tmppath}
201- change name of specfile
202- don't use a find script to generate file lists
203- general cleanup
204- add descriptive summary and description
205
206
207* Mon Aug 14 2000 Tim Powers <timp@redhat.com>
208- Spec file was autogenerated. 
Note: See TracBrowser for help on using the repository browser.