source: projects/specs/trunk/p/perl-DBD-Pg/perl-DBD-Pg-vl.spec @ 521

Revision 521, 2.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: the DBI PostgreSQL interface for Perl
2Name: perl-DBD-Pg
3Version: 1.49
4Release: 5%{?_dist_release}
5License: GPL or Artistic
6Group: Development/Libraries
7Source0: http://search.cpan.org/CPAN/authors/id/D/DB/DBDPG/DBD-Pg-%{version}.tar.gz
8Patch0:perl-DBD-1.31-fixver.patch
9Patch1:perl-DBD-Pg-CVE-2009-0663+1341.patch
10
11Url: http://search.cpan.org/author/DWHEELER/DBD-Pg/
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: perl >= 5.004, postgresql-devel, perl-DBI
14Requires: perl >= 5.004
15
16%description
17the DBI PostgreSQL interface for Perl
18
19%prep
20%setup -q -n DBD-Pg-%{version}
21
22%patch0 -p1 -b .fixver
23%patch1 -p1 -b .CVE-2009-0663+1341
24
25%build
26export POSTGRES_INCLUDE=%{_includedir}/pgsql
27export POSTGRES_LIB=%{_libdir}
28CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
29make
30
31%check
32make test
33
34%clean
35rm -rf %{buildroot}
36
37%install
38rm -rf %{buildroot}
39#mkdir -p %{buildroot}%{_prefix}
40#make INSTALLSITEARCH=%{buildroot}%{perl_sitearch} \
41#     INSTALLSITEMAN3DIR=%{buildroot}%{_mandir}/man3  \
42#     install
43
44make DESTDIR=$RPM_BUILD_ROOT install
45
46find %{buildroot}%{_prefix} -type f -print |
47        sed "s@^%{buildroot}@@g" |
48        grep -v ^%{_mandir} |
49        grep -v perllocal.pod |
50        grep -v "\.packlist" > %{name}.files
51if [ "$(cat %{name}.files)X" = "X" ] ; then
52    echo "ERROR: EMPTY FILE LIST"
53    exit -1
54fi
55
56%files -f %{name}.files
57%defattr(-,root,root)
58%doc README Changes
59%dir %{perl_vendorarch}/DBD
60%dir %{perl_vendorarch}/auto/DBD
61%dir %{perl_vendorarch}/auto/DBD/Pg
62%{_mandir}/*/*
63
64%changelog
65* Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.49-5
66- rebuilt with postgresql-8.4.0
67
68* Sat May 16 2009 Satoshi IWMAOTO <satoshi.iwamoto@nifty.ne.jp> 1.49-4vl5
69- add patch0 from rhel5
70- add patch1 to fix CVE-2009-0663, 1341
71- 2vl5,3vl5 are skipped to Plus < Seed version number...
72
73* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 1.49-1vl5
74- applied new versioning policy
75- rebuilt with postgresql-8.3.3
76
77* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 1.49-0vl5
78- rebuilt with postgresql-8.2.6
79
80* Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 1.49-0vl4
81- rebuilt with postgresql-8.2.5
82
83* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.49-0vl1
84- new upstream release
85- rebuilt with perl-5.8.6, perl-DBI-1.51
86- changed Group to Development/Libraries
87- installed files to vendor_perl
88
89* Mon Jan 10 2005 Satoshi MACHINO <machino@vinelinux.org> 1.22-0vl3
90- rebuilt for VineSeed
91        -- built with perl-5.8.6, perl-DBI-1.46
92
93* Mon Jan 10 2005 Satoshi MACHINO <machino@vinelinux.org> 1.22-0vl2
94- rebuilt for VineLinux-3.1
95        -- built with perl-5.8.2, perl-DBI-1.46
96
97* Sat May 24 2003 IWAI Masaharu <iwai@alib.jp> 1.22-0vl1
98- first build for Vine Linux
99
Note: See TracBrowser for help on using the repository browser.