source: projects/specs/trunk/p/perl-DBD-MySQL/perl-DBD-MySQL-vl.spec @ 12120

Revision 12120, 4.1 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1%define version 4.050
2%define release 1
3
4Summary:       A MySQL interface for perl
5Summary(ja):   MySQL用のperlインターフェイス
6Name:          perl-DBD-MySQL
7Version:       %{version}
8Release:       %{release}%{?_dist_release}
9License:       GPL+ or Artistic
10Group:         Development/Libraries
11Source:        DBD-mysql-%{version}.tar.gz
12Source1:       filter-requires-dbdmysql.sh
13URL:           http://search.cpan.org/dist/DBD-mysql/
14BuildRoot:     %{_tmppath}/%{name}-%{version}-root
15BuildRequires: libmariadb-devel
16BuildRequires: perl(ExtUtils::MakeMaker)
17BuildRequires: perl(DynaLoader)
18BuildRequires: perl(DBI)
19BuildRequires: perl(Devel::CheckLib)
20BuildRequires: zlib-devel
21Requires:      perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
22Requires:      perl-DBI
23
24
25%description
26An implementation of DBI for MySQL for Perl.
27
28%description -l ja
29perlを使ったMySQL用のDBI
30
31# Provide perl-specific find-{provides,requires}.
32#define __find_provides /usr/lib/rpm/find-provides.perl
33#define __find_requires /usr/lib/rpm/find-requires.perl
34%define __perl_requires %{SOURCE1}
35
36
37%prep
38%setup -q -n DBD-mysql-%{version}
39# Correct file permissions
40find . -type f -exec chmod -x {} ';'
41
42%build
43# CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor --testhost=localhost
44CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor --ssl
45make OPTIMIZE="$RPM_OPT_FLAGS"
46
47%install
48[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
49make DESTDIR=%{buildroot} pure_install
50find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
51find %{buildroot} -type f -name '*.bs' -empty -exec rm -f {} ';'
52find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
53chmod -R u+w %{buildroot}/*
54
55%check || :
56# Full test coverage requires a live MySQL database
57# make test
58
59%clean
60[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
61
62
63%files
64%defattr(-,root,root)
65%doc README ChangeLog TODO
66%{perl_vendorarch}/*
67%{_mandir}/*/*
68
69
70%changelog
71* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.050-1
72- new upstream release.
73- rebuilt with perl-5.26.
74
75* Tue Jul  1 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.027-1
76- new upstream release.
77
78* Thu Mar 08 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.020-1
79- updated to 4.020-1
80
81* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.006-5
82- rebuild with perl-5.12.3
83
84* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.006-4
85- rebuilt with MySQL-5.1.34.
86
87* Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 4.006-3
88- spec in utf-8
89
90* Thu May  1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.006-2
91- rebuilt with perl-5.10.0.
92
93* Wed Apr 23 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 4.006-1
94- new upstream release
95- add missing changelog: 4.001-0vl1
96
97* Sun Feb  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.001-0vl1
98- updated to 4.001
99
100* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.0007-0vl1
101- updated to 3.0007
102- changed Group to Development/Libraries
103- installed files to vendor_perl
104
105* Mon Jan 10 2005 Satoshi MACHINO <machino@vinelinux.org> 2.9004-0vl1
106- new upstream version(DBD-mysql-2.9004)
107- fixed spec file
108        -- used rpm macros
109        -- fixed package's dependencies
110        -- built with perl-5.8.6, MySQL-4.0.21, perl-DBI-1.46
111
112* Tue Oct 12 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2219-0vl2
113- rebuilt with perl-5.8.2 and MySQL-4.0.21
114
115* Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 1.2219-0vl1
116- updated Msql-Mysql-modules-1.2219
117
118* Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 1.2216-1vl4
119- added BuildRequires: perl >= 1:5.6.0, perl-DBI >= 1.15, zlib-devel
120
121* Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
122- rebuilt with perl-5.6.1
123- Spec was written in Shift_JIS. Fixed.
124- modified %%files section
125
126* Fri Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 1.2216-1vl2
127- rebuild on perl-5.6.0
128- removed perl version in Requires
129- changed mandir to /usr/share/man
130
131* Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 1.2216-1vl1
132- build on Vine Linux
133
134* Tue May  1 2001 Trond Eivind Glomsr <teg@redhat.com>
135- 1.2216
136- Add doc files
137- Minor cleanups
138
139* Thu Nov 30 2000 Trond Eivind Glomsr <teg@redhat.com>
140- First cut
Note: See TracBrowser for help on using the repository browser.