source: projects/specs/trunk/p/perl-DBD-CSV/perl-DBD-CSV-vl.spec @ 5803

Revision 5803, 2.6 KB checked in by shaolin, 12 years ago (diff)
  • new packages (and a few updates)
Line 
1%define perl_vendorlib    %(eval "`perl -V:installvendorlib`"; echo $installvendorlib)
2%define perl_vendorarch    %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
3
4# Provide perl-specific find-{provides,requires}.
5%define __find_provides /usr/lib/rpm/find-provides.perl
6%define __find_requires /usr/lib/rpm/find-requires.perl
7
8Summary: DBD-CSV module for perl
9Name: perl-DBD-CSV
10Version: 0.33
11Release: 1%{?_dist_release}
12License: distributable
13Group: Development/Libraries
14Source0: http://www.cpan.org/authors/id/J/JZ/JZUCKER/DBD-CSV-%{version}.tgz
15URL: http://search.cpan.org/~jzucker/DBD-CSV/
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildArch: noarch
18#BuildRequires:  perl(DBD::File) >= 0.40
19BuildRequires:  perl(DBI) >= 1.614
20BuildRequires:  perl(ExtUtils::MakeMaker)
21BuildRequires:  perl(SQL::Statement) >= 1.33
22BuildRequires:  perl(Text::CSV_XS) >= 0.71
23BuildRequires:  perl(Test::Harness)
24# BuildRequires >= 0.90, but 0.98 is recommended
25#BuildRequires: perl(Test::More) >= 0.98
26BuildRequires:  perl(Test::More) >= 0.94
27Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
28Requires:       perl(DBD::File) >= 0.40
29Requires:       perl(DBI) >= 1.614
30Requires:       perl(SQL::Statement) >= 1.31
31# Requires >= 0.71, but 0.83 is recommended
32Requires:       perl(Text::CSV_XS) >= 0.71
33
34
35%description
36DBD-CSV module for perl
37
38%prep
39%setup -q -n DBD-CSV-%{version}
40
41%build
42%{__perl} Makefile.PL INSTALLDIRS=vendor
43make %{?_smp_mflags}
44
45%check
46make test
47
48%clean
49rm -rf %{buildroot}
50
51%install
52rm -rf %{buildroot}
53make pure_install DESTDIR=%{buildroot}
54find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
55find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
56chmod -R u+w %{buildroot}/*
57
58%files
59%defattr(-,root,root)
60%doc README ChangeLog
61%dir %{perl_vendorlib}/Bundle/DBD
62%dir %{perl_vendorlib}/DBD
63%{perl_vendorlib}/Bundle/DBD/*.pm
64%{perl_vendorlib}/DBD/*.pm
65%{_mandir}/*/*
66
67%changelog
68* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.33-1
69- updated to 0.33; spec revamped
70
71* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22-2
72- rebuild with perl-5.12.3
73
74* Mon May 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.22-1
75- applied new versioning policy
76
77* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.22-0vl2
78- changed Group to Development/Libraries
79- s/Copyright/License/
80
81* Thu Sep  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.22-0vl1
82- updated to 0.22
83- added BuildRequires: perl-DBI
84- rebuild with perl 5.8.6
85- use vendor_perl dir
86
87* Sat Apr 13 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.2002-0vl1
88- first build for Vine Linux
Note: See TracBrowser for help on using the repository browser.